none
Publish XEN Desktop via UAG - Cookies Issue

    Question

  • Hi,

     

    We've got a UAG array v4.0.1752.10000.


    I'm trying to publish access to our XEN DESKTOP (note not XEN APP) and have encountered a problem where it says the following in the browser when I try to access it:

    -----------------------------------------------------------------------------------------------------------------------

    Cookies Required

    This Web site uses cookies to deliver your resources.

    You must configure your browser to accept cookies. Contact your system administrator for assistance.

    -----------------------------------------------------------------------------------------------------------------------

    I used the XEN APP application option when publishing it.

    I've checked all of the XEN APP stuff and have successfully published XEN APP items to the portal without an issue. The XML file is as other threads mention. Is there something I need to do to the XML file to get around this problem?

    The XEN DESKTOP URL is http://servername/Citrix/DesktopWeb/auth/login.aspx

    Anyone got any ideas on where I might be going wrong? I've had a look on the web but can't see much relating to publishing XEN Desktop on UAG.

    Friday, May 20, 2011 11:00 AM

Answers

All replies

  • Hi,

    I don't have a XEN Desktop application to test for myself, but from your description it seems that there is some client side code that checks for the existence of a specific cookie. And, apparently, that cookie is not found, therefore you receive the "Cookies Required" page that you mentioned. I assume that the cookie is not found, or to be more exact, is not recognized on the client side, since UAG, by default, modifies Set-Cookie headers sent through it, and changes either the cookie name or the cookie value.

    So you would probably have to find two pieces of information:

    a) the client side code that verifies for the existence of that cookie, in order for you to understand what cookie is it looking for

    b) the modified Set-Cookie header that is actually received by the browser

    Once you have these two, you would probably have to create a custom AppWrap file to change the client side code, so that it will find the cookie as it is sent through UAG. You can maybe get a few pointers on how to do this from this UAG Team Blog article: How to publish Citrix XenApp 5.x with UAG 2010. More information about UAG's AppWrap mechanism is discussed here: AppWrap and SRA.

     

    Regards,


    -Ran
    Monday, May 23, 2011 7:47 AM
  • We recently had a similar issue when trying to publish XEN DESKTOP with UAG (btw, it can be published successfully).

    Our solution for this particular issue was found in the following vendor KB article:

    http://support.citrix.com/article/CTX117597

    • Marked as answer by Mahilu Tuesday, May 24, 2011 11:38 AM
    Monday, May 23, 2011 10:44 AM
  • Thanks for the info,

    Modifying the XEN DESKTOP source code, as mentioned in that Citrix KB article, would definitely be the easiest solution!  :)

    Regards,


    -Ran
    Monday, May 23, 2011 10:59 AM
  • What a great solution, just reconfigure Citrix to remove the additional cookie security feature...nice ;)
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Monday, May 23, 2011 4:29 PM
  • This did the trick however for further info the Xen Desktop we are running v 5.4 just goes into a loop. It does work though with v5.3 as per the following:

    http://social.technet.microsoft.com/Forums/en-US/forefrontedgeiag/thread/20aa3cf8-3bc6-418f-84d3-ee10aa689ac3

    Thanks for your help on this.

    Tuesday, May 24, 2011 11:40 AM
  • Benjies,

     

    How did you successfully manage to publish this? In the application settings I put in the web server for the URL and under the Server Settings I entered the name of our Citrix Farm servers.


    When I attempt to launch the desktop I get an SSL Application Tunneling message saying A request to access the resource was denied.

     

    Web monitor tells me it's 10.143.2.10 on ports 1494 and 2598 which it can't access and this is the IP of the virtual desktop. I added this IP and others which are in the range being used by these machines to the Server Settings tab but it doesn't work.

     

    Any advice you can give me would be great.

    Thanks 

    Tuesday, May 24, 2011 1:19 PM