none
Agent Incoming / Outgoing Errors

    Pregunta

  • Hello,

    I am getting lots and lots of erros with the following in Operations Console of FCS...

    Description:

    The Agent outgoing data processing has been blocked. This indicates problems with communication or database processing.
    Management Group: ForefrontClientSecurity

    Description:

    The Agent incoming queue data submission has been blocked. This may indicate that queue does not have sufficient space or is unavailable to accept data.
    Management Group: ForefrontClientSecurity

    Does anyone know why I am getting so many of these? I am trying to make the server as efficient as I can however I have lots of these amongst other errors which I am looking at.

    Many Thanks

    James

    lunes, 11 de julio de 2011 9:48

Todas las respuestas

  • Hi,

    Look the solution for event IDs 21268 and 21269 here http://technet.microsoft.com/en-us/library/bb643195.aspx

    And in plus this hotfix http://support.microsoft.com/kb/906858


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/ | Time zone : GMT+1
    miércoles, 13 de julio de 2011 7:16
  • Hello,

    Thanks for the response.

    I have applied the patch and upped the temp storage to 2GB so hopefully it will sort out them issues. Will it also sort out the Outgoing Data Processing errors? As the Outgoing Queue's are full...

    Many Thanks

    James

    miércoles, 13 de julio de 2011 8:14
  • Hello,

    I am still getting lots of these errors for both incoming and outgoing queues being full does anyone know why?

    Many Thanks

    James

    jueves, 04 de agosto de 2011 9:08
  • Hi James,

    Please perform these steps to troubleshooting:
    1. Based on Bechir post url, you have set agent's queue size over 6MB and MOM server's incoming queue size over 100 MB?
    2. Patch hotfix KB904944
    3. Add MOM file location to FCS scan exclusions on server
       C:\Documents and Settings\All Users\Application Data\Microsoft\Microsoft Operations Manager\FroefrontClientSecurity
    4. If the server still receives the errors, purge MOM cache files like below:
      a. Stop MOM service
      b. Delete all files in folder
         C:\Documents and Settings\All Users\Application Data\Microsoft\Microsoft Operations Manager\FroefrontClientSecurity
      c. Start MOM service
      d. Verify MOM cache file will recreate in the folder
      e. Check if you receive the MOM event log error

    If there are more inquiries on this issue, please feel free to let us know.


    Regards,
    Rick Tan
    lunes, 08 de agosto de 2011 7:11
  • Where do I set the servers queue size? and then I will have a check...

    The agents Communication Packet size is: 1000KB

    The Temp storage is 102400KB

    I have applied the patch you have suggested and added the mom file locations to the server.

    I will leave the rest of your instructions for now until I can confirm the top part... If you need me to let me know and I will do the additional.

    Many Thanks

    James

     

    miércoles, 10 de agosto de 2011 12:20
  • Hi James,

    Server outgoing data processing has been blocked with event ID 22061

    Solution:To adjust the MOM server's incoming queue size
    1.On the management server, open the MOM Administrator console.
    2.In the tree, expand Administration and click Global Settings.
    3.In the details pane, double-click Management Servers and click the Temporary Storage tab.
    4.Enter a new value (100000KB) in the Maximum disk space field and click OK


    Regards,
    Rick Tan
    jueves, 11 de agosto de 2011 5:26
  • Hello,

    Thanks for that I have already got the above setting set so does it need to be higher than that?

    Many Thanks

    James

    viernes, 12 de agosto de 2011 9:16
  • Hi James,

    It's up to you.

    BTW, have your setup Management Servers HeartBeat interval from 601 to 602?

    MOM agent properties cannot be modified
    To enable agent configuration changes
    1.On the management server, open the MOM Administrator console.
    2.In the tree, expand Administration and click Global Settings.
    3.In the details pane, double-click Management Servers and click the Heartbeat Checking tab.
    4.In the Interval to scan for agent heartbeats box, enter 602 and click OK.


    Regards,
    Rick Tan
    viernes, 12 de agosto de 2011 9:31
  • Hello,

    Yes I have indeed changed it to 602.

    So do you think it would stop the alerts if I did or do you think its something else which is causing it do give all the alerts?

    Many Thanks

    James

    lunes, 15 de agosto de 2011 8:15
  • Hi James,

    I wish it will work or you need to try other suggestions I pervious mentioned.


    Regards,
    Rick Tan
    martes, 16 de agosto de 2011 2:08
  • Hello,

    I have thrown another 0 on the end for testing and see what happens.

    I will let you know in a few days time whats happening.

    Many Thanks

    James

    miércoles, 17 de agosto de 2011 8:24
  • I have the same problem in the incoming queue size for the agents, are you able to resolve it..

    I have found the following article regarding event IDs 21268 and 21269, maybe this would help you

    http://technet.microsoft.com/en-us/library/bb643195.aspx#Queue

    i have done these changes and i will update yo if that resolves my problem.

     

    jueves, 10 de noviembre de 2011 8:31
  • Did this resolve your issue?

    Many Thanks

    James

    miércoles, 15 de febrero de 2012 15:44
  • for me no it didnt
    domingo, 19 de febrero de 2012 9:38
  • Me either...

    I wonder if its something which needs to be patched on the server or the clients or both....

    lunes, 20 de febrero de 2012 14:10
  • Hello,

    Does anyone have any suggestions on this as I am still experiencing the issues lots and lots of errors coming up for lots of PC's and I can get rid of the errors.

    If anyone has any other suggestions they would be greatly appreciated.

    James

    viernes, 18 de mayo de 2012 7:59