none
Edit Cookie attribute not working

    Pergunta

  • Hi,

    In an application using multiple web servers, there are differences in Cookie content.
    The cookie difference gives issues with closing sessions on the (SAP) backend server.

    Here is an example from Fiddler:

    Set-Cookie: SAPWP_active=1; Domain=lo.intern; Path=/

    Server: Microsoft-IIS/6.0

    Set-cookie: NLSessionSTrunkname=iKHjPlkGU3awDWtkvG9UrFFpsNiGRmkH7RgWtMvkJrXIuDrl8wq

    The "Domain=lo.intern" has to be "Domain=example.com". Tried several Cookie Handling actions like even deleting the SAPWP_active cookie, but nothing changes. I use the SRA file to try to change content (or delete the cookie).

    <WHLFILTSECUREREMOTE ver="2.2"> 

    Anyway, i dont want to delete. I just want the cookie to be set to another value. Could somebody point me in the right direction?


    <COOKIES_HANDLING> 
    <SERVER> 
    <APPLICATION_TYPE>SAP</APPLICATION_TYPE> 
    <Set-Cookie remove="true"> 
    <NAME>SAPWP_active</NAME> 
    </Set-Cookie> 
    </SERVER> 
    </COOKIES_HANDLING> 
    </WHLFILTSECUREREMOTE>
    sexta-feira, 1 de março de 2013 12:49

Todas as Respostas

  • Hi ,

    You need to remove only the domain attribute from the cookie and not the cookie itself, should be something similar to:

    <WHLFILTSECUREREMOTE ver="2.2">

    <COOKIES_HANDLING> 
    <SERVER> 
    <APPLICATION_TYPE>SAP</APPLICATION_TYPE> 
    <Set-Cookie>
    <NAME>SAPWP_active</NAME>

    <Domain remove="true">io.intern</Domain>    
    </Set-Cookie> 
    </SERVER> 
    </COOKIES_HANDLING> 
    </WHLFILTSECUREREMOTE>

                
    HTH,

               Ophir.

    sexta-feira, 8 de março de 2013 08:48