locked
Error Installing 1603

    Întrebare

  •  

    I've been trying to install Forefront client security but it continues to fails. Here's the log:

     

    Number of verifications started: [3/17/2008 9:10:09 AM]

    [3/17/2008 9:10:10 AM] Verification(Verifying operating system requirements)


    [3/17/2008 9:10:10 AM] Verification(Verifying hardware requirements)
    Warning: Having two or more processors is recommended for the specified component(s).  Recommended processor speed (in MHz): 2850
    Warning: More RAM is recommended for the specified component(s).  Recommended RAM (in MB): 2048
    Warning:  More disk space is recommended for the specified component(s).  Recommended available disk space on drive D (in MB): 113152

    [3/17/2008 9:10:11 AM] Verification(Verifying software prerequisites)


    [3/17/2008 9:10:11 AM] Verification(Verifying collection database)


    [3/17/2008 9:10:12 AM] Verification(Verifying access to collection server)


    [3/17/2008 9:10:12 AM] Verification(Verifying DAS account)


    [3/17/2008 9:10:12 AM] Verification(Verifying access to reporting server)


    [3/17/2008 9:10:13 AM] Verification(Verifying reporting database configuration)


    [3/17/2008 9:10:13 AM] Verification(Verifying URLs for reports)


    [3/17/2008 9:10:14 AM] Verification(Verifying action account)


    [3/17/2008 9:10:14 AM] Verification(Verifying DAS account)


    [3/17/2008 9:10:15 AM] Verification(Verifying DTS account)


    [3/17/2008 9:10:15 AM] Verification(Verifying reporting database service startup)

    Number of verifications completed: [3/17/2008 9:10:15 AM]
    Tasks started: [3/17/2008 9:10:18 AM]
    Root Directory: E:\server
    Current Directory: E:\AUTORUN
    [3/17/2008 9:10:18 AM] Task(Install the Collection Database)
    Installing from this MSI: 'e:\Server\MOMServer.msi'
    Log file: 'D:\Program Files\Microsoft Forefront\Client Security\Server\Logs\MOMDB.log'.
    [3/17/2008 9:10:18 AM] Task(Install the Collection Database)
    Starting Install the Collection Database.
    [3/17/2008 9:10:18 AM] Task(Install the Collection Database)
    Starting C:\WINDOWS\system32\msiexec.exe.
    [3/17/2008 9:10:18 AM] Task(Install the Collection Database)
    Process command 'C:\WINDOWS\system32\msiexec.exe'
    [3/17/2008 9:10:18 AM] Task(Install the Collection Database)
    Process arguments '/i "e:\Server\MOMServer.msi" /norestart /qn /l*v "D:\Program Files\Microsoft Forefront\Client Security\Server\Logs\MOMDB.log" INSTALLDIR="D:\Program Files\Microsoft Forefront\Client Security\Server\Microsoft Operations Manager 2005" ADDLOCAL="MOMXDB" MOM_SERVER="SERVER" SQLSVR_INSTANCE="SERVER" DAS_ACCOUNT="FOREFRONTACCOUNT" DAS_PASSWORD="*****" DAS_DOMAIN="DOMAIN" DB_SIZE="15360" CONFIG_GROUP="ForefrontClientSecurity" '
    [3/17/2008 9:10:38 AM] Task(Install the Collection Database)

    [3/17/2008 9:10:38 AM] Task(Install the Collection Database)
    The following process failed.
    Process: C:\WINDOWS\system32\msiexec.exe
    Exit code: 1603Number of tasks completed: [3/17/2008 9:10:38 AM]

     

    I have the momdb.log but it's 342KB. I modified the domain name above to be anonymous. Any help would be much appreciated.

     

    This installation is with a new Open Value agreement. So far I haven't found that I qualify for any support from Microsoft. Is this true or am I missing something?

    17 martie 2008 16:22

Toate mesajele

  • Hi,

     

    It looks like the initial pre-req's have passed OK, so we would need to see the relevant section of the momdb.log file

     

    See if you can find the section with the errors, and post just before and after and I'm sure we can take a look

     

    cheers

    Chris

     

    17 martie 2008 17:30
  • Here's the two main parts with error codes

     

    MSI (s) (0C:B0) [09:10:34:822]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI40F.tmp, Entrypoint: VerifyPreRequisites
    MSI (s) (0C!9C) [09:10:36:134]: Note: 1: 2711 2: MOMReporting
    Action start 9:10:34: _VerifyPreRequisites.
    GetMsiFeatureState: Failed to get feature state. Error Code: 0x80070646. MOMReporting
    VerifyPreRequisites: SourceDir Property: .
    VerifyPreRequisites: Report Directory: . C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp
    Feature States:
    MOMDB: InstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_LOCAL
    MOMCONSOLE: InstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_UNKNOWN
    MOMSERVER: InstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_UNKNOWN
    MOMREPORTING: InstallState: INSTALLSTATE_UNKNOWN, ActionState: INSTALLSTATE_UNKNOWN
    MCF: InstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_UNKNOWN
    MMPC: InstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_UNKNOWN
    Unknown MOM componentInstallState: INSTALLSTATE_ABSENT, ActionState: INSTALLSTATE_UNKNOWN
    Install Flags: 1
    CPreReqUtil::LoadPropertyString: MsiViewFetch failed. HRESULT = -2147024637
    LoadPropertyString failedfailed: hr: -2147024637
    CPreReqVerifier::CheckMOMComponentVersion: Open key failed. HRESULT = -2147024894 SOFTWARE\Mission Critical Software\OnePoint\Configurations\Default\McsApplications\Operations Manager\Install
    CPreReqVerifier::Checkfailed: hr: -2147024894
    CPreReqVerifier::CheckSp1Agent: Open key failed. HRESULT = -2147024894 SOFTWARE\Mission Critical Software\OnePoint
    CPreReqVerifier::ExclusiveChecksfailed: hr: -2147024894
    CPreReqVerifier::CheckInstallDir: Open key failed. HRESULT = -2147024894 SOFTWARE\Microsoft\Microsoft Operations Manager\2.0\Setup
    CPreReqVerifier::ExclusiveChecksfailed: hr: -2147024894
    CPreReqVerifier::CheckSQLInstances: InstalledInstances. HRESULT = 0 SBSMONITORING
    VerifySQLVersion: Current Version: . HRESULT = 0 8.00.194
    VerifySQLVersion: CSD Version: . HRESULT = 0 8.00.761
    CService::Init: QueryService. HRESULT = 0 MSSQL$SBSMONITORING
    CService::Init: QueryServiceStatus. HRESULT = 0 MSSQL$SBSMONITORING
    CService::Init: QueryService. HRESULT = 0 SQLAgent$SBSMONITORING
    CService::Init: QueryServiceStatus. HRESULT = 0 SQLAgent$SBSMONITORING
    VerifySQLVersion: Current Version: . HRESULT = 0 8.00.194
    VerifySQLVersion: CSD Version: . HRESULT = 0 8.00.1100
    CService::Init: QueryService. HRESULT = 0 MSSQL$SHAREPOINT
    CService::Init: QueryServiceStatus. HRESULT = 0 MSSQL$SHAREPOINT
    CService::Init: QueryService. HRESULT = 0 SQLAgent$SHAREPOINT
    CService::Init: QueryServiceStatus. HRESULT = 0 SQLAgent$SHAREPOINT
    VerifySQLVersion: Current Version: . HRESULT = 0 9.00.2047.00
    CService::Init: QueryService. HRESULT = 0 MSSQLSERVER
    CService::Init: QueryServiceStatus. HRESULT = 0 MSSQLSERVER
    CService::Init: QueryService. HRESULT = 0 SQLSERVERAGENT
    CService::Init: QueryServiceStatus. HRESULT = 0 SQLSERVERAGENT
    CPreReqVerifier::CheckSQLInstances: InstalledInstances. HRESULT = 0 SBSMONITORING
    CService::Init: QueryService. HRESULT = 0 MSSQL$SBSMONITORING
    CService::Init: QueryServiceStatus. HRESULT = 0 MSSQL$SBSMONITORING

    CPreReqVerifier::CheckCurrentUserIsDBAdmin: Setup registry key not found. Error Code: 0x80070002.
    CPreReqVerifier::ExclusiveChecksfailed: hr: -2147024894
    CPreReqVerifier::ExclusiveChecksfailed: hr: -2147024894
    CPreReqVerifier::Checkfailed: hr: -2147024894
    CPreReqUtil::CopyFileFromMsi: Query: . HRESULT = 0 SELECT `Data` FROM `Binary` WHERE `Name`='PreReq.dll'
    CPreReqUtil::LoadHTMLResourceFromMsiBin: Resource size: . HRESULT = 18158
    CPreReqUtil::CopyFileFromMsi: Query: . HRESULT = 0 SELECT `Data` FROM `Binary` WHERE `Name`='Error.gif'
    CPreReqUtil::CopyFileFromMsi: Query: . HRESULT = 0 SELECT `Data` FROM `Binary` WHERE `Name`='Success.gif'
    CPreReqUtil::CopyFileFromMsi: Query: . HRESULT = 0 SELECT `Data` FROM `Binary` WHERE `Name`='Warning.gif'
    VerifyPreReqs: Check returned. HRESULT = 0
    VerifyPreRequisites: Result of Pre-Req check: PreReq_Requirements_Not_Met . See PreReq report for details: \MOMPreReqReport.html. Error Code: 0x80004005.
    VerifyPreRequisites: Function returned value. Error Code: 0x80004005.
    Action ended 9:10:38: _VerifyPreRequisites. Return value 3.
    Action ended 9:10:38: INSTALL. Return value 3.

    ....

     

    MSI (s) (0C:30) [09:10:38:275]: Note: 1: 1708
    MSI (s) (0C:30) [09:10:38:275]: Product: Microsoft Operations Manager 2005 -- Installation failed.

    MSI (s) (0C:30) [09:10:38:322]: Cleaning up uninstalled install packages, if any exist
    MSI (s) (0C:30) [09:10:38:322]: MainEngineThread is returning 1603
    MSI (s) (0C:80) [09:10:38:431]: Destroying RemoteAPI object.
    MSI (s) (0C:88) [09:10:38:431]: Custom Action Manager thread ending.
    === Logging stopped: 3/17/2008  9:10:38 ===
    MSI (c) (F8:18) [09:10:38:431]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (F8:18) [09:10:38:431]: MainEngineThread is returning 1603
    === Verbose logging stopped: 3/17/2008  9:10:38 ===

     

    17 martie 2008 17:55
  • Hi,

     

    this one initially shows a problem

     

    MSI (s) (0C!9C) [09:10:36:134]: Note: 1: 2711 2: MOMReporting
    Action start 9:10:34: _VerifyPreRequisites.
    GetMsiFeatureState: Failed to get feature state. Error Code: 0x80070646. MOMReporting

     

    So there is a problem with the pre-req's

     

    There are some tips here http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2197233&SiteID=17 relating to SQL Service Pack and some other tips for troubleshooting.

     

    Also here http://www.eggheadcafe.com/software/aspnet/29844139/installing-opsmgr-on-a-na.aspx 

     

    Is it x86 all the way with x86 SQL ? What version of SQL Service Pack are you running ?

     

    Also have a look at the entry

     

    VerifyPreRequisites: Result of Pre-Req check: PreReq_Requirements_Not_Met . See PreReq report for details: \MOMPreReqReport.html. Error Code: 0x80004005.

     

    What is in the MOMPreReqReport.html file ?

    17 martie 2008 18:11
  • Does MOM need to be installed before I try the install? I have gone through the deployment guide and it doesn't say anything about it being a pre-req.

     

    18 martie 2008 04:22
  • This is in the MOMPreReqReport. I haven't changed the name of the server, but I'm not the orginal administrator. Any fixes for this?

     

    The computer name has changed after SQL server was installed. SQL server must be reinstalled.  MOM Database
    MOM Reporting
     The computer name has changed after SQL server was installed. SQL server must be reinstalled. For more information look at SQL Books Online.

     

    18 martie 2008 04:27
  • I did a query of the database server with SELECT @@SERVERNAME and it returned SERVER, the proper name of the server. So it's not a NULL value.
    18 martie 2008 04:45
  • Actually, doing the queries:
    Select @@Servername
    Select ServerProperty('machinename')

     

    Both returned SERVER. I should be getting this error if the two values are inconsistent but they're not. So i don't know what's going on. Any ideas?

     

    Anyone know if I get support from MS with an Open Value license?

    18 martie 2008 07:57
  • Hi,

     

    Re the issue for the server name, take a look at http://support.microsoft.com/kb/303774 you can rename a SQL Server OK, but sounds like the script hasn't been run

     

    I don't believe you can get "free" support from MS with an open license, you could pay per incident...

     

    Chris

     

    18 martie 2008 08:07
  • Still doesn't work. Same error in the MOMPreReqReport.

     

    We pay all this money for the licenses but still can't call MS for support. I'll be recommending another product next time.

     

    18 martie 2008 08:18
  • Hi,

    If you don't have a contract with Microsoft Support you will not be able to place a call. If this problem is still occurring for you I would like to help you out over this channel. Can you let me know if you are installing on a Windows Server 2008 system?

    thanks,
    Oguzhan

    21 aprilie 2009 11:59
    Moderator
  • I am having this same issue and have tried all of the above solutions with no luck.  I am running Server 2008 x86 with SP2.  The server names in SQL are correct and match.

    Thanks, Adam

    17 mai 2010 14:42
  • One thing to watch out for is that the installer insists on trying to install the databases into the default SQL Server location C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data and if when you installed SQL Server you changed this then the installer will just give up, get it's coat and go home (nice programming people). The solution to this is to change the default database location back to the above default, install the software, and then move the databases to the actual location where they should be.
    2 iunie 2010 14:16