none
Publication Outlook Web Access Exchange 2010 SP2 via FTMG Standard 2010 SP2

    Question

  • Bonjour,

    Ce n'est pas bloquant dans le sens où tout fonctionne mais j'ai une interrogation.
    J'ai mis en place FTMG qui publie OWA, jusqu'ici rien de fabuleux, j'ai également créé une règle de redirection qui redirige les URLs https://nomdnspublic/ vers https://nomdnspublic/OWA pour éviter d'avoir à taper le /OWA. Plus convivial pour les utilisateurs.

    Ça fonctionne et on tombe sur le formulaire FTMG (bleu) quand on tape https://mondnspublic/

    Par contre lorsqu'on tape https://mondnspublic/OWA (je vois pas l'intérêt mais bon le client a essayé...), on tombe sur le formulaire OWA d'Exchange (jaune).

    Comment pourrait-on faire pour éviter celà ? Si quelqu'un a une idée ! :)

    jeudi 2 février 2012 04:48

Réponses

  • Bonjour,

    essayer de faire les etapes suivantes sur TMG :

    1. au niveau de la règle de publication TMG, sous l'onglet "Action" cliquez sur "Deny", cochez "redirect HTTP request.." et tapez lurl avec /owa
    2. au niveau du port listener, verifiez si lareponse à l'option "toujours authentifier" est "non"
    3. au niveau de "chemin d'accès", effacez les chemins internes déja inscrits et ajoutez le chemin root "/"
    4. sous délégation de l'authentification choisissez "pas de délégation, mais le client peut s'authentifier directement"
    5. sous utilisateur, choisissez 'tout les utilisateurs"

    Merci,

     

     

    jeudi 2 février 2012 11:08
  • Bonjour,

    as-tu activé le formulaire spécifique pour Exchange de TMG ? Il devrait apparaître comme celui-ci :

    https://exchange.faqexchange.info/CookieAuth.dll?GetLogon?curl=Z2F&reason=0&formdir=1

    En particulier la ligne "Sécurisé par ...TMG" !

    L'authentification doit rester au niveau du TMG, c'est un gage de sécurité... (c'est l'une des 2 raisons d'utiliser TMG pour de nombreux clients).

    Personnellement, j'utilise un fichier de redirection "default.htm" que je mets dans la racine de IIS sur les différents CAS. Au niveau de la règle de publication, je dois ajouter le chemin "/" (mais pas "/*" qui permettrait beaucoup trop de choses). La  racine de IIS est autorisée en anonyme, donc pas de problème de ce côté là.

    A bientôt,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    jeudi 2 février 2012 12:29

Toutes les réponses

  • Bonjour,

    essayer de faire les etapes suivantes sur TMG :

    1. au niveau de la règle de publication TMG, sous l'onglet "Action" cliquez sur "Deny", cochez "redirect HTTP request.." et tapez lurl avec /owa
    2. au niveau du port listener, verifiez si lareponse à l'option "toujours authentifier" est "non"
    3. au niveau de "chemin d'accès", effacez les chemins internes déja inscrits et ajoutez le chemin root "/"
    4. sous délégation de l'authentification choisissez "pas de délégation, mais le client peut s'authentifier directement"
    5. sous utilisateur, choisissez 'tout les utilisateurs"

    Merci,

     

     

    jeudi 2 février 2012 11:08
  • Bonjour,

    as-tu activé le formulaire spécifique pour Exchange de TMG ? Il devrait apparaître comme celui-ci :

    https://exchange.faqexchange.info/CookieAuth.dll?GetLogon?curl=Z2F&reason=0&formdir=1

    En particulier la ligne "Sécurisé par ...TMG" !

    L'authentification doit rester au niveau du TMG, c'est un gage de sécurité... (c'est l'une des 2 raisons d'utiliser TMG pour de nombreux clients).

    Personnellement, j'utilise un fichier de redirection "default.htm" que je mets dans la racine de IIS sur les différents CAS. Au niveau de la règle de publication, je dois ajouter le chemin "/" (mais pas "/*" qui permettrait beaucoup trop de choses). La  racine de IIS est autorisée en anonyme, donc pas de problème de ce côté là.

    A bientôt,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info
    jeudi 2 février 2012 12:29
  • Bonjour,

    Pouvons-nous considérer que vous avez résolu votre problème avec les scénarios proposés ? Dans l'affirmative, pourriez-vous partager avec nous la solution, afin que d'autres personnes avec le même problème puissent profiter de cette solution ?

    Désormais, nous marquons les solutions proposées. N'hésitez pas à revenir et supprimer la réponse marquée si la solution n’est pas correcte. Merci !

    Cordialement,

    Florin



    Florin CIUCA, MSFT       Join TechNetFr on Viadeo   Votez! Appel à la contribution
    Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    mardi 7 février 2012 20:30
  • Bonjour,

    Je vous tiens au courant, j'espère pouvoir tester d'autres solutions très prochainement.

    Cordialement.

    mardi 7 février 2012 22:04
  • bonjour,

    tu peux faire la redirection directement depuis le IIS sur tes serveurs CAS, puis authorisé sur le TMG / et /owa/* dans ce cas tu garderas toujours l'authentification TMG.

    Geoffrey,

    • Proposé comme réponse Geof62970 jeudi 9 février 2012 09:36
    jeudi 9 février 2012 09:36
  • La solution de Tunisian man a fonctionné.

    J'ai trouvé par ailleurs un article sur Internet qui explique bien le comment ! :)

    Petite précision, ne pas oublier de mettre la règle de redirection en dernier.

    http://www.alexgiraud.net/blog/Lists/Billets/Post.aspx?ID=197

    jeudi 23 février 2012 02:21