none
SharePoint 2010 FBA and Opera Browser - 403 Forbidden

    Question

  • I have configured SharePoint 2010 for FBA.

    No customisation, using OOTB login page.

    Using the SQL role and membership providers along with NTLM authentication on the same web app (no extended web app).

    Web application is configured for claims authentication.

    Web application and site collection are configured for anonymous access.

    On ie, safari and firefox I can connect and see the site as anonymous.  Pick the 'sign in link' (being rendered by the OOTB welcome.ascx control) and I get prompted for user creditentials and can log in with an NTLM or FBA user - all works perfectly.

    Opera (on the same Windows XP machine as the other browsers) gives a 403 forbidden when trying to render authenticate.aspx. 

    This is the exact link.

    http://cleanfba/_layouts/Authenticate.aspx?Source=%2FSitePages%2FHome%2Easpx

    Can anyone profer a solution?

     

     

     

    mardi 31 mai 2011 17:49

Réponses

  • Essentially the only real fix is to not use Opera.  It's not on the supported browser list.   Chrome isn't on the list either, although that one normally works.  Opera has always had issues with SharePoint and it isn't fixed in 2010.  Probably won't be fixed.  Here's the list of approved browsers.

    http://technet.microsoft.com/en-us/library/cc263526.aspx


    Paul Stork SharePoint Server MVP
    mardi 31 mai 2011 18:04
  • There was a similar problem with Opera in SharePoint 2007.  In that case it had something to do with Office Live being installed on the machine.  There are also reported issues with how Opera renders the Ribbon.  If FBA works with other browsers then I don't think its your configuration that is the problem.  There are issues with the way that Opera works behind the scenes. 
    Paul Stork SharePoint Server MVP
    mercredi 1 juin 2011 11:47

Toutes les réponses

  • Essentially the only real fix is to not use Opera.  It's not on the supported browser list.   Chrome isn't on the list either, although that one normally works.  Opera has always had issues with SharePoint and it isn't fixed in 2010.  Probably won't be fixed.  Here's the list of approved browsers.

    http://technet.microsoft.com/en-us/library/cc263526.aspx


    Paul Stork SharePoint Server MVP
    mardi 31 mai 2011 18:04
  • Paul,  Thanks for the reply and guidance.  It would be good to know if you or anyone has experienced this exact problem.  This is for a public facing website hence we have no over which browser is being used.

     

    I would be interested to know if this is definately a problem between opera and SP2010 or if it is perhaps something in our configuration or which may be changed perhaps by using an alternative authentication control or similar?

     

    Stranglely the anonymous access to the site seems to work just fine with Opera.

    mercredi 1 juin 2011 10:16
  • There was a similar problem with Opera in SharePoint 2007.  In that case it had something to do with Office Live being installed on the machine.  There are also reported issues with how Opera renders the Ribbon.  If FBA works with other browsers then I don't think its your configuration that is the problem.  There are issues with the way that Opera works behind the scenes. 
    Paul Stork SharePoint Server MVP
    mercredi 1 juin 2011 11:47
  • I have seen that with Claims Authentication and external IP, Sharepoint 2010 SP 1 and Opera 11.6 there seems to be a workaround on Client Side:

    In Opera right Click select site Preferences

    under Browser identification" drop-down, select "Identify as Internet Explorer"

    For a server side workaround this may be helpful:

    http://blogs.pointbridge.com/Blogs/nielsen_travis/Pages/Post.aspx?_ID=46

    However Opera is not supported and may have other issues.

    • Proposé comme réponse Caroline2AT mardi 4 décembre 2012 10:59
    lundi 20 février 2012 15:55
  • Hi,

    I am forced to find a solution to this problem with Opera. I found that selecting the exact URL of a custom login page works fine without your workaround. Unfortunately this is not acceptable for the final solution, to give people such a long URL.

    I thought of a simple redirect to enter the server address to the login page, but attempts to do this in IIS failed. I do not know whether this is with my lack of skill in the administration, or perhaps with the Sharepoint server, you can not do that?
    Please help and best regards

    • Modifié bartekC dimanche 17 juin 2012 23:01
    dimanche 17 juin 2012 22:59
  • Opera is not in the list of supported Browsers and there is a workaround to make Opera "identify as Ineternt Explorer"

    You should advice Users to use IE or Opera + Workaround.

    You can try to redirect URLs with 'URL rewrite' but...  i can hardly imagine its leading anywhere. The basic Problem is that Opera does not behave correctly with HTTP Status 401 and 403.

    lundi 18 juin 2012 09:18
  • Opera is not in the list of supported Browsers and there is a workaround to make Opera "identify as Ineternt Explorer"

    You should advice Users to use IE or Opera + Workaround.

    You can try to redirect URLs with 'URL rewrite' but...  i can hardly imagine its leading anywhere. The basic Problem is that Opera does not behave correctly with HTTP Status 401 and 403.

    Thanks .... I understand that Opera is not supported, but it is difficult to explain to our client ;). Besides, why in other web-based solutions there is no problem with Opera and authentication?
    mardi 19 juin 2012 07:06
  • I'm not sure why it is so difficult to explain to clients.  Just show them the official list of supported browsers and point out that Opera isn't on the list.  That means its NOT SUPPORTED and something about the way the browser works doesn't work.  SharePoint uses Claims based authentication so there are additional things going on in the background when authenticating that evidently Opera doesn't support.  It just doesn't work and there is no workaround that I am aware of.

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposé comme réponse bartekC jeudi 21 juin 2012 06:27
    mardi 19 juin 2012 12:14