none
Windows RDS 2012 - Single sign-on using Firefox or Chrome when launching RemoteApp from RDweb

    Question

  • Hi

    I have deployed RDS integrally on Windows Server 2012. This is my deploymnet:

    RDweb01 - RD Web access and gateway - Let's say "rdweb.contoso.com"

    RDCBroker01 - Connection Broker in HA mode using a certificate signed by a public trust CA. We have just one Broker. The HA mode is only to be able to use the certificate. Let's say "rdfarm.contoso.com"

    RDSHost01 and RDSHost02 - RD Session host.

    I have several RemoteApp publishd through RDWeb. It's just IE pointing to different web sites.

    When the users are using IE evrything works fine. No warnings and SSO works. The users log on to rdweb.contoso.com and then they are able to launch any RemoteApp without being asked for credentials, i.e. SSO works fine.

    The problem is when using Firefox or Chrome. Then the users are asked for credentials when launching any RemoteApp. It seems the request comes from the broker. Since I can see the address rdfarm.contoso.com in the credential window.

    The question is if SSO is supposed to work on non-IE browsers and if so HOW?

    Thanks in advanced.

    dimanche 30 juin 2013 13:42

Réponses

  • Hi,

    Web SSO is only supported under IE since it requires Activex.  With non-IE browsers users will be prompted once to log on to RDWeb, then a second time when they launch a RemoteApp.

    -TP

    • Proposé comme réponse Tomas Hidalgo dimanche 30 juin 2013 16:56
    • Marqué comme réponse Antuanfff dimanche 30 juin 2013 23:11
    dimanche 30 juin 2013 14:53
    Modérateur