none
'New Document' requires a Microsoft SharePoint Foundation-compatible

    Question

  • hi

    When I click the new button within a document library I get an error :

    'New Document' requires a Microsoft SharePoint Foundation-compatible application and web browser. To add a document to this document library, click the 'Upload Document' button.

    I've tried a couple of browsers and same error occurs. Running SP 2010 Server. Client computers have office 2007.

    I read a few articles, is it necessary to install office on my Sharepoint Server ? I would rather not do this. I also read I need to reference a file called
    Owssupp.dll ??
    What are my options on this ?


    jeudi 5 avril 2012 20:33

Réponses

  • Hi,

    Please try to add 'Non-Office' Content types like 'Picture', 'Basic Page',  and 'Link to a Document' to the document library, then check if the issue can be reproduced.

    And try to check if you can see the icon for the document in the document library, if you cannot, it may be caused by there is something error in docicon.xml file, locate in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML.

    Please check the docicon.xml  and check if missed closing tag for pdf and other custom icon.

    You can refer this article to edit docicon.xml file:http://support.microsoft.com/kb/837849


    Xue-mei Chang

    TechNet Community Support

    mercredi 11 avril 2012 03:01
    Modérateur

Toutes les réponses

  • What browser are you using? From Plan Browser Support (SharePoint Foundation 2010) and Plan Browser Support (SharePoint Server 2010):

    New Document

    Microsoft Office 2010 does not provide a 64-bit version of this control.

    Although the New Document command may not work, you can use the Upload Document functionality. If you install and configure Office Web Applications on the server, the New Document command works, and you can create an Office document in your browser.

    In other words, the only way for New to work for a new Office document (Word, Excel, PowerPoint, etc) is to be running Internet Explorer 7, 8, or 9, 32-bit (64-bit IE will not work). ALternatively, installing Office Web Apps will allow users to open the file in the browser which you probably do not want.

    The server does not require Office installed. The file Owssupp.dll you've seen referenced is installed as part of the Office installation with the SharePoint support feature under Office Tools (I believe it is installed by default). This is required to be installed on your client machines.


    Jason Warren
    Infrastructure Specialist
    Habañero Consulting Group
    www.habaneros.com/blog

    jeudi 5 avril 2012 20:49
  • hi

    I'm running on the client IE9 32bit.. so should it work ? In the client machine I can see Owssupp.dll

    I've checked the server and there seems to be no Owssupp.dll .

    Any ideas ?

    jeudi 5 avril 2012 20:59
  • I would look at the ActiveX settings, maybe they've been restricted or the site is not added to the Local Intranet or Trusted Sites zones.

    Jason Warren
    Infrastructure Specialist
    Habañero Consulting Group
    www.habaneros.com/blog

    jeudi 5 avril 2012 21:10
  • hi

    Also multiple files upload dows not work ! just notices this now but it worked before !

    I've just relised with my test sharepoint server seems to work with multiple file uploads and the 'New Document'. I created a new document library set to word template. I used the same client machine as earlier.

    So why is my test server working and production server not ?


    jeudi 5 avril 2012 22:24
  • Please look at below url:

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/06a4943a-5150-44c5-ae6b-3354c85396f5

    make sure you are using 32 bit of IE at client and also Multiple file upload is not the feature of SharePoint 2010 is the feature of MS Office.

    http://blog.bugrapostaci.com/2011/08/04/multiple-file-upload-and-drag-and-drop-file-feature-on-sharepoint-2010/


    Jayant Sharma


    vendredi 6 avril 2012 04:46
  • Hi

    I've tried the above link and problems persist.

    I tried again today, for a moment the multiple files upload button was enabled, but then later disabled. All I done was restart the browser..Seems unpredictable.

    So now neither the 'multiple upload ' or 'new document' works on my live server, however these controls work from my test server on the same client and I cant see any difference in the IE settings!

    So I'm beginning to think its a server related issue. Do I need to enable anything on my live server ? (Client Integration is enabled in CA)


    Thanks


    vendredi 6 avril 2012 11:35
  • Hi,

    Please try to add 'Non-Office' Content types like 'Picture', 'Basic Page',  and 'Link to a Document' to the document library, then check if the issue can be reproduced.

    And try to check if you can see the icon for the document in the document library, if you cannot, it may be caused by there is something error in docicon.xml file, locate in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML.

    Please check the docicon.xml  and check if missed closing tag for pdf and other custom icon.

    You can refer this article to edit docicon.xml file:http://support.microsoft.com/kb/837849


    Xue-mei Chang

    TechNet Community Support

    mercredi 11 avril 2012 03:01
    Modérateur
  • Hi

    I've enabled content types, prior to this Content Types were disabled for document Library.

    I added 'Basic Page' and 'Link to a document' Content Types. I then used the new button and was able to create both document types.  Clicking the original 'Document' still produces the earlier error.

    The icons all seem okay, I can see  a Basic Page icon (from new) and pdf and word icons (from uploading).

    In my previous post I mentioned it all works on my test server, i have realise I have a newer patch on this test server. Could this be the reason ?

    Live server 14.0.6029.1000 Service Pack 1 Patch
    Test Server June Update 2011 - kb2536599 14.0.6105.5000

    mercredi 11 avril 2012 21:40
  • Hi I'm still struggling with this. i've built another test server and on my client the 'new document' works. i.e. I can create new word files and not see the dreaded error message I mentioned earlier ' 'New Document' requires a Microsoft SharePoint Foundation-compatible application and web browser'. So there is someting wrong with my live server which shows this error.

    And try to check if you can see the icon for the document in the document library, if you cannot, it may be caused by there is something error in docicon.xml file, locate in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML.

    I've noticed when I hover above 'new document' in the ribbon I dont see the word icon, instead I see a blank icon. Could this be a clue in fixing this.. The above quote aimed at this I think but I dont see how I can fix a docicon.xml file . When I upload files I can see icons in the document libraries though, word and pdf's so maybe the docicon.xml is okay.

    Any help with this appreciated. thanks


    mardi 24 avril 2012 08:59
  • I found the problem, I had a incorrect tag in docicon.xml file. thanks everyone.
    mardi 24 avril 2012 12:52
  • I found the problem, I had a incorrect tag in docicon.xml file. thanks everyone.

    What did you to with the tag do fix the problem? I think I have the same problem with the docicon.xml
    • Modifié jill_nor mercredi 25 avril 2012 06:42
    mercredi 25 avril 2012 06:10
  • Hi

    I added a pdf icon but made an error in syntax (missed out the /). This is how the code should look :

    <Mapping Value="pdficon_small.gif" Key="pdf"/>

    A way of testing that the xml file is 'well formed' is trying to open with IE if it fails to open, then there may be a problem with file.

    Hope this helps.

    mercredi 25 avril 2012 07:44
  • I have the same issue and in my case it is not docicon.xml
    • Proposé comme réponse fb75 mercredi 8 mai 2013 13:53
    jeudi 13 septembre 2012 14:45
  • Are you using IE ? In my experience other browsers cause problems.
    vendredi 14 septembre 2012 14:55