none
Handling export-only attributes in ECMA2

    Question

  • I am creating an ECMA2 MA.

    I have a couple of metaverse attributes, that I use ONLY when exporting - and that I cannot read back in an import, because they are not stored anywhere. 

    So the export works fine, but when I then try to Import, I get "exported-change-not-reimported" errors.

    How can I avoid that?

    One workaround is to define a constant import for an export-only attribute. This will not get rid of the "exported-change-not-reimported" errors on first import, but on subsequent export/import cycles, the constant value will have taken over, and I will not get the error again. Feels like a dirty hack though, since I still get the error first time around.

    Another workaround could be to store the export-only values in a file or something, so I can import them again, but that seems like a lot of trouble for no value - and just another dirty hack. 

    If anybody is wondering "why would you export something, that you cannot import again":

    An example is that on export I supply a geographic identifier, to determine which mailstore a new shared mailbox (exchange) should be created in. That geographic id is never stored anywhere, as it is only used temporarily.


    ---Sig---

    vendredi 2 août 2013 12:36

Toutes les réponses

  • Hi,

    My suggestion here is to only write these values out as initial values only as these are handled differently by FIM and aren't part of the standard flow rules which need to confirmed during the subsequent import.


    Visit My Blog: http://theidentityguy.blogspot.com/

    mardi 6 août 2013 01:44
  • Thank you for your answer.

    I was not aware of "initial flow only", and it seems like just what I am looking for.

    However, it seems this only applies to declarative provisioning, which we do not use (yet). Is that correct, or am I overlooking something?


    ---Sig---

    mardi 6 août 2013 06:34
  • So the challenge here is to export data without requiring a confirming import.. Unfortunately if you are exporting data and the MA is set as an import /export MA then you need to confirm the data coming back. The other option is to set the MA to an Export only MA, which means that it will never do an import. From the scenario you are painting, you are probably needing to import data from the source...

    Visit My Blog: http://theidentityguy.blogspot.com/

    mardi 6 août 2013 11:41