none
MDT Erreur de Creation de catalogue

    Question

  • Bonjour,

     

    J'ai un probleme, je n'arrive pas crée ou recrée le fichier catalogue de mes Images.

    J'ai reinstallé MDT, rien ni fait.

     

    Auriez- vous une idée??

     

    Je vous met le fichier log de l'erreur

     

    Opération « generate » en cours sur la cible « Catalog ».
    Échec d’exécution de l’opération.
    System.Reflection.TargetInvocationException: Une exception a été levée par la cible d'un appel. ---> System.ArgumentNullException: La référence de chaîne n'est pas définie à une instance d'une chaîne.
    Nom du paramètre : source
       à System.Globalization.CompareInfo.IsPrefix(String source, String prefix, CompareOptions options)
       à ?A0xfe36268f.ConvertToNtPath(String path)
       à Microsoft.ComponentStudio.ComponentPlatformInterface.CbsSessionAdaptor..ctor(String bootDrive, String imageWinDir, String servicingPath)
       à Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageImpl.InitializePackages()
       à Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageImpl..ctor(OfflineImageInfo imageInfo)
       --- Fin de la trace de la pile d'exception interne ---
       à System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
       à System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       à System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       à Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.PlatformImplementation.CreateOfflineImageInstance(OfflineImageInfo imageInfo)

    mardi 25 octobre 2011 06:01

Toutes les réponses

  • bonjour,

    vous devriez désinstaller et réinstaller le WAIK, le service Windows System Image Manager doit être en carafe.

    vous pouvez générer vos catalogues via le fichier install.wim mais aussi le fichier *.cfg qui se trouve dans vos sources windows 7

    Tenez nous au courant

    samedi 29 octobre 2011 22:36
  • J'ai désinstaller et réinstaller WAIK mais rien a faire
    mardi 8 novembre 2011 08:12
  • Bonjour,

    pouvez vous nous en dire plus sur ce qui à été fait et ce que vous essayez de faire ?

    Le problème est-il présent pour toutes les images ?

    s'agit-il d'images qui ont été personnalisées ?

    WSIM vous remonte-t-il des erreurs lorsque vous ouvrez et créez un clg depuis une image non personnalisée ?


    Julien Darakdjian [Nelite] - http://www.nelite.com/community/b/jdarakdjian/default.aspx
    mardi 8 novembre 2011 18:04
  • Bonjour,

    En fait, j'ai voulu juste édité mon fichier Unattend.xml, il essaie de crée un fichier catalogue puis ERREUR.

    Je précise c'est une image personnalisée. Ce que je comprend pas c'est que sa marchais très bien.

    lundi 14 novembre 2011 13:13
  • Essayez d’exécuter la commande DISM /cleanup-wim puis essayez à nouveau de générer un catalogue.

    Si ça ne fonctionne pas, regardez les erreurs dans %Windir%\Logs\dism.log


    Julien Darakdjian [Nelite] - http://www.nelite.com/community/b/jdarakdjian/default.aspx
    lundi 14 novembre 2011 16:14
  • Pas de souci le cleanup-wim a bien fonctionné. Mais je ne peut toujours pas recréer mon catalogue, même erreur.
    lundi 14 novembre 2011 17:40
  • Avez-vous regardé le contenu des logs indiqué dans mon post précédent ?

    Pouvez-vous ouvrir l'image wim depuis l'outil Windows System Image Manager ?

    Votre serveur est installé en x64 ou x86 ?


    Julien Darakdjian [Nelite] - http://www.nelite.com/community/b/jdarakdjian/default.aspx
    mardi 15 novembre 2011 09:21
  • Non je n'arrive pas a l'ouvrir avec Windows System Image Manager
    mercredi 16 novembre 2011 13:45
  • Bonjour

    J'ai le même probléme avec le même message d'erreur quand je vais dans la séquence de tache. Onglet OS Info, et que j'édite de ficher unattend.xmL

    je n'arrive pas non plus à l'ouvrir avec WSIM.

    quand il est à la partie Nettoyage, j'ai un message d'erreur me disant que L'Assistant Gestion d'installation n'a pas pu générer un catalogue. Détails : Echec d'éxécution de l'opération

    Pour info, il s'agit d'une image personnalisé. En fait c'est une image sysprépée. Et sinon, j'arrive à ouvrir le fichier unattend.xml qui se trouve dans DeploymentShare$\Control (je ne sais pas si c'est le même)

    Merci de votre aide

    vendredi 13 janvier 2012 14:12