none
Getting stopped-file-embedded-nulls error when importing tab separated file

    Question

  • I've configured the delimited text file MA to import a tab separated file that's generated as an output file from an HR system. I've specified that the schema is on the first line of the file and have set up attribute flow rules within the MA configuration. I told the sync engine to import the file but I get a stopped-file-embedded-nulls error pretty quickly.

    I've checked the event logs for any information on this error but nothing is showing up. I've also searched the internet for information on this error and found some stuff about CSV files, but the answers didn't get me where I need to go. Based on suggestions in my searches, I tried specifying both the Western and Unicode code pages but that didn't make a difference.

    Could it be that the sync engine is choking on a bogus null char in the file? Where could that null be located and how would I get rid of it to test the theory?

    jeudi 16 mai 2013 22:09

Réponses

  • Hey Ace!

    Here are a couple of things you can try...  If the file is small enough to open in Notepad, use the Save As option.  You will see an Encoding option at the bottom of the Save As window.  Try some of the other encoding options and align that in the MA code page.  You could also try opening the file in Excel and verify that the columns align correctly.

    Let me know how it goes! 

    • Marqué comme réponse aceswerling2 vendredi 17 mai 2013 20:24
    jeudi 16 mai 2013 22:21

Toutes les réponses

  • Hey Ace!

    Here are a couple of things you can try...  If the file is small enough to open in Notepad, use the Save As option.  You will see an Encoding option at the bottom of the Save As window.  Try some of the other encoding options and align that in the MA code page.  You could also try opening the file in Excel and verify that the columns align correctly.

    Let me know how it goes! 

    • Marqué comme réponse aceswerling2 vendredi 17 mai 2013 20:24
    jeudi 16 mai 2013 22:21
  • Hey, Rebecca. Good to hear from you!

    Your suggestion did the trick. I resaved the file as Unicode, made sure that's the code page the MA expects, and then had a successful import. Does it sound plausible that our dump process put a bogus null character in the file, which Notepad then stripped out when I resaved the file?

    Thanks a ton for the help!

    vendredi 17 mai 2013 20:24
  • I suppose just about anything is possible, although its more likely an encoding problem.  There should be some advanced text editors out there that will show you exactly whats in the file, including any null characters.
    mardi 21 mai 2013 16:07