none
Réinstallation de Exchange Impossible

    Discussion générale

  • Bonjour à tous !

    N'ayant malheureusement pas trouvé cas similaire sur le Web, je vous fais part de mon problème.

    Suite à un crash HDD, j'ai perdu mon installation de Exchange 2010.

    J'ai donc repris l'installation à zéro sur un nouveau Server 2008 R2 SP1 (comme avant).
    Lorsque j'ai lancé la commande : Prepareshema, une erreur est survenue :
    Le programme d'installation a échoué lors de l'exécution de l'action " DisasterRecovery ". Vous ne pouvez pas reprendre l'installation en exécutant l'action " Install ".
    Le programme d'installation a échoué lors de l'exécution de laction "Uninstall ". Vous ne pouvez pas reprendre l'installation en exécutant l'action " Install ".

    Je tiens à préciser que j'ai toujours mon DC effectif qui contient donc les paramètres de l'ancien serveur Exchange. Peut-être que ceci explique celà... ? Mais quelles méthodes appliquées pour tout vider sans formater mon DC ?!

    J'ai bien sur tenté un RecoverServer mais sans succès.

    Donc, je me retrouve bloqué sans aucune possibilité.

    Merci pour votre aide :)

    mardi 21 février 2012 16:38

Toutes les réponses

  • bonjour,

    lors d'une récupération ou l'ajout de nouveau serveur exchange, pas besoin de repréparer le schema, domaine.

    pour ton cas, il faut faire un recover.

    1 : faire un reset du compte serveur qui est down (AD)

    2: installer ton serveur avec l'ancien nom, puis le mettre dans le domaine.

    3: installation prés requis et update etc..

    4: lancer a partir des sources exchange 

    Setup /m:RecoverServer

    5: restoration de l'états systéme avant le crash si sauvegarde, sinon tu récupéras que la configuration de l'organisation.

    Geoffrey,


    MCITP Exchange 2010 Si ma réponse vous a été utile, ou apporté une résolution, merci de voter ou de la marquer comme réponse.

    mardi 21 février 2012 19:22
  • Bonjour,

    si les données Exchange et en particulier les bases sont perdues, il est probablement préférable de redémarrer l'installation Exchange depuis zéro.

    => Dans ADSIEDIT, supprimer l'organisation Exchange dans la partie "configuration", "services".

    Tous les paramètres, boîtes, etc... devront être redéfinis.

    Sinon, avez-vous repris le même nom et la même configuration lors de la tentative de RecoverServer?

    A+


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info

    mercredi 22 février 2012 15:44
  • Bonjour à vous deux,

    Geoffrey, je pense avoir pratiqué à peu près la marche à suivre que tu me proposes, bien que je ne vois pas pour le reset du coumpte serveur.
    J'ai installé un tout nouvel ordinateur, avec l'ancien nom de poste (que j'avais préalablement supprimé de mon AD) et en me servant de l'administrateur précédent.
    C'est lorsque j'ai tapé la commande de "/Prepareschema" qu'il m'a proposé de pratiquer un recoverserver.

    Thierry, merci à vous de bien vouloir consacrer un peu de temps à mon problème.
    Je suis donc allé dans ASIEDIT (que je ne connaissais pas), dans la partie configuration et dans le dossier "service" supprimer tout ce qui avait un nom d'"Exchange".

    J'ai donc, je pense ce qu'il fallait faire, lancer un " /Prepareschema", une nouvelle erreur est survenue :
    Controle de l'oganisation Echec
    Une erreur d'installation s'est produite précédemment pendant l'installation du role Hubtransport. Vous devez soit exécuter de nouveau le programme d'installation pour ce rôle, soit supprimer le rôle depuis le Panneau de configuration.
    Un petit tour sur l'observateur d'évènements fructueux :

     

    La description de l’ID d’événement 5 dans la source MSExchange Configuration Cmdlet - Management Console est introuvable. Le composant qui a déclenché cet événement n’est pas installé sur l’ordinateur local ou l’installation est endommagée. Vous pouvez installer ou réparer le composant sur l’ordinateur local.
    Si l’événement provient d’un autre ordinateur, les informations d’affichage doivent être enregistrées avec l’événement
    Les informations suivantes étaient incluses avec l’événement :
    2908
    12
    Get-OrganizationConfig

    Microsoft.Exchange.Data.Directory.SystemConfiguration.OrgContainerNotFoundException: Conteneur Organisation de l'entreprise introuvable.

       à Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String fqdn, NetworkCredential credential)

       à Microsoft.Exchange.Configuration.Tasks.GetSingletonSystemConfigurationObjectTask`1.InternalBeginProcessing()

       à Microsoft.Exchange.Configuration.Tasks.Task.BeginProcessing()

    {8ec123c2-e1bb-4171-9271-28ac1dd6943c}

    La ressource de message est présente mais le message ne se trouve pas dans la table des chaînes ou des messages

    Une autre bien sur :


    La description de l’ID d’événement 4 dans la source MSExchange Configuration Cmdlet - Management Console est introuvable. Le composant qui a déclenché cet événement n’est pas installé sur l’ordinateur local ou l’installation est endommagée. Vous pouvez installer ou réparer le composant sur l’ordinateur local.
    Si l’événement provient d’un autre ordinateur, les informations d’affichage doivent être enregistrées avec l’événement.
    Les informations suivantes étaient incluses avec l’événement :
    2908
    3
    test-SetupHealth
    0
    Microsoft.Exchange.Management.BestPracticesAnalyzer.BPAConfigurationErrorFoundException: Une erreur d'installation s'est produite précédemment pendant l'installation du rôle HubTransport. Vous devez soit exécuter de nouveau le programme d'installation pour ce rôle, soit supprimer le rôle depuis le Panneau de configuration.
    {bbae2bbe-a6ea-4b79-bfa5-b60f5a004639}
    La ressource de message est présente mais le message ne se trouve pas dans la table des chaînes ou des messages

     Je pense que ca va être plus dur que ce que je pensais.

    En tout cas merci encore à vous deux pour les pistes.

    Bonne soirée :)

    mercredi 22 février 2012 22:17
  • Bonjour,

    si l'on prend l'option de nettoyer l'annuaire, il faut repartir d'un serveur "propre" ou bien nettoyer complètement les restes d'Exchange sur le serveur  (registres et dossiers)!

    Ensuite, dans le cas d'un annuaire "simple", on peut lancer SETUP sans paramètre... si nécessaire, les étapes  seront alors indiquées au fur et à mesure. Sinon, le setup exécutera directement toutes les préparations manquantes.

    A bientôt,


    Thierry DEMAN. Exchange MVP. https://www.mcpvirtualbusinesscard.com/VBCServer/MVPtdeman/profile (68 MCPs) http://base.faqexchange.info

    vendredi 24 février 2012 13:21
  • Bonjour,

    Je reviens enfin vers vous ! Mieux vaut tard que jamais comme l'on dit :)

    Donc, après avoir suivi les instructions de Thierry, effectivement tout marche !

    Un petit nettoyage du Server 2008 R2 DC avec la fameuse commande, une réinstallation complète de Exchange sur une nouvelle machine et en avant.

    J'ai juste des soucis avec mon TMG pour que il laisse Exchange exercer son travail, mais ceci est un autre problème que je poserai surement sur la section dédiée.

    Merci encore !

    samedi 17 mars 2012 17:43