none
Installationssprache wird bei Installation nicht ausgewählt

    Pertanyaan

  • Hallo NG

    Vorhanden: Unbeaufsichtigte Installation von Windows 7

    Nachdem das deutsche Sprachpaket glücklich zur install.wim zugefügt wurde, möchte ich es bei der Installation auch ausgewält haben.
    Die unattend.xml sieht folgendermaßen aus:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                        <WillShowUI>OnError</WillShowUI>
                    </OSImage>
                </ImageInstall>
                <UserData>
                    <AcceptEula>true</AcceptEula>
                    <FullName>Firma</FullName>
                    <Organization>Firma</Organization>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        <Key></Key>
                    </ProductKey>
                </UserData>
            </component>
       <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
                <SetupUILanguage>
                    <UILanguage>de-de</UILanguage>
                </SetupUILanguage>
                <UILanguage>de-de</UILanguage>
                <SystemLocale>de-de</SystemLocale>
                <UserLocale>de-de</UserLocale>
            </component>
      </settings>

    Bei der Installation wird ein Auswahlfenster gezeigt, indem man die Sprache auswählen soll. Vorauswahl der Installationsprache ist englisch und nur englisch ist auswählbar.  Für Tastatur und Zeiteinstellungen kann man aus der Liste ein Land wählen.

    Wenn ich dann fertig installiere kann ich in der Systemsteuerung / Regions und Spracheinstellungen Deutsch als Displaysprache auswählen und das funktioniert auch.

    Ich möchte aber, dass das unattended setup Deutsch als Installationssprache auswählt.

    Es scheint mir als ob das Setup bei der Installation noch nicht weiss, dass Deutsch als Sprachpaket zum Installationspaket zugehört. Schreibe ich die unattend für language en-us installiert Windows ohne Unterbrechung.

    Kann mir jemand helfen und sagen wo der Fehler ist?
    Gruß Hans-Jörg

    11 Januari 2012 13:37

Jawaban

  • Hallo an alle, und vielen Dank für die Antworten.

    Meine Recherche hat eine Weile gedauert. Aber jetzt ist es so wie ich es haben möchte.

    Nachdem die Sprachpakete der install.wim mit Dism hinzugegügt waren, wurde mit
    intlcfg.exe eine lang.ini datei erzeugt , die die Sprachpakete in der install.wim anzeigt.
    Die lang.ini habe ich in das Verzeichniss kopiert , in der auch die install.wim bereitliegt.

    Lang.ini:
    [Available UI Languages]
    de-DE = 3
    en-US = 2
    fr-FR = 2
    hu-HU = 2
    [Fallback Languages]
    hu-HU = en-us

    Die unattend.xml war soweit OK:
     <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
                <SetupUILanguage>
                    <UILanguage>de-de</UILanguage>
                </SetupUILanguage>
                <UILanguage>de-de</UILanguage>
                <SystemLocale>de-de</SystemLocale>
                <UserLocale>de-de</UserLocale>
            </component>

    Ich musste aus unbekannten Gründen noch das Administratorpasswort eintragen. (Bei en-US brauchte ich es nicht)

            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               <UserAccounts>
                    <AdministratorPassword>
                        <Value>Passwort</Value>
                        <PlainText>True</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
            </component>
       
    Wenn ich jetzt die unattend.xml ändere kann ich dementsprechend die gewünschte MUI eingestellt haben.

    Gruß Hans-Jörg

     

    25 Januari 2012 14:33

Semua Balasan

  • > Es scheint mir als ob das Setup bei der Installation noch nicht weiss,
    > dass Deutsch als Sprachpaket zum Installationspaket zugehört.
     
    Ja, weiß es auch nicht. Du MUSST ein deutsches Image verwenden, wenn die
    Installation in deutsch laufen soll.
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    11 Januari 2012 14:07
  • Hallo Martin, 

    Ich hoffe ich bin nicht zu ungenau.
    Der Install.wim habe ich ein deutsches Sprachpaket zugewiesen.
    Ich möchte, dass nach der Installation eine dem Land (z.B. Deutschland) entsprechende Oberfläche in Windows existiert.
    Tatsächlich ist die Installationssprache egal. Hauptsache der Benutzeroberfläche ist angepasst.

    Den  Eintrag: 
    <SetupUILanguage>
                  <UILanguage>de-de</UILanguage> 
    </SetupUILanguage>

    hatte ich auch mit en-US ausprobiert, aber  
    dann war auch nicht die deutsche Oberfläche, gemäß den anderen Einträgen, installiert.

    Ich bin ratlos wenn Du schreibst, dass eine deutsche Installtions-Version nötig ist, da dann für jedes Land ein eine neue Installation eingerichtet sein muß. Genau das möchte ich nicht. ES sollte doch mit Sprachpaketen funktionieren?

    Gruß Hans-Jörg

     

     


    • Diedit oleh HansJ1 11 Januari 2012 16:19
    11 Januari 2012 16:17
  • Hi,

    Am 11.01.2012 14:37, schrieb HansJ1:

    <?xml version="1.0" encoding="utf-8"?>[...]

    Ersetze im XML alle "en-US" durch "de-DE" und alle "0409" durch "0407"

    Tschö
    Mark


    Mark Heitbrink - MVP Windows Server - Group Policy

    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm

    11 Januari 2012 16:27
  • Hallo,

    mounte doch bitte einmal dein Installations-Image unt setze die default language:

    /Set-UILang:
    /Set-SetupUILang:


    http://technet.microsoft.com/en-us/library/dd744360(WS.10).aspx

     

    Mehr Informationen:

    http://technet.microsoft.com/en-us/library/dd799268(WS.10).aspx

    http://technet.microsoft.com/en-us/library/dd744569(WS.10).aspx

    http://technet.microsoft.com/en-us/library/dd799306(WS.10).aspx

     


    MVP - Group Policy http://matthiaswolf.blogspot.com/

    11 Januari 2012 16:44
  • > Ich möchte, dass nach der Installation eine dem Land (z.B. Deutschland)
    > entsprechende Oberfläche in Windows existiert.
     
    Jetzt wird's klarer (:
     
    Defaultsprache setzen (hier de-DE mit en-US als Fallback):
     
    <gs:GlobalizationServices  xmlns:gs="urn:longhornGlobalizationUnattend">
     <!-- User List -->   <gs:UserList>   <gs:User UserID="Current"
    CopySettingsToDefaultUserAcct="true" />   </gs:UserList>  <!-- MUI-->
    <gs:MUILanguagePreferences>    <gs:MUILanguage Value="de-DE" />
    <gs:MUIFallback Value="en-US" />
    </gs:MUILanguagePreferences></gs:GlobalizationServices>
     
    in ein XML stecken und
     
    control intl.cpl,, /f:"File.xml"
     
    aufrufen. Rest findest bestimmt dann bei Technet.
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV... Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    12 Januari 2012 10:33
  • Hallo an alle, und vielen Dank für die Antworten.

    Meine Recherche hat eine Weile gedauert. Aber jetzt ist es so wie ich es haben möchte.

    Nachdem die Sprachpakete der install.wim mit Dism hinzugegügt waren, wurde mit
    intlcfg.exe eine lang.ini datei erzeugt , die die Sprachpakete in der install.wim anzeigt.
    Die lang.ini habe ich in das Verzeichniss kopiert , in der auch die install.wim bereitliegt.

    Lang.ini:
    [Available UI Languages]
    de-DE = 3
    en-US = 2
    fr-FR = 2
    hu-HU = 2
    [Fallback Languages]
    hu-HU = en-us

    Die unattend.xml war soweit OK:
     <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
                <SetupUILanguage>
                    <UILanguage>de-de</UILanguage>
                </SetupUILanguage>
                <UILanguage>de-de</UILanguage>
                <SystemLocale>de-de</SystemLocale>
                <UserLocale>de-de</UserLocale>
            </component>

    Ich musste aus unbekannten Gründen noch das Administratorpasswort eintragen. (Bei en-US brauchte ich es nicht)

            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
               <UserAccounts>
                    <AdministratorPassword>
                        <Value>Passwort</Value>
                        <PlainText>True</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
            </component>
       
    Wenn ich jetzt die unattend.xml ändere kann ich dementsprechend die gewünschte MUI eingestellt haben.

    Gruß Hans-Jörg

     

    25 Januari 2012 14:33