none
IE 8 or 9 will not launch or open under Win 7

    Dotaz

  • Hello all,

    I have Win 7 64bit OS and I am unable to launch IE 8 or IE 9. When i try to open it, the browser window will on open. All i see is a hour glass for a couple  of seconds and that is it. In the process manager i can see that it starts IE then closes it again. I have tried to restore back to a previous version and still unable to get it to work. I upgraded the stock IE 8 to IE 9 in hopes that it will fix the issue but it has not, IE 9 does the same thing.

    I have tried to uninstall IE 8 from Programs and then re-install it back and that did not help either.

    At this time i am out of ideas on what it could be!

    Any help you can provide will be much appreciated!

    Regards,

    Sam

    28. června 2012 20:14

Všechny reakce

  • Hi,


    I suggest you try the following steps to test the issue.


    1. Please check if the issue will occur in Safe Mode with networking.

    2. Also test the issue in Clean Boot mode.


    Hope this helps.


    Vincent Wang

    TechNet Community Support

    2. července 2012 8:44
  • Hi Vincent,

    Thanks for the reply! I have tried both of your suggestions but still not able to get IE to work. Looks like i might have deleted some registry entries when i had uninstalled it and then used the CCleaner to clean the registry and then installed IE 8 back. Is there a way to do a full IE8 install on Win 7?

    Thanks,

    Samit

    7. července 2012 6:31
  • Hi Samit,


    First, please understand that we don’t recommend to use third party tool to change the registry, because it may cause unexpected results.


    I suggest you perform a system restore to check the result. In addition, you can use System File Checker tool to scan the system files.


    Hope this helps.


    Vincent Wang

    TechNet Community Support

    10. července 2012 6:15
  • Hello Vincent,

    I have tried your suggestions again and neither of them worked. The restore failed and the system file checker repaired only the "diskmgt.CHM" file. That was the only file that was corrupt.

    Regards,

    Samit

    11. července 2012 21:15
  • Hi,


    I suggest you have an In-Place upgrade to repair system.


    How to Perform an In-Place Upgrade on Windows Vista, Windows 7, Windows Server 2008 & Windows Server 2008 R2

    http://support.microsoft.com/kb/2255099


    Hope this helps




    Vincent Wang

    TechNet Community Support

    16. července 2012 1:41
  • Hi Vincent,

    I have finally done manual compare and found that this registry key was missing...[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{A4A1A128-768F-41E0-BF75-E4FDDD701CBA}\InProcServer32]
    @="C:\\Program Files (x86)\\Internet Explorer\\ieproxy.dll"
    "ThreadingModel"="Both"

    Once i added it back i was able to open internet explorer.

    Thanks for your help with this issue!

    Regards,

    Samit

    24. července 2012 17:47