none
Internet explorer IE9 certificate error no option to continue to site

    Question

  • I have a watchguard ssl 100 and when I try to connect I get the expected certificate error as I have not installed one. The continue option is gone all I can

    do is close the web page. I cannot login into my SSL is there a way to add the continue back in

    The security certificate presented by this website was not issued by a trusted certificate authority
    The security certificate presented by this website was issued for a different website's address


    Friday, May 10, 2013 3:12 AM

Answers

  • Ok fixed it! Let me clarify for all who may read this

    Continue to this website (not recommended).  was missing --> it was replaced with close this webpage link

    I went into programs and features uninstalled IE and reinstalled. That did it. Also of note I had shortcut to my website I deleted it off the desktop and created the link on IE toolbar

    I am mentioning this in case that influenced IE certificate response. Also I tried these from other posts below they did not work

    certutil -setreg chain\minRSAPubKeyBitLength 512   it was no go

    certutil -setreg chain\EnableWeakSignatureFlags 8   it was no go

    1. Go to "run" -> gpedit.msc   
    2. Under Computer configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control 

    Panel
    3. Under Prevent ignoring certificate error (set to disable even though it's set to undefined). it was no go


    • Marked as answer by Jeff_1 Wednesday, May 15, 2013 12:24 AM
    Wednesday, May 15, 2013 12:23 AM

All replies

  • http://www.watchguard.com/products/watchguard-ssl/overview.asp

    Questions regarding Internet Explorer 8, 9 and 10 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us


    Rob^_^

    • Marked as answer by Jeff_1 Friday, May 10, 2013 5:13 AM
    • Unmarked as answer by Jeff_1 Friday, May 10, 2013 5:14 AM
    Friday, May 10, 2013 4:45 AM
  • I am not a consumer. I know about watchguard website and I have a case open with there technical support. I plan to install a cert in the future . Typically you can click the continue to bypass certificate error. there some change on IE security that prevents users from making a choice to go to a site who's certificate is not valid. I might add there are some IT pros that have posted about this exact issue on this forum that had some intelligent responses. However they did not resolve my issue
    • Edited by Jeff_1 Friday, May 10, 2013 5:22 AM
    Friday, May 10, 2013 5:16 AM
  • sorry... we/I don't know about watchguard... does the issue persist if you turn it off?

    there are some security settings on the Advanced tab of Internet Options....

    otherwise the other security zone settings are located on the Security tab of Internet Options.

    Perhaps watchguard will post an intelligible response about their products.


    Rob^_^

    Friday, May 10, 2013 6:51 AM
  • The issue really is IE9. Again I reiterate IE9 will not allow you to go to a site that the certificate is invalid. It never reaches a login I can

    login in with any other PC I just click past certificate error.  That was the first place I looked was at internet options. It was no go. I did find this as a possible solution.

    certutil -setreg chain\minRSAPubKeyBitLength 512   it was no go

    found this one will try it next

    1. Go to "run" -> gpedit.msc
    2. Under Computer configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control 

    Panel
    3. Under Prevent ignoring certificate error (set to disable even though it's set to undefined).


    Friday, May 10, 2013 3:27 PM
  • some IT pros that have posted about this exact issue on this forum that had some intelligent responses. However they did not resolve my issue

    The main example that I can recall was on Answers and was resolved mysteriously...

    http://answers.microsoft.com/en-us/ie/forum/ie8-windows_xp/ie8-certificate-error-navigation-blocked/99119d89-921e-47de-8db7-f8db8ab18cb0?page=2&msgId=148c91c8-80bf-40cf-8f25-0c3f8e14658b

    <quote>

    Found that someone else in IT "reimaged" the IE8 test workstation this morning because he "was having problems with ActiveX controls".

    </quote>

    Friday, May 10, 2013 4:10 PM
    Answerer
  • The last comment "was resolved mysteriously" what kind of solution is that? and then to mark it as the answer.  I was hoping someone would post some intelligent

    solutions both comments I have received have not even addressed the issue.  



    • Edited by Jeff_1 Tuesday, May 14, 2013 1:57 PM
    Tuesday, May 14, 2013 1:54 PM
  • The last comment "was resolved mysteriously"

    The thread I linked to contained a diagnostic which is still available.   Then if it works my comment to the OP would also apply to you:

    <quote>
    Please confirm that the procedure at least works with the public site.  Then, as PA Bear implies your problem symptoms would be limited to your one intranet site and nothing else to do with IE by itself.
    </quote>

     
    FYI

    Robert
    ---

    Tuesday, May 14, 2013 9:25 PM
    Answerer
  • Robert please ,note my first post "I get the expected certificate error as I have not installed one"  so a certificate error is expected.

    Note my Previous post  "I can log in in with any other PC I just click past certificate error

    Let me clarify I can take 10 other computers with IE or any other browser and click past the certificate warning by hitting continue and they all work

    1. I know my certificate is not valid

    2. I want to hit continue to the site the "continue link"is missing, gone, kerput, absent, 

    3. Yes in the future I will generate a CSR and install the certificate, in the meantime please anybody suggesting

    Anyone posting Please focus on why the continue on to website link is gone, registry setting, group policy, security option



    • Edited by Jeff_1 Tuesday, May 14, 2013 11:40 PM
    Tuesday, May 14, 2013 11:36 PM
  • Ok fixed it! Let me clarify for all who may read this

    Continue to this website (not recommended).  was missing --> it was replaced with close this webpage link

    I went into programs and features uninstalled IE and reinstalled. That did it. Also of note I had shortcut to my website I deleted it off the desktop and created the link on IE toolbar

    I am mentioning this in case that influenced IE certificate response. Also I tried these from other posts below they did not work

    certutil -setreg chain\minRSAPubKeyBitLength 512   it was no go

    certutil -setreg chain\EnableWeakSignatureFlags 8   it was no go

    1. Go to "run" -> gpedit.msc   
    2. Under Computer configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control 

    Panel
    3. Under Prevent ignoring certificate error (set to disable even though it's set to undefined). it was no go


    • Marked as answer by Jeff_1 Wednesday, May 15, 2013 12:24 AM
    Wednesday, May 15, 2013 12:23 AM
  • I have confirmed that when you have a shortcut on the desktop to the website the continue option is gone however when you type the URL in the browser

    address bar the continue to this website returns. So the lesson is dont put a shorcut on the desktop to a site that the certificate is not valid


    Thursday, May 16, 2013 6:33 PM
  • the lesson is dont put a shorcut on the desktop to a site that the certificate is not valid

    I can't repro that claim (in IE10 on W8 ICIM).   The test site that I pointed you to apparently is no longer offering a fail case.   So, instead I used Fiddler4 for its "Man-in-the-middle" certificate problem case with this URL  https://connect.microsoft.com/

    Then as suggested above I created an Internet Shortcut (.url file) on the Desktop for that and tried it.  Same message, same functionality, including Continue to this website (not recommended), which also works/fails.

    I only have IE10 on W7 too but I'll try to remember to try it when I get back there.
     
    Do you think it has to be IE9 to achieve a repro?  Or does it have to be your Intranet site?   <eg>

     
    FYI

     
    Robert
    ---

    Thursday, May 16, 2013 8:29 PM
    Answerer
  • IE9 on windows 7 on new Dell inspiron laptop, not my site note prior post

    Let me clarify I can take 10 other computers with IE or any other browser and click past the certificate warning by hitting continue and they all work

    • Edited by Jeff_1 Thursday, May 16, 2013 8:46 PM
    Thursday, May 16, 2013 8:44 PM
  • Let me clarify I can take 10 other computers with IE or any other browser and click past the certificate warning by hitting continue and they all work

    So this observation is only about 1 particular machine?   Then please try my repro example using Fiddler.   I don't think it has to be Fiddler4, just one which can try to intercept HTTPS content.  I think it would also be a good idea to be running ProcMon to capture all the registry and file accesses involved for the iexplore.exe tasks (at least).   You could do the same thing with one of your other cases, save both traces and compare them for their significant differences.  Note another symptom from the earlier case was that the OP could see the button source when CSS was disabled, e.g. using View, Style, No Style (Alt-V y N).   See if you have that symptom too?

     
    HTH
     
    Robert
    ---

    Thursday, May 16, 2013 10:15 PM
    Answerer
  • So was there ever an answer to this problem?

    I am setting up some Vista and Win7 PCs with SecureRemote VPN access to some older model Check Point routers. The routers support VPN and have their own embedded certificate, but naturally it is not "trusted".

    The PCs have IE9 and the option for "I'm an adult and understand the risks - let me proceed" are not showing up on the several PCs I am working with... On one of the Vista machines I uninstalled IE9 (which reverted to IE7) and then the "I'm an adult..." option was available and I was able to get everything working ... but I'm not real thrilled about it............

    Thank you in advance if you can lend a hand on this issue!


    • Edited by IT_hoser Friday, February 07, 2014 1:56 AM
    Friday, February 07, 2014 1:55 AM