none
IE 9 timeout

    Question

  • Hello,

    After searching the Web I see that this is a common issue, but I couldn't find the solution yet that worked for me.

    I'm running IE 9 on Windows 7 64 bit. The problem started after I upgraded from IE 8 to 9.

    If the site doesn't respond quickly, the IE displays the message that the "Internet Explorer cannot display the webpage". Troubleshooting connection doesn't do any good. The other browsers like Firefox don't have this problem, so for specific sites I have to use Firefox.

    This is definitely a timeout issue, only sites that are not responding within a few seconds are affected. How to fix this? Can I increase he timeout for IE?

    I've tried to use compatibility mode, increase the number of retries in the registry, run IE with no add-ons - no luck.

    Thank you.


    Sunday, August 07, 2011 9:35 PM

All replies

  • Hi,

     

    To change the default time-out setting for Internet Explorer, follow these steps:

     

    1.    Start Registry Editor.

    2.    Locate the following subkey:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    3.    In this subkey, add a ReceiveTimeout DWORD entry that has a value of (<number of seconds>)*1000. For example, if you want the time-out duration to be 8 minutes, set the value of the ReceiveTimeout entry to 480000 (<480>*1000).

    4.    Restart the computer.

     

    If this issue persists, I suggest you try the methods which mentioned in the following link to troubleshoot this problem:

     

    Error "Internet Explorer cannot display the webpage" when viewing a website in Internet Explorer

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by John Zimdars Tuesday, April 17, 2012 9:45 PM
    • Unproposed as answer by John Zimdars Tuesday, April 17, 2012 9:45 PM
    • Proposed as answer by IECustomizerMVP Tuesday, April 17, 2012 10:25 PM
    Wednesday, August 10, 2011 8:41 AM
  • Hi,

    Thank you, but it didn't work. I've tried all this.

    This is strange, this is a bug in IE 9, everybody I know have the same issue with IE 9. Yet I couldn't find any good solution of this problem, and no fixes from Microsoft.

    Thursday, August 11, 2011 3:01 AM
  • Hi,

      To solve your problem all you have to do is registry edit. Please follow these steps it will definitely help you:


       1. Click Start, click Run, type regedit, and then click OK.
       2. Locate and then click the following key in the registry:
          HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings
       3. On the Edit menu, point to New, and then click DWORD Value.
       4. Type KeepAliveTimeout, and then press ENTER.
       5. On the Edit menu, click Modify.
       6. Type the appropriate time-out value (in milliseconds), and then click OK. For example, to set the time-out value to two minutes, type 120000.
       7. Restart Internet Explorer.

    Thursday, August 11, 2011 5:49 AM
  • Thank you, I'll try this too.

    I assume that I have to choose Decimal, not Hex, and DWORD 64 bit, not 32, correct?

    Peter

    Thursday, August 11, 2011 1:57 PM
  • Tried everything - didn't help. Switching to Firefox, there is no other way. I don't really like Firefox, but at least it's usable.
    Friday, August 12, 2011 1:55 PM
  • Found it.  The registry key is HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ReceiveTimeout

     

    It defaults to 10000 ms ... just increase it to what you think is reasonable... and restart IE and you should be fine.

    • Proposed as answer by Jim Worley Monday, September 09, 2013 1:56 PM
    Wednesday, September 21, 2011 6:21 PM
  • Thank you. I've changed the settings, seems to be working now.
    Thursday, September 22, 2011 1:33 AM
  • Alex

     

    I was getting the "cannot display webpage" when I was waiting for a website to return a listing of airfares. The message came up consistenly after 10 seconds. I checked my registry setting for ReceiveTimeout and it was set to 10 seconds. I changed it to 5 minutes (600 seconds) and my problem went away. Thank you very much because I was about ready to give up on IE. My question now is what should the default setting be (initial setting from Microsoft)? I checked my wife's setting (she doesn't download software) and it is set to 150 seconds so would I be correct in assuming that is the initial setting?

     

    This may have not solved GUDZON's case (I can't understand why) but it solved my case, which seems identical to GUDZON's. 

    Saturday, October 08, 2011 8:58 PM
  • No, this solved my problem as well.

    I don't know what was the default setting, but I started having this problem as soon as I upgraded my IE to version 9. So I guess 10 seconds is the default setting for IE9, but I'm not sure.

    Saturday, October 08, 2011 9:32 PM
  • After spending about 3 hours with MS technician last night - with no results, I found your website and made the change to the receivetimeout and it worked like a charm. Thanks a million.

    Thursday, November 17, 2011 6:37 PM
  • Hi Alex,

    I just wanted to thank you for this post. I was having the same problem as many seem to have with Internet Explorer 9 timing out after 10 seconds and displaying 'Internet Explorer cannot display the webpage'. It was driving me crazy trying to figure out what the problem was. I re-set the browser, disabled all the add ons and as a last act of desperation uninstalled Internet Explorer 9 hoping that it would default to I.E.8  instead, but with no success. I had to do a system restore just to get back online again. I kept searching Google trying to find the solution, but it was only when I searched I.E.9 Timeout that I came across this thread. I followed your instructions and sure enough the ReceiveTimeout was set to 10000. I've now changed it to 120000 (2 minutes) and problem solved.

    This all begs the question that if Microsoft know about this problem why the hell don't they do something about it and change the default settings? There must be thousands of people all having the same problem and either just putting up with it or changing over to a new browser.

    Anyway thanks again, I can switch off my P.C. tonight and breath a sigh of relief that's another problem solved :)

    Mike Smith  

    Wednesday, March 28, 2012 2:34 AM
  • Ken if you see my post above to Alex you'll see that you're solution is correct up to step 4 but without the need to type 'KeepAliveTimeout'. Just go down the list and change the setting of 'ReceiveTimeout' from 10000 to whatever you choose by clicking 'Edit' and then 'Modify. I've set it to 120000 which is 2 minutes, I think if a website hasn't responded by then it's safe to assume there is a problem with the site and not the computer.

    Mike

    Wednesday, March 28, 2012 2:43 AM
  • Thanks to you and other contributers on here for helping me solve the same problem :)

    Mike

    Wednesday, March 28, 2012 2:44 AM
  • Same here, problem solved thanks to Alex. If everyone's timeout is 10 seconds then I think it might be safe to assume that is the default setting which begs the question why don't Microsoft do something about it if they know it's causing all these problems? Coincidentally it kept causing me problems checking airfares too :)

    Mike

    Wednesday, March 28, 2012 2:50 AM
  • My previous fix was to just use Safari. But too often, I'd have to start what I was doing all over. The local MLS only works on IE. That and we need Office Business w/ Outlook 2010 to run our business. Otherwise we would be on Macs.

    I have a couple websites I use that I use to order print material and by design sometimes takes longer than 10 seconds to respond as the server is rendering my input to a proof. Crash, start over. Uggh!

    Last night I wound up ordering two cruises on Expedia because the website took longer, appearantly, than 10 seconds to process payment. $1,000+ almost down the drain as the cruise was non-refundable. Carnival fixed it for us, though.

    Yeah, MS has some quality issues. This and MS Backup crashes sometimes. The solution... find the reparse point that is pointing to an object <eyes glazing over> ... blah, blah... (something like that). Like a ten second default timeout that says, "Network connection problem..." when it really isn't and no way to adjust the timeout in "Internet Options" WTH?! What average consumer can figure this stuff out?

    We have 5 iPhones, a Mac Book Pro and an iPad in our house. Stuff like this is why Apple is a $600 billion company and has the two hottest products on the planet, leaving MS in the dust. 

    Anyway, thanks for the solution. Very easy and seems like it should work.

    Monday, April 09, 2012 12:38 AM
  • Thank GOD for the guys who find a solution and take the time to tell the rest of us about it!

    Error "Internet Explorer cannot display the webpage"

    I reported this as a timeout problem to Delta Airlines over a year ago and their answer was the generic “…use compatibility mode”.  That didn’t help and I’ve wasted 100’s of hours since then chasing it down.  More than likely they have lost millions of dollars from guys like me who just gave up and DROVE THEIR CAR FROM MINNEAPOLIS TO FLORIDA because they couldn’t buy a ticket!

    I'm running IE 9 on Windows 7 64 bit.  For guys like me that need really detailed directions, here’s what worked for me:

    • The Run command no longer appears on the Start menu in this version of Windows but You can access the Run command by pressing the Windows logo key concurrently
      with the “R” key
    • At the run command, type regedit, and then left-click OK.
    • Double-left-click on each entry in the following path till you reach the end:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings

    • Right-click on “ReceiveTimeout” in the alphabetical list on the right
    • Left-click on “Modify”
    • Left-click on “Decimal”
    • Add a zero to extend time-out by a factor of 10.
    • Left-click OK

    PROBLEM SOLVED – WHEW!


    • Edited by John Zimdars Tuesday, April 17, 2012 9:56 PM
    • Proposed as answer by John Zimdars Tuesday, April 17, 2012 9:57 PM
    Tuesday, April 17, 2012 9:53 PM
  • I did the above and it helped a lot but how can I change the number of retries in the registry, i had to do this on the last relase of IE and it worked great

    Peter

    Monday, May 14, 2012 8:46 AM
  • I found the retries setting but it did no good, I deleted IE 9 and did a re install, looks to be working fine now

    Peter

    Monday, May 14, 2012 6:37 PM
  • My PC worked fine with the new install of IE 9 and the increased timeout however this morning my PC reinstalled Microsoft update KB2675157 and all the "Internet Explorer cannot display the webpage" problems came back.

    I deleted KB2675157 and the problem went away !!!!!!!

    Peter

    Tuesday, May 15, 2012 7:28 AM
  • I have no "ReceiveTimeout" entry in the registry in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings.

    Could that be part of the problem? 


    LG

    Tuesday, April 16, 2013 5:09 PM
  • This worked for me - Win7 & IE 10.  I was on a website that prepares a PDF for you and then presents a download link.  Clicking on the link to download the PDF resulted in a short wait, and then the dreaded "Page Not Found" message.  I just increased the ReceiveTimeOut to a factor of 3 times its original value and hey presto - no more problem.
    Monday, September 09, 2013 1:53 PM
  • Great, thats exactly what i am searching on. Thanks :)

    • Edited by Mayyash Thursday, October 10, 2013 6:43 PM
    Thursday, October 10, 2013 6:43 PM
  • Hi,

    I tried setting the keepalivetimeout and receivetimeout keys to 3 hours, but, IE 7 & 8 always times out at 10 minutes. I need IE to wait for a huge query to finish, which can take +- 2 hours.

    Thanks in advance.

    Regards,

    Monday, November 25, 2013 11:16 AM