none
How do I stop shortcuts from opening new windows in IE9?

    Question

  • I know how most people will answer this question and it's not what you think so I'll explain carefully.  This is IE9 and I'll perform the following steps:

    - Load a web page, like this one right here.

    - Drag the icon from the address bar in IE and drop it to the desktop.

    Right there!  The next thing IE9 will do is close the current window and open a new, even stranger one.  Even though my home page is google, suddenly this page becomes "home" and actually, the home button disappears.  The back buttone turns red and I can't go back in my history.  The same thing will happen if I drag that shortcut on my desktop into an IE window.  A new window opens up, no home button, red back buttons...

    How do I stop this?  I don't want a new browser window, especially one that's partially disabled.  It's not:

    - The IE tab setting "Open Links from other programs (currently set to open a new tab in current window)

    - Advanced/Reuse windows for lanching shortcuts (It's checked)

    Where else can I look?

    Thanks!

     

    Friday, October 28, 2011 6:35 PM

Answers

  • I know how most people will answer this question and it's not what you think


    ?

    FWIW I think you created a  Pinned website (aka .website shortcut file) instead of an Internet Shortcut (aka .url file).   You could have done this by dragging and dropping an icon in the Address bar without first pressing Shift-.    ; )

     

    HTH

    Robert Aldwinckle
    ---

    • Marked as answer by meshman333 Monday, October 31, 2011 2:41 PM
    Friday, October 28, 2011 8:10 PM
    Answerer

All replies

  • I know how most people will answer this question and it's not what you think


    ?

    FWIW I think you created a  Pinned website (aka .website shortcut file) instead of an Internet Shortcut (aka .url file).   You could have done this by dragging and dropping an icon in the Address bar without first pressing Shift-.    ; )

     

    HTH

    Robert Aldwinckle
    ---

    • Marked as answer by meshman333 Monday, October 31, 2011 2:41 PM
    Friday, October 28, 2011 8:10 PM
    Answerer
  • If I don't use shift, I get a shortcut on the desktop with this property:

    Pinned Site Shortcut (.website)

    So as you suggested, I held down shift while dragging the icon out.  It creates this:

    Internet Shortcut (.url)

    Ok, weird but I get it.  But the problem still persists.  Whether I click the .website or the .url shortcut, a new IE window opens with no home button and the back button disabled.  How do I stop it from doing this?

     

    Thanks for the reply.

     

    Friday, October 28, 2011 8:21 PM
  • Whether I click the .website or the .url shortcut, a new IE window opens with no home button and the back button disabled.


    I don't know how that would happen.  Even if I have an iexplore.exe open from a Pinned Website (which is what your symptom suggests it is, especially the no home button description), clicking on an Internet Shortcut (aka .url file) opens a normal IE window or new tab in an existing normal window.

    See this thread for some related recent discussion which shows that TabProcGrowth can have some unexpected quirky effects.

    So, this has reminded me that you could look at the command line involved.   E.g. using Task Manager's Processes tab or Process Explorer (procexp) or even better Process Monitor (procmon).

    I imagine that another reason for not having a Home button could be some misapplied administrative registry changes.   ProcMon could help you detect that possibility too.   ; )

     

    FYI

    Robert
    ---

    Saturday, October 29, 2011 3:51 AM
    Answerer