none
IE 9 will not Save Passwords

    Question

  • I am running W7 Home Premium and IE9.  For some reason IE has lost it ability to save Passwords.  I have tried all the obvious stuff that is recommend on various forums - Tools/Internet Options/Advanced/Reset and/or Restore Advance Settings.  I have also made sure the Tools/Internet Options/Content/Auto Complete Settings for "User Names and Passwords" and "Ask Me Before Saving Passwords" are checked.  Nothing helps!  What else can I do to get this thing working.  I have two other machines with the same set up and they work and act like they should.  The machine I am having trouble with is a friend's who has let several "free" virus scanner downloads happen and I am pretty sure one of them has screwed up IE9.  As a last resort is there any way to just delete IE9 and reload it?
    • Edited by Ken429 Monday, October 31, 2011 6:52 PM
    Monday, October 31, 2011 6:38 PM

All replies

  • Maybe something blocks the IE from saving password. Try to boot in Safe Mode with Networking and check the result. If the issue does not occur, reboot and try to launch IE to No Add-ons Mode to troubleshoot.

    Troubleshooting and Internet Explorer’s (No Add-ons) Mode
    http://blogs.msdn.com/b/ie/archive/2006/07/25/678113.aspx

    However if the issue still occurs in Safe Mode, I suggest you clear all IE history and Cookies and then check the result.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, November 02, 2011 7:35 AM
  • I thought when I did the  "Reset" it disabled all the add-ons?

    http://windows.microsoft.com/en-US/windows7/Reset-Internet-Explorer-settings

    Since I did the "Reset", and then ran CCleaner to delete Cookies, etc. and still had the problem where do I go next - delete IE9 and reinstall - delete W7 and restore/reinstall!?  I always create a clean version of W7 using Acronis Backup in case a virus gets me but I really would like to figure out who did what to cause this isolated problem.

    Wednesday, November 02, 2011 11:08 AM
  • I am having the same problem on a brand new laptop.  I want to smash the dang thing.  I have tried every reccomendation several times today, absolutely no luck.  What's really od is sometimes on a few websites the box will pop up asking if I want to save a password or not, but it dissapears too quick to possibly click.  I downloaded Mozilla Firefox and it will not remember passwords either.  PLEASE help!!!!  This is such a simple feature, and it is extremely annoying it won't work, in fact I hate my new computer because of it.

     

    Monday, November 28, 2011 5:51 AM
  • Same problem here. A complete reset doesn't help. One thing I noticed though, when I'm logging on to my iGoogle account the bar at the bottom asking if I want to save the password appears for less than a second and then it's gone. When logging on to Hotmail the bar doesn't even show up. It does the same thing in safe mode.  My clients report the same problem and looks like for the moment the only thing I can recommend to them is to change the web browser. 
    yaro
    • Edited by yaro137 Thursday, December 08, 2011 10:08 AM
    Thursday, December 08, 2011 9:51 AM
  • I'm also encountering this problem..How to fix it..Have ticked and also unticked the ask me before saving password and reset ie setting but to no avail..Microsoft oh microsoft..
    Tuesday, December 20, 2011 6:08 AM
  • Same here with IE9 it wont remember passwords and freezing up all the time ,so now using Firefox with no problems at all
    Tuesday, October 02, 2012 8:36 PM
  • Same problem with YahooMail. Worked for a while on this new laptop. Now nothing. No longer asked to save passwords and ones I saved yesterday no longer appear.
    Friday, October 12, 2012 6:20 AM