none
How do I stop IE 9 from blocking websites from displaying content with security certificate errors?

    Question

  • How do I stop IE 9 from blocking websites from displaying content with security certificate errors? Every site that I visit, I get this message, and I keep clicking and clicking and most of the times, the photographs go blank.

    THen when I try to sign into my facebook page, I get Access denied, you do not have permission to access.

    THis has absolutely got to be the very worst Internet Explorer version that I have ever used in over  20 years of use. I am very VERY close to not using IE atoll and use Firefox, or Chrome or even Safari.

    Saturday, May 12, 2012 9:38 PM

Answers

  • "Set the clock"
    Please check your Date & Time settings.

    Also See Microsoft Windows Help & How-to:
    About certificate errors
    Certificate errors: frequently asked questions

    Regards,

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo

    Sunday, May 13, 2012 6:11 AM
  • Hi,



    This issue can be caused by the high security settings, antivirus or firewall which the access.


    I suggest try the following:


    1. Please also test the issue in Clean Boot and see if it still will pop up again.

    2. Please refer to the following link to configure the security settings in IE:

        Change Internet Explorer Security settings

        also uncheck “Enable protected mode”

    3. You can press F12 to change Browser Mode and Document Mode.

    4. In “internet option”-> “content” click “clear SSL state” and remove certificates

    5. Reset your IE settings. Here is an official article can be referred to.

     

    How to reset Internet Explorer settings

    http://support.microsoft.com/kb/923737


    If the issue persists, please collect the screenshot for us.


    How to capture a screenshot

    ======================

    1. When the message pops up, please press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" Button, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste". Then click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click "Desktop" on the left pane and then click "Save".



    Hope this helps.


    Vincent Wang

    TechNet Community Support

    Monday, May 14, 2012 9:33 AM
    Moderator

All replies

  • "Set the clock"
    Please check your Date & Time settings.

    Also See Microsoft Windows Help & How-to:
    About certificate errors
    Certificate errors: frequently asked questions

    Regards,

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo

    Sunday, May 13, 2012 6:11 AM
  • Hi,



    This issue can be caused by the high security settings, antivirus or firewall which the access.


    I suggest try the following:


    1. Please also test the issue in Clean Boot and see if it still will pop up again.

    2. Please refer to the following link to configure the security settings in IE:

        Change Internet Explorer Security settings

        also uncheck “Enable protected mode”

    3. You can press F12 to change Browser Mode and Document Mode.

    4. In “internet option”-> “content” click “clear SSL state” and remove certificates

    5. Reset your IE settings. Here is an official article can be referred to.

     

    How to reset Internet Explorer settings

    http://support.microsoft.com/kb/923737


    If the issue persists, please collect the screenshot for us.


    How to capture a screenshot

    ======================

    1. When the message pops up, please press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" Button, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste". Then click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click "Desktop" on the left pane and then click "Save".



    Hope this helps.


    Vincent Wang

    TechNet Community Support

    Monday, May 14, 2012 9:33 AM
    Moderator
  • Hello,

    Earlier, I was facing the same issues with Internet Explorer 9.  Whichever website I visit, used to see a pop-up with security certificate errors.  This really annoyed me for many days.  But after synchronizing my PC time with 'time.windows.com', my issue has been resolved. 

    Thanks a lot for the resolution. :)

    Saturday, July 07, 2012 5:50 AM
  • Hello,

    Earlier, I was facing the same issues with Internet Explorer 9.  Whichever website I visit, used to see a pop-up with security certificate errors.  This really annoyed me for many days.  But after synchronizing my PC time with 'time.windows.com', my issue has been resolved. 

    Thanks a lot for the resolution. :)

    Excellent.

    You're welcome. Glad to help and thank you very much for your feedback.

    Regards,

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums
    My MVP Profile

    Saturday, July 07, 2012 5:55 AM
  • I have been having the issue about I9 blocking websites from displaying content with security certificate errors? I hooked at the time on my computer and it was 5pm on july 12th.  I adjusted the time date etc and all is well.

    Thanks for the great info!

    Monday, August 13, 2012 1:41 AM
  • I have been having the issue about I9 blocking websites from displaying content with security certificate errors? I hooked at the time on my computer and it was 5pm on july 12th.  I adjusted the time date etc and all is well.

    Thanks for the great info!

    You're welcome & Thanks for your feedback.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums
    My MVP Profile

    Monday, August 13, 2012 3:50 AM
  • My issue was caused by the Date&Time settings being incorrect Thanks Vincenzo!
    Sunday, August 19, 2012 7:35 PM
  • My issue was caused by the Date&Time settings being incorrect Thanks Vincenzo!
    You're welcome!

    Best of Luck,

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Answers and TechNet Forums
    My MVP Profile

    Monday, August 20, 2012 4:22 AM
  • Could the Asker (TheKnightCall) or a moderator/answerer mark Vincenzo Di Russo's proposed answer as an answer. Three others with the problem have thanked him already, so it's obviously also an answer here.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Monday, August 20, 2012 8:10 PM
  • Obviously, Vincenzo's answer is good and it works.  However, there is a bigger issue here.  Internet Explorer is too unwieldy for the average user to configure and tweak.  I can do it, but most people I know can't because they're not geeks.  I find myself much more willing to use Mozilla because even though I don't like the look and feel of the brower as much as I.E., I don't have to worry about all these stupid security messages and every other POS message I have to deal with when using I.E.  One other thing,  about 2 or 3% of the webpages I try to open in I.E. 9.09 will not open and I have to use Firefox to open them.  I am very tired of this, MS.  I wonder if the management has the brain power to realize what garbage they are putting out.
    Wednesday, September 19, 2012 11:13 AM
  • Frustrating?

    Yes.  No call for choice language though.  With the vitriol we are surrounded by today, let's endeavour to raise the class herein.

    Unwieldly?  

    The workflow pattern doesn't come naturally but, right click is your friend in all kinds of unknown situations.  In time, it gets intuitive.  Thing to remember is just like any other skill, we are not born knowing this stuff.  We learn by doing.

    With regard to this content stuff, for those that are still having it - (your time looks right) just step through the protocol.

      • Right click the clock in your system tray
      • The second option down is the one you want [date/time thingi]
      • Select 'internet time' - the tab furthest to your right
      • Click change settngs button [another dialogue window pops up]
      • Select an internet server from the drop down menu then click the 'update' button.  All done.

    Note.  If it is a work laptop or machine you are using, call IT.  If they are doing their jobs right, you will not be able to perform any of the above.


    • Edited by bossmj Monday, October 15, 2012 11:21 AM
    Monday, October 15, 2012 11:18 AM
  • My clock is correct, but I have the issue.

    Where to disable this message?

    Tks

    Friday, October 26, 2012 6:09 PM
  • My clock is correct, but I have the issue.

    Where to disable this message?

    Tks

    How about disabling protected mode on the desired zone you are browsing?

    I had the same issue of certificate errors because of incorrect time.

    Saturday, December 15, 2012 2:41 PM
  • I have been dealing this problem as well.. and I adjusted my clock..and bam....it worked...that is crazy ..what does that affect that like that

    Sunday, December 23, 2012 6:28 PM
  •  ..what does that affect that like that


    I believe that certification authorization is very much dependend on time, because certs do expire. There are lot of public certs existing in every IE browser.
    Sunday, December 23, 2012 7:23 PM
  • Dude, you are God.

    Searched EVERYWHERE online and the answer was in the lower right-hand corner the whole time.

    Major props!!!!!!

    Thursday, January 03, 2013 3:57 AM
  • Hi,



    This issue can be caused by the high security settings, antivirus or firewall which the access.


    I suggest try the following:


    1. Please also test the issue in Clean boot and see if it still will pop up again.

    2. Please refer to the following link to configure the security settings in IE:

        Change Internet Explorer security settings

        also uncheck “Enable protected mode”

    3. You can press F12 to change Browser Mode and Document Mode.

    4. In “internet option”-> “content” click “clear SSL state” and remove certificates

    5. Reset your IE settings. Here is an official article can be referred to.

     

    How to reset Internet Explorer settings


    If the issue persists, please collect the screenshot for us.


    How to capture a screenshot

    ======================

    1. When the message pops up, please press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" Button, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste". Then click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click "Desktop" on the left pane and then click "Save".



    Hope this helps.


    Vincent Wang

    TechNet Community Support


    I did everything on this post, still I am having the issues with https error. Even with google chrome.

    Is this an OS issues? I am using Windows 7 Pro. x86. Thank you.

    Monday, February 11, 2013 5:10 PM
  • Awesome answer!  I had a similar problem and setting the correct time fixed my issue! More power to you.

    Monday, July 01, 2013 5:41 PM
  • Hi All,

    I tried all a/m solutions and still didn't work for me :(((

    Monday, August 12, 2013 4:33 AM
  • I did the RESET in the internet options and that was the quickest fix.  NO more annoying "SHOW CONTENT" pop up.  Thank you everyone!
    • Proposed as answer by AnupamKol Thursday, October 24, 2013 10:02 AM
    • Unproposed as answer by AnupamKol Thursday, October 24, 2013 10:02 AM
    Friday, September 13, 2013 9:20 PM
  • My Problem has resolved after Disable the Anti-Virus Firewall. You can try it.

    Thanks

    Anupam

    • Edited by AnupamKol Thursday, October 24, 2013 10:04 AM
    Thursday, October 24, 2013 10:04 AM
  • Hello , I am having this new problem for almost 3 weeks, it didn't happened before and I am used to go into this website on a regular basis. I have tried all the options you have indicated above, but it didn't work for me, I have tried to enclosed the screenshot of the website which I cannot access anymore, but also with this the system doesn't enable me to do so due to some "verify" reasons. looking forward for your urgent assitance. thanks Daniela
    Monday, October 28, 2013 8:55 AM
  • Hello again, just to be accurate, the problem I am having is with IE 10. THANKS,
    Monday, October 28, 2013 8:58 AM
  • Hi All,

    I also did the "Reset" and it worked!  Thank you!  I did the clock synchronize and it did not work, but the Reset process described above did work.

    Thursday, November 14, 2013 5:22 PM
  • This worked like a cham

    Saturday, January 04, 2014 8:00 AM
  • Thank You! I was going crazy with adjusting my security settings & my anti virus forgetting that I changed the date for some (unmentionable) reason the other day. Thanks! The "Set the clock" answer made my day! :D

    u da man!

    Monday, March 03, 2014 3:59 PM
  • You're welcome & Thanks for your feedback.


    Regards,


    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Community and TechNet Forums
    My MVP Profile

    Monday, March 03, 2014 4:15 PM
  • Frustrating?

    Yes.  No call for choice language though.  With the vitriol we are surrounded by today, let's endeavour to raise the class herein.

    Unwieldly?  

    The workflow pattern doesn't come naturally but, right click is your friend in all kinds of unknown situations.  In time, it gets intuitive.  Thing to remember is just like any other skill, we are not born knowing this stuff.  We learn by doing.

    With regard to this content stuff, for those that are still having it - (your time looks right) just step through the protocol.

      • Right click the clock in your system tray
      • The second option down is the one you want [date/time thingi]
      • Select 'internet time' - the tab furthest to your right
      • Click change settngs button [another dialogue window pops up]
      • Select an internet server from the drop down menu then click the 'update' button.  All done.

    Note.  If it is a work laptop or machine you are using, call IT.  If they are doing their jobs right, you will not be able to perform any of the above.



    bossmj I commend your good nature and solution orientation, but the commentor you tried to calm down seemed dead on bullseye to me. They were not profane, I might change "brains to realize" to "integrity to care". Btw I have the problem, have run thru these and more solutions, still have it. This is NOT correct. And its become SOP more and more w/ MS. If in a blackout I signed an employment contract w/ MS and am unaware then I apologize, but if thats the case where is MS mailing my checks? I realize its impossible to roll out a perfect product every time. I also realize skimping on R & D guarantees more problems. I paid $ to MS for a finished if imperfect product and more and more it seems they shirk their end of that agreement, and as often as not dodge and weave even acknowledging some of the worst problems whatsoever in support forums. I dont mean one case, I mean its plainly how theyve chosen to do business. They force us to update browsers, media players and whatever when many of us, me for one, find every single "update" inferior to the existing one. And as they said not everyone is, wants to become or should be expectd to become super savvy. Its like expecting anyone who buys a car to be a certified auto mechanic. Its unethical and we ought be outraged
    Monday, April 14, 2014 8:51 AM