locked
"There is a problem with this website's security certificate"

    Question

  • "There is a problem with this website's security certificate".... that's the error message on IE7 when I try to logon to any web services whether is secured website or non secure sites.

     

    I had tried to clear the SSL, checked the system clock and the certificate duration, it's still valid until 2008.

    I couldn't able to add the selected website to trusted sites due to organization policies. At such, is there any workaround to resolve the problem?

     

     

    Friday, August 03, 2007 7:20 AM

Answers

  • In Vista, we can re-enable the Group Policy in order to continue to update the certificates.

    Launch the GPedit in administrator mode, click on Computer Configuration. Then, click on Administrative Templates and follow by System. Select Internet Communication Management and open the Internet Communication Settings.

     

    Select "turn off automatic root certificates update" and choose the state as disabled or not configured. Hence when you surf any website that required a certificate update, it will contact Windows Update Web site automatically.

     

    Monday, September 24, 2007 3:16 PM

All replies

  •  

    One of the reason it may happen is due to the Group Policy disabled the automatic update for the certificates.

    By enabling the to automatically update the certificates, the security alert message will suppress. It is workable if copy a set of good working condition certificates and installed it to the problematic computer. However, this method works for few websites only.

    Monday, September 24, 2007 2:59 PM
  • In Vista, we can re-enable the Group Policy in order to continue to update the certificates.

    Launch the GPedit in administrator mode, click on Computer Configuration. Then, click on Administrative Templates and follow by System. Select Internet Communication Management and open the Internet Communication Settings.

     

    Select "turn off automatic root certificates update" and choose the state as disabled or not configured. Hence when you surf any website that required a certificate update, it will contact Windows Update Web site automatically.

     

    Monday, September 24, 2007 3:16 PM
  • Hi

    I dont know if this helps anyone with this problem

    but I have encountered it.

    1/ check to see if the time and date on your PC is correct

    if not reset the Bios Clock/

    this cured the problem for me, certificates work on a time and year principle

    if the clock is out the certs do not appeaar to function.

    If this problem occurs again check the battery on your mother board this controls

    the time keeping on your PC

     

    Plinyold

    Wednesday, January 16, 2008 9:33 PM
  •  

    ISSUE: " There is a problem with this website's security certificate". The security certificate presented by this website was not issued by a trusted certificate authority".

     

    The issue resolution as follows :

     

    1. In Windows Internet Explorer 7, click Continue to this website (not recommended). 80% the issue would be resolved once you follow this step.
    If not, you will see a red Address Bar and a certificate warning appear, keep clicking on next & cu will get a PHISHLING FILTER. Click on "YES", close ie and re- open.

    2. Another cause for this issue is that the computer's time/ date could be wrong, because in that case, the certificates may show up as expired. Change the computers time to a different date and month and revert back to the old one (Believe me, it works !!!)

    4. In rare scenarios, resetting modem & for Windows Vista users, right clicking on Internet Explorer icon, "Select Run as Administrator." has worked.

     

    In Internet explorer 6, none gets the error "There is a problem with this website's security certificate"...

     

    In Internet Explorer 6, the user will only receive a message that resembles the following:

     

    "Information you exchange with this site cannot be viewed or changed by others. However there is a problem with the site's security certificate."

    The security certificate was issued by a company you have not chosen to trust. View the certificate to determine whether you want to trust the certifying authority.

     

    The error "There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority." is dedicated for ie 7.

     

    This is infact caused due to Phishing Filter in IE 7 for enhanced security.

    more info on Phishling Filter : https://phishingfilter.microsoft.com/faq.aspx

     

    APPLIES TO:

    • Windows Internet Explorer 7 in Windows Vista

    • Windows Internet Explorer 7 for Windows Server 2003

    • Windows Internet Explorer 7 for Windows XP

     

    Reference websites:

    support.microsoft.com/kb/931850/en-us

                               msmvps.com/blogs/donna/archive/2007/02/09/ie-there-is-a-problem-with-this-website-s-security-certificate.aspx

    http://www.ie-vista.com/secure.html#cert%20problems

    Regard's,

     

    RATISH SEKHARAN NAIR

    Monday, January 28, 2008 1:07 AM
  •  

    I'm having the same problem with vista but only when I'm connecting using wireless to get to hotmail, others like yahoo works just fine.  The clock is set correctly.  If I plug it into the lan port it works just fine.  Can anyone please assist?

     

    There is a problem with this website's security certificate.

    The security certificate presented by this website was not issued by
    trusted certificate authority
    Security certificate problems may indicate an attempt to fool you o
    intercept any data you send to the server.
    We recommend that you close this webpage and do not continue to thi
    website
    Click here to close this webpage
    Continue to this website (not recommended)
    More information*-

    Thanks.

    Tuesday, January 29, 2008 3:11 PM
  •  

    This was exacly what was wrong with my PC.  My Bois calendar was in 2100. Dont know how it got there but I fixed it and that got rid of the website security certificate problem.   Thanks Plinyold!

    Friday, March 07, 2008 11:31 PM
  • Hi plinyold,

    It sure worked like a charm ...

    Thanks a Million ...

    Tuesday, March 25, 2008 5:39 PM
  •  plinyold wrote:

    Hi

    I dont know if this helps anyone with this problem

    but I have encountered it.

    1/ check to see if the time and date on your PC is correct

    if not reset the Bios Clock/

    this cured the problem for me, certificates work on a time and year principle

    if the clock is out the certs do not appeaar to function.

    If this problem occurs again check the battery on your mother board this controls

    the time keeping on your PC

     

    Plinyold

    Hi plinyold,

    It sure worked like a charm ...

    Thanks a Million ...

    Tuesday, March 25, 2008 5:47 PM
  • Thank You RATISH, corrected my problem!

    Opa

     

    Tuesday, April 01, 2008 4:28 AM
  • It worked for me! Thanks!

     

    Thursday, April 03, 2008 3:23 PM
  • hello I opened the internet page of my company and I got the message " There's a problem with this website's security certificate".

    I click Continue to this website (not recommended). the the page from my company open with a purple Certificate warning error  at the address bar..

    After few days I contined to use my company page the same way, until now because the page stop working, the only thing I get is the Microsoft office outlook web access, but isnt working. Before I used to get a white window asking me for password and username.

    I tried to click on the certificate error but i get the message Untrusted certificate" I dont see anything about the PHISHLING FILTER.

    i already reset my modem and still didnt work.

    I changed the date abnd time and still nothing..

    I was told that my problem was for the antivirus program , but I already unstalled the program and still not working

    Will someone please help me this is the page of my company and it seems that the only one with a problem is me!!!

    Friday, September 05, 2008 5:17 PM
  •  

    I have windows vista
    Friday, September 05, 2008 5:18 PM
  • I'm having the same problem... I would have spent hours thinking my PC had a virus or something but thankfully I was looking at MI6's website at the time it first occurred.

     

    The time and date on the clock are correct, the phishing filter is off. Microsoft themselves seem to be offering no explaination... Someone please Heeeeeeelllllllllllpppppp.

    Saturday, November 22, 2008 10:34 AM
  •  

    ISSUE: " There is a problem with this website's security certificate". The security certificate presented by this website was not issued by a trusted certificate authority".

     

    The issue resolution as follows :

     

    1. In Windows Internet Explorer 7, click Continue to this website (not recommended). 80% the issue would be resolved once you follow this step.
    If not, you will see a red Address Bar and a certificate warning appear, keep clicking on next & cu will get a PHISHLING FILTER. Click on "YES", close ie and re- open.

    2. Another cause for this issue is that the computer's time/ date could be wrong, because in that case, the certificates may show up as expired. Change the computers time to a different date and month and revert back to the old one (Believe me, it works !!!)

    4. In rare scenarios, resetting modem & for Windows Vista users, right clicking on Internet Explorer icon, "Select Run as Administrator." has worked.

     

    In Internet explorer 6, none gets the error "There is a problem with this website's security certificate"...

     

    In Internet Explorer 6, the user will only receive a message that resembles the following:

     

    "Information you exchange with this site cannot be viewed or changed by others. However there is a problem with the site's security certificate."

    The security certificate was issued by a company you have not chosen to trust. View the certificate to determine whether you want to trust the certifying authority.

     

    The error "There is a problem with this website's security certificate. The security certificate presented by this website was not issued by a trusted certificate authority." is dedicated for ie 7.

     

    This is infact caused due to Phishing Filter in IE 7 for enhanced security.

    more info on Phishling Filter : https://phishingfilter.microsoft.com/faq.aspx

     

    APPLIES TO:

    • Windows Internet Explorer 7 in Windows Vista

    • Windows Internet Explorer 7 for Windows Server 2003

    • Windows Internet Explorer 7 for Windows XP

     

    Reference websites:

    support.microsoft.com/kb/931850/en-us

                               msmvps.com/blogs/donna/archive/2007/02/09/ie-there-is-a-problem-with-this-website-s-security-certificate.aspx

    http://www.ie-vista.com/secure.html#cert%20problems

    Regard's,

     

    RATISH SEKHARAN NAIR

     



    Thank you
    Saturday, January 02, 2010 9:37 PM
  • After reading many posts with computer mumbo jumbo I finally found  yours. This is absolutely awesome! My computer is fixed. Thank you so much. Freen Been
    Wednesday, January 06, 2010 5:09 PM
  • Thank you for the information you provided. I've had this problem for a while with my IE8. I solved it by putting in the correct time. I'm not sure how this happened but the year on my computer was 2007. Not sure how that happened but once I updated to the correct time problem went away.

    Thanks again.
    Tuesday, February 16, 2010 12:39 AM
  • thank you , I changed the time and date to the correct one and the problem didn't apear any more.

    Friday, April 02, 2010 4:49 PM
  • HI ,

     GoTo : -> Tools -> Internet options -> select 'content tab' and click certificate button (open one window)  , click -untrusted publisher tab  and remove yr certificate

     

     

     

    Thanks

     Santhana .

    Tuesday, May 11, 2010 9:34 AM
  • I am using Windows XP Home with Internet Explorer 8.

    When I try to access a secure web page, I am getting the message: " There is a problem with this website's security certificate". The security certificate presented by this website was not issued by a trusted certificate authority".

    This problem only occurs with Internet Explorer 8 and not with Firefox

    My brother does not get this problem with IE8 on his computer

    My date and time are correct

    So far this has not happened to me on any other web page

    There is a message against the certificate that says "This certificate cannot be verified up to a trusted certification authority".

    I have looked at the certificate and it looks fine.

    I have verified that the certificate is, in fact, issued by a trusted certification authority (Entrust.net) and that there is no problem with the web page.

    I have tried to install the certificate. It installs fine, but that doesn't solve the problem.

    Conclusion: Something is missing in the registry or an IE8 file that would allow it to recognise Entrust.net as a trusted certification authority.

    Most of the solutions posted so far in this thread do not resolve the problem; they simply bypass it by switching off levels of security in IE8, leaving IE8 exposed to security threats.

    There are no certificates under the 'Untrusted Publisher' tab.

    The certificate appears under the 'Other People' tab.

    What I am looking for is a way to get IE8 to recognise 'Entrust' as a trusted certification authority. Until that happens, the problem will not be solved.

     

    Tuesday, June 15, 2010 5:59 PM
  • That was the ticket!  Thanks for the post!!!
    Tuesday, July 13, 2010 12:56 AM
  • YES!!! Thanks... I forgot that I changed the date on my computer... (don't ask me why...).

    This solved my problem.

    Thursday, August 12, 2010 6:22 PM