locked
IE8 can't use ftp proxy (Frox)

    General discussion

  • I test download file by protocal ftp and user ftp proxy on linux gateway. I use ipcop and install addon copfilter for enable frox . But it can't connecting to anywhere. And I debug my proxy when I connecting ftp.

    1. Use command ftp to ftp server
    • Start --> run > cmd and Enter
    • Type ftp to my host
    • Send username and password
    • get file
    This step complete.

    Debug log my ftp proxy(Frox).

    Tue Jul 14 23:28:29 2009 frox[27367] Connect from 192.168.2.234
    S: 220 Frox transparent ftp proxy. Login with username[@host[:port]]
    Tue Jul 14 23:28:33 2009 frox[27367] ... to 203.146.140.xxx()
    s: 220 ProFTPD 1.3.2 Server (ProFTPD By xxxxxx) [203.146.140.xxx]
    C: USER username
    S: 331 Password required for username
    C: PASS password
    S: 230 User username logged in
    C: TYPE I
    S: 200 Type set to I
    C: TYPE A
    S: 200 Type set to A
    C: PORT 222,123,35,220,197,153
    S: 200 PORT command successful
    C: NLST
    S: 150 Opening ASCII mode data connection for file list
    .... S: 226 Transfer complete
    C: TYPE I
    S: 200 Type set to I
    C: PORT 222,123,35,220,196,235
    S: 200 PORT command successful
    S: 150 Starting transfer
    ....................................................................... S: 226 Transfer complete
    Tue Jul 14 23:29:12 2009 frox[27367] 192.168.2.234 DOWNLOADED ftp://username@203.146.140.xxx/
    C: QUIT
    S: 221 Goodbye.

    2. Use Ftp by IE8
    • Type URL  like this  ftp://username:password@203.146.140.xxx/
    For browse my file IE8 will show like this.
      Internet Explorer cannot display the webpage 
       
       What you can try: 
        Diagnose Connection Problems  
     
         More information 
    
    This problem can be caused by a variety of issues, including: 
    
    •Internet connectivity has been lost.
    •The website is temporarily unavailable.
    •The Domain Name Server (DNS) is not reachable.
    •The Domain Name Server (DNS) does not have a listing for the website's domain.
    •There might be a typing error in the address.
    •If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.
    
    For offline users
    
    You can still view subscribed feeds and some recently viewed webpages.
    To view subscribed feeds 
    
    1.Click the Favorites Center button , click Feeds, and then click the feed you want to view.
    
    To view recently visited webpages (might not work on all pages) 
    
    1.Click Tools , and then click Work Offline.
    2.Click the Favorites Center button , click History, and then click the page you want to view.
    
     
    
    And Debug log my ftp proxy(Frox).
    Tue Jul 14 23:29:23 2009 frox[27367] Client closed connection
    Tue Jul 14 23:29:23 2009 frox[27367] Closing session
    Tue Jul 14 23:30:15 2009 frox[27623] Connect from 192.168.2.234
      S: 220 Frox transparent ftp proxy. Login with username[@host[:port]]
    Tue Jul 14 23:30:15 2009 frox[27623] ... to 203.146.140.xxx()
      s: 220 ProFTPD 1.3.2 Server (ProFTPD By xxxxxx) [203.146.140.xxx]
      C: USER username  S: 331 Password required for username  C: PASS password  S: 230 User username logged in
      C: CWD /
      s: 250 CWD command successful
      S: 250 CWD command successful
      C: TYPE A
      S: 200 Type set to A
      C: PASV
      s: 227 Entering Passive Mode (203,146,140,26,184,114).
      S: 227 Entering Passive Mode (192,168,2,254,196,35)
    Tue Jul 14 23:30:16 2009 frox[27623] Client closed connection
    Tue Jul 14 23:30:16 2009 frox[27623] Closing session
    Tue Jul 14 23:30:16 2009 frox[27624] Connect from 192.168.2.234
      S: 220 Frox transparent ftp proxy. Login with username[@host[:port]]
    Tue Jul 14 23:30:16 2009 frox[27624] ... to 203.146.140.xxx()
      s: 220 ProFTPD 1.3.2 Server (ProFTPD By xxxxxx) [203.146.140.xxx]
      C: USER username  S: 331 Password required for username  C: PASS password  S: 230 User username logged in
      C: CWD /
      s: 250 CWD command successful
      S: 250 CWD command successful
      C: TYPE A
      S: 200 Type set to A
      C: PASV
      s: 227 Entering Passive Mode (203,146,140,26,218,178).
      S: 227 Entering Passive Mode (192,168,2,254,196,75)
    Tue Jul 14 23:35:16 2009 frox[27624] Connection timed out.
    Tue Jul 14 23:35:16 2009 frox[27624] Closing session
    

    I test this solotion on IE6 IE7 it work have no anymessage can browse or get file.

    This problem is on Windows 7 and any kind of windows if install IE8 too.
    And when install IE8 this problem will happen on any browser Firefox Safari etc, but when uninstall IE8 it have no problem anymore.



    Tuesday, July 14, 2009 4:55 PM

All replies

  • i have same problem with frox.

    if i set IE8 to use active mode it`s work fine.

    Go to the Tools menu in Internet Explorer and select Internet Options. In the dialogue box that opens, click on the Advanced tab. Scroll down until you see "Enable FTP folder view" in the Browsing section and make sure it is checked. Uncheck the box  "Use Passive FTP.".

    for use in corporate envirement i use next adm template for AD group policy.

     

    CLASS USER
    
    CATEGORY !!Internet
    
    CATEGORY !!FTP
    POLICY "Use Passive FTP"
    KEYNAME "Software\Microsoft\FTP"
    VALUENAME "Use PASV"
    VALUEON "Yes"
    VALUEOFF "No"
    END POLICY
    
    POLICY "open in Explorer Folder View"
    KEYNAME "SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_INTERNET_SHELL_FOLDERS"
    VALUENAME "iexplore.exe"
    VALUEON NUMERIC 1
    VALUEOFF NUMERIC 0
    END POLICY
    END CATEGORY
    
    CATEGORY !!ProxySettings
    POLICY "Use HTTP 1.1"
    KEYNAME "Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings"
    VALUENAME EnableHttp1_1
    VALUEON NUMERIC 1
    VALUEOFF NUMERIC 0
    END POLICY
    
    POLICY "Use HTTP 1.1 Through Proxy Connections"
    KEYNAME "Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings"
    VALUENAME ProxyHttp1.1
    VALUEON NUMERIC 1
    VALUEOFF NUMERIC 0
    END POLICY
    END CATEGORY
    
    END CATEGORY
    
    [strings]
    Internet="Internet Explorer Advanced Settings"
    ProxySettings="HTTP 1.1 Settings"
    FTP="FTP"
    

     

    enjoy!

     

    Saturday, November 13, 2010 4:00 PM