none
IE11 hangs on startup even with all add-ons disabled

    Question

  • Hi,

    I'm working at Taipie Veterans General Hospital, where all workstations are not allowed to upgrade  to IE11 because of system crash and incompatibity issues.

    My personal laptop (Windows 7 64-bit), however, was upgraded to IE11 about three days ago.   IE11 run well initially but hangs on startup in the second day of upgrade.   I was able to start the IE11 using the safe mode without any add-ons.   So I  disables on all add-ons in the options and then tried to re-start the IE11 in normal mode.  It just hanged on starup with blank menu bar even though I had already disabled all add-ons. 

    There was no log of error in the eventvwr.

    I searched for possible solutions over the net and tried the following steps without success:

    1. Clear all the cache and temporary files.
    2. Disable protected mode in the security tab of internet option

    Please help, thanks in advance.

    I think I might have to revert to and stay put with IE10, just like my Hopstial did.

    CY




    • Edited by cyshiau Saturday, November 30, 2013 4:56 AM Typo Error on Title
    Saturday, November 30, 2013 3:27 AM

Answers

  • Hi Robert,

    Thanks for you several advice and recommendations in the past few days. 

    I finally figured it out that the IE11 hang with blank menu bar is caused by the corrupted user profile.

    After repairing my profile,  I've got IE11 running smoothly with all add-ons.

    I just don't know why IE11 is so sensitive to damaged profile.

    Thanks again for your help.

    CY

    • Marked as answer by cyshiau Thursday, December 05, 2013 2:32 PM
    Thursday, December 05, 2013 2:30 PM

All replies

  • hanged on starup with blank menu bar even though I had already disabled all add-ons. 

    You could try using ResMon.exe to see which task is hung and why.  Hint: right-click Analyze wait-chain...

    Otherwise, my guess would be that there is different processing when add-ons are disabled versus when no add-ons are allowed and that is what is causing the symptom.  In that case, instead of just disabling add-ons it might be necessary to uninstall them too.  As a further guess I would try removing Flash and Acrobat first and other programs which may be trying too hard to do things their way instead of a standard way.  You can always reinstall them again if the test fails.  In fact you can try reinstalling them again if the test succeeds and then hopefully will be lucky to discover that they get their hooks set more cleanly in the new environment.   ; )



    Robert Aldwinckle
    ---

    Saturday, November 30, 2013 4:43 PM
    Answerer
  • Thanks for your advise.

    I did uninstall the Adobe Flash and some other add-ons one-by-one (including google bar, bing bar, Divx bar, PDF architect, asus web extensions).  However, the IE11 still hanged.  Running out of patience,  I uninstalled the IE11 and re-installed the IE10.  

    If I reinstall the IE11, I will definitively try your susggestion of ResMon.exe to see which task is hung.

    Thansk again.

    CY

    Sunday, December 01, 2013 1:55 AM
  • Following your recommendation, I re-installed the IE11 and used ResMon.exe to see what happened.

    The CPU usage for all IE11 processses were 0.  Right click on the IE11 wait chain showed that IE11 is normally executing.

    I have to revert back to IE10 and wait for Microsoft to have a clear solution for this issue.

    Thanks again for your advise.

    CY

    Sunday, December 01, 2013 2:43 AM
  • Hi CY,

    In order to eliminate the software conflicts, I would like to suggest you try to boot into safe mode with networking to check the result.

    Hope it helps.

    Regards.

    Blair Deng


    Blair Deng
    TechNet Community Support


    Tuesday, December 03, 2013 9:11 AM
    Moderator
  • Hi Blair,

    I followed your recommendation and booted into safe mode.  The IE11 still hanged (blank page with blank menu bar) with all add-ons disabled in safe mode, even though the ResMon still reported that IE11, wth 0% CPU usage,  is running without any error.  As a result, there was no log of any error in eventvwr.

    Thanks.

    CY

    Tuesday, December 03, 2013 1:03 PM
  • There are at least 7 threads in less than 24 hours citing problems with IE11.

    Will Microsoft software engineers look into the problems?  Or, are we just S.O.L.?

     

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Tuesday, December 03, 2013 9:02 PM
  • I followed your recommendation and booted into safe mode.  The IE11 still hanged (blank page with blank menu bar) with all add-ons disabled in safe mode, even though the ResMon still reported that IE11, wth 0% CPU usage,  is running without any error.

    So that doesn't sounds like a hang, just perhaps a rendering problem.  Try using the Developer Tools to find out what the source is.  E.g. use the Emulation tab to try changing Document mode or User-Agent string to find a better emulation.

    If the site is publicly accessible (or perhaps even if it isn't) and you need to have a persistent emulation better than just IE7 you could report it to Microsoft using the following site and wait to see if the Compatibility list would be updated so you could start using it normally (e.g. unfortunately the Developer Tools, Emulation choice does not persist.  The one that you manually add a site to the Compatibility View list may persist, but it would only be an IE7 emulation.)

    http://www.modern.ie/en-us/compat-issue-report

    Good luck

    Robert
    ---



    Robert Aldwinckle
    ---

    Wednesday, December 04, 2013 1:50 AM
    Answerer
  • Hi Robert,

    The menu bar is blank and dead. So is te F12 hot key.  I was not able to start the Developer Tools by pressing F12.  The Developer Tools are accessible if IE11 is in safe mode without add-ons.

    The home page is blank and there should be no rendering issue.

    BTW, my windows 7 64-bit is Chinese / Taiwanese version.  I assume that this should not be the problem.

    Thanks but no luck.

    CY


    • Edited by cyshiau Wednesday, December 04, 2013 1:39 PM Typo Error
    Wednesday, December 04, 2013 1:12 PM
  • The Developer Tools are accessible if IE11 is in safe mode without add-ons.


    I thought you had implied that you still saw a problem symptom in safe mode but that there was no sign of a hang (e.g. using ResMon.exe).   Perhaps you picked the wrong task thread to look at? 

    If instead you have two otherwise identical cases to compare you could look at what is loaded.  ResMon can be used for that too.  Unfortunately you can not use ProcMon in safe mode because its driver won't be available then.



    Robert Aldwinckle
    ---

    Wednesday, December 04, 2013 5:10 PM
    Answerer
  • Hi Robert,

    Thanks for you several advice and recommendations in the past few days. 

    I finally figured it out that the IE11 hang with blank menu bar is caused by the corrupted user profile.

    After repairing my profile,  I've got IE11 running smoothly with all add-ons.

    I just don't know why IE11 is so sensitive to damaged profile.

    Thanks again for your help.

    CY

    • Marked as answer by cyshiau Thursday, December 05, 2013 2:32 PM
    Thursday, December 05, 2013 2:30 PM
  • I have the same problem. How did you repair you profile?
    Would be of great help to know.

    Thx!

    Friday, February 28, 2014 10:23 AM