none
Problem with Page set-up with Internet Explorer 11 in Windows 7

    Question

  • I have upgraded from IE10 to IE11.  I have not changed Page Setup in any way, so my current settings are as follows:

    Page size:       A4
    All Margins:    19.05 millimetres
    Shrink to Fit:   Enabled
    Header:          Title       Empty      Page # of Total Pages
    Footer:            URL       Empty      Date and Time (in long format)

    The upgrade to IE11 is causing printing problems.

    With IE10, the footer used to display the URL of the web page.  With IE10, the footer shows the location of a temporary file on my computer.

    So when I print this page, the URL appears as file:///C:/USERS/[User name]/AppData/Local/Temp/Low/XRP72PG2..., instead of "http://social.technet.microsoft.com/Forums/ie/en-US/newthread?category..."

    The location of the temporary file on my computer is totally useless.  Is there any way of reverting to the previous printer format?

    -   !

    

    "#"$! %&&'$-(&$)*+, - ...     

    Monday, November 25, 2013 7:25 PM

Answers

  • Changing the view setting to "No style" did not help.

    Unfortunately that would not work because the printer preview switches to its own CSS.  In IE10 the Developer Tools have a Disable All CSS command which can work around this in case it actually does help.  Unfortunately, in IE11 that function has been removed from its DT.  I'm not sure how you could prevent use of the printer preview CSS now.

    Perhaps you will have to add your own manual override each time you want to have the page footer say something else?  <eg>



    Robert Aldwinckle
    ---

    • Proposed as answer by Harkanwar Singh Tuesday, January 21, 2014 8:24 AM
    • Unproposed as answer by Harkanwar Singh Tuesday, January 21, 2014 8:29 AM
    • Marked as answer by BobTroll Tuesday, January 21, 2014 9:09 AM
    Monday, December 09, 2013 1:51 PM
    Answerer

All replies

  • Hi,

    Whats your default printer?

    try changing it to the MS XPS printer.

    try uncheck "Do not save encrypted files to disk" on the advanced tab of Internet OPtions.

    try Tools>Manage Addons>Show all addons... ensure that your pdf and xps addons are enabled.

    IE11 by default runs in Enhanced Protected Mode and x86 addons are disabled... try adding the unnamed website to your trusted sites list to allow x86 addons to run on that site.

    If you have a PDF printing addon installed, check with the vendors website for updates and x64 versions.

    Post consumer questions about IE to http://answers.microsoft (Help>Online Support menu from IE). Include with your questions the FULL address of any websites you are having issue with.

    If you are using a company network, in the first instance contact your company's internal support.

    Regards.


    Rob^_^

    Tuesday, November 26, 2013 12:03 AM
  • Hi,

    Based on your description, I would like to suggest you resetting IE settings and check the “delete personal files” settings to check the issue.

    How to reset Internet Explorer settings

    http://support.microsoft.com/kb/923737

    Please understand that reset Internet Explorer to its default configuration. This step will also disable any add-ons, plug-ins, or toolbars that are installed.

    Hope it works.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Wednesday, November 27, 2013 2:42 AM
    Moderator
  • I have been away from home for the past few weeks, so I have only just been able to try the various suggestions.  Re-setting Internet Explorer to its default configuration (and deletion of personal files) did not resolve the problem.

    My default printer is an HP LaserJet 1018.  Other installed printers include the CutePDF Writer and the Microsoft XPS Document Writer.  It makes no difference whether I select the HP LaserJet - or print the document as an XPS or PDF file.  The result quotes details of the local file at the bottom of each page, instead of the URL.

    Print preview also displays details of the local file, instead of the URL.

    There seems to be a fundamental difference between IE10 and IE11, which affects the way the browser prepares web pages for printing - and submits them to the printer (any printer).

    I would add that when I print from Google Chrome, the printed version still shows the URL correctly, at the foot of every page.  Consequently, I am having to use Chrome for those web pages that I need to print.




    • Edited by BobTroll Sunday, December 08, 2013 10:08 PM
    Sunday, December 08, 2013 10:06 PM
  • Hi,

    can you provide the url of the web page you are trying to print please.

    There seems to be a fundamental difference between IE10 and IE11, which affects the way the browser prepares web pages for printing - and submits them to the printer (any printer).

    yep... media queries...

    test in IE by turning off styles... View>Style>No Style.


    Rob^_^

    Monday, December 09, 2013 4:33 AM
  • The problem affects all URLs.

    For instance, I am typing this reply at http://social.technet.microsoft.com/Forums/ie/en-US/4226e470-a0d6-41c7-8af2-15f6c9e34807/problem-with-page-setup-with-internet-explorer-11-in-windows-7?forum=ieitprocurrentver.

    However, print preview (and subsequent prints) display the URL as file:///C:/Users/[User Name]/AppData/Local/Temp/Low/1PSRQDUQ.htm.

    Changing the view setting to "No style" did not help.

    Monday, December 09, 2013 8:48 AM
  • Changing the view setting to "No style" did not help.

    Unfortunately that would not work because the printer preview switches to its own CSS.  In IE10 the Developer Tools have a Disable All CSS command which can work around this in case it actually does help.  Unfortunately, in IE11 that function has been removed from its DT.  I'm not sure how you could prevent use of the printer preview CSS now.

    Perhaps you will have to add your own manual override each time you want to have the page footer say something else?  <eg>



    Robert Aldwinckle
    ---

    • Proposed as answer by Harkanwar Singh Tuesday, January 21, 2014 8:24 AM
    • Unproposed as answer by Harkanwar Singh Tuesday, January 21, 2014 8:29 AM
    • Marked as answer by BobTroll Tuesday, January 21, 2014 9:09 AM
    Monday, December 09, 2013 1:51 PM
    Answerer
  • Perhaps you will have to add your own manual override each time you want to have the page footer say something else?  <eg>



    Robert Aldwinckle
    ---

    Brilliant !

    It will be far to cumbersome to revert to manual override, every time I want to print a webpage.

    It seems incredible that the developers of IE11 did not realise that printed webpages should display the correct URL - as opposed to details of a temporary file.

    Chrome is not perfect.  However, it does not include this defect.  It seems I will have to change my default browser.

    Tuesday, December 10, 2013 9:37 AM
  • It seems incredible that the developers of IE11 did not realise that printed webpages should display the correct URL - as opposed to details of a temporary file.

    Chrome is not perfect.  However, it does not include this defect.  It seems I will have to change my default browser.

    Maybe that was the idea, avoid having to fix all the other problems with printing that associate negatively with IE by driving users to another method of printing?   <eg>



    Robert Aldwinckle
    ---

    Tuesday, December 10, 2013 3:40 PM
    Answerer
  • I have just noticed that this problem has disappeared of its own accord.  Printing from Internet Explorer 11 in the 64-bit version of Windows 7 Professional has started to show the URL, in the same way as with previous versions of Internet Explorer.

    I wonder whether this miracle results from the "Important Update" (MS13-097), which Microsoft offered in mid-December http://support.microsoft.com/kb/2898785/en-gb.  Irrespective of the cause, I am delighted that I am able to print normally once again, without having to tweak my IE print settings or using a different browser.

    Tuesday, January 21, 2014 9:01 AM
  • I have just noticed that this problem has disappeared of its own accord.

    Someone else reported finding a workaround (using Compatibility View IIRC).



    Robert Aldwinckle
    ---

    Tuesday, January 21, 2014 6:36 PM
    Answerer
  • I too have the same problem with IE 11 in 64-bit Windows 7. I got it to go away by downgrading to IE 9. Then automatic updates installed IE 10 for me and the problem reappeared. However I found that some web pages are printed with the web URL, not the local temp file URL (e.g., https://cccwpd.edd.ca.gov/Security/Login.aspx?ReturnUrl=%2fdefault.aspx) and I can't figure out what is special about some pages and not others.

    Tuesday, February 11, 2014 3:35 PM
  • some web pages are printed with the web URL

    See my reply to your other post.  Use the Developer Tools, Emulation tab to see if there is a Document mode (or User-Agent string) override which could account for such observations.   (F12, Ctrl-8)



    Robert Aldwinckle
    ---

    Tuesday, February 11, 2014 9:10 PM
    Answerer
  • F12 opens Developer Tools, but after that Ctrl-8 doesn't do anything - there is no "Emulation Tab" to select. Do you mean the "Browser Mode: tab?" I can select "Internet Explorer 7" from a dropdown list when I click on the "Browser Mode:" tab.
    Wednesday, February 12, 2014 3:57 PM
  • Do you mean the "Browser Mode: tab?"
    That is the IE10 functionality.  This thread is about IE11 so I gave instructions for it..


    Robert Aldwinckle
    ---

    Wednesday, February 12, 2014 4:33 PM
    Answerer