none
Flash player installed , IE9 tells me to install it to view flash videos :S

    Question

  • I installed Internet Explorer 9 the other day, the 64-bit system since I run windows 7 64bit.
    At first i could not watch videos on youtube and such sites because it said I must install flash player from adobe despite it already being installed. I then found out that I must install Flash player from Adobe for x64 systems, named "Square".

    I installed this new version of flash player, the 64 bit version, and yet no matter what site I visit it says that I must install flash player to view flash videos. What's up with that?

    Thursday, March 17, 2011 1:53 PM

Answers

  • You will find support for Adobe Flash Player in this forum: http://forums.adobe.com/community/webplayers/flash_player 
    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
    Sunday, March 20, 2011 11:31 PM
  • Hi,

     

    I suggest resetting IE to check the result. However, if the issue persists, please download 32-bit Internet Explorer 9 and 32-bit Flash Player.

     

    Also, here is the Adobe support.

    http://www.adobe.com/aboutadobe/contact.html

     

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 21, 2011 9:48 AM
  • I have the same problem as RCMAN2.  Last week I downloaded and installed IE9 and the MS download process selected the 64-bit browser for me as our OS is Win 7-64.  I have noticed that flash content will no longer display, generally we are advised by the webpage to install a flash player or update our flash player.  (Sometimes the page will advise to allow Java script as well--it is enabled and up to date FWIW.)

    I have tried switching to the Square beta 64-bit version of Adobe's Flash Player, but it doesn't help with these flash pages/sites.  I was running IE8 32-bit before and I can revert to that if need be (IE8 64-bit was also installed, but I never used it).  What shocks me is that MS isn't installing both the 32-bit and 64-bit IE9 with an advice that flash may not work (yet) on the 64-bit version.  (Are they trying to pressure Adobe to come out with a finished 64-bit flash player--see advice above to seek support from Adobe?)

    Can anyone advise if they have IE9 64-bit that works with Adobe Flash Player?  Which version of the flash player?  If anyone has gotten the Square 64-bit beta version of the Flash Player to work with IE9 64-bit, are there any tricks, tweaks, uninstall-download-install process quirks, or settings that I may be overlooking?

    Can one download and install IE9 32-bit simultaneous with the 64-bit version (as was the case with IE8)?  In that case, how does one toggle between them--select one's default version?

    WRONG, WRONG, WRONG--I was running IE9 32-bit in the first place!  When IE9 is downloaded and installed, both the 64-bit and the 32-bit versions are installed and the 32-bit version is the default!  So now I am really at a loss.  Why isn't flash working anymore?  One guy in another thread suggested using Internet Options, Advanced, Reset, Delete Personal Settings to wipe everything back to zero/default.  I suppose that I can create a restore point first.... (I should note all the "personal settings" so that I can try to figure out which one(s) were the culprit(s), assuming that this works.

    Okay, #1 I jumped to wrong conclusion: that I was running IE9 64-bit and that was cause of "problem."  Also sorry about any wrongful inferences about MS, etc.--they are trying to force Adobe to come out with 64-bit flash, etc.  In fact, when downloading and installing IE9 on 64-bit OS, you get both versions of IE9, 64-bit and 32-bit, just as with IE8.  And the 32-bit version is the default version.  So the short answer to why flash wasn't working is simple: Under the browser Safety settings I had turned on Active-X Filtering!  (Didn't have to go through all my settings, add-ons, etc.  Not that there might not be something else that I might find later that also disables flash...if I find anything else, I will come back here.)  Playing with new settings in IE9, I had set Active-X Filtering on and that disables flash.  Duh.

    Is this the only and definitive reason flash may not work with IE9?  No, but check this before jumping to other more complicated conclusions.


    X
    Tuesday, March 22, 2011 6:05 PM
  • Here are some things for RCMAN2 and XB77 to try.

     

    First go into Manage addons and check to see if the Adobe Addons are 1) present and 2) enabled.

    Second have you set either Tracking Protection or ActiveX filtering to on? If the site doesn't have fallback content or does not pick up on the ActiveX event then the message about not having the right version or needing to install Flash is observed. Same would apply to Silverlight or any active plugin.

     

    hth.

    Mark

    Wednesday, March 23, 2011 9:10 PM

All replies

  • nobody can help me see flash videos using IE9 ?
    Sunday, March 20, 2011 5:12 PM
  • You will find support for Adobe Flash Player in this forum: http://forums.adobe.com/community/webplayers/flash_player 
    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
    Sunday, March 20, 2011 11:31 PM
  • Hi,

     

    I suggest resetting IE to check the result. However, if the issue persists, please download 32-bit Internet Explorer 9 and 32-bit Flash Player.

     

    Also, here is the Adobe support.

    http://www.adobe.com/aboutadobe/contact.html

     

    Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 21, 2011 9:48 AM
  • I have the same problem as RCMAN2.  Last week I downloaded and installed IE9 and the MS download process selected the 64-bit browser for me as our OS is Win 7-64.  I have noticed that flash content will no longer display, generally we are advised by the webpage to install a flash player or update our flash player.  (Sometimes the page will advise to allow Java script as well--it is enabled and up to date FWIW.)

    I have tried switching to the Square beta 64-bit version of Adobe's Flash Player, but it doesn't help with these flash pages/sites.  I was running IE8 32-bit before and I can revert to that if need be (IE8 64-bit was also installed, but I never used it).  What shocks me is that MS isn't installing both the 32-bit and 64-bit IE9 with an advice that flash may not work (yet) on the 64-bit version.  (Are they trying to pressure Adobe to come out with a finished 64-bit flash player--see advice above to seek support from Adobe?)

    Can anyone advise if they have IE9 64-bit that works with Adobe Flash Player?  Which version of the flash player?  If anyone has gotten the Square 64-bit beta version of the Flash Player to work with IE9 64-bit, are there any tricks, tweaks, uninstall-download-install process quirks, or settings that I may be overlooking?

    Can one download and install IE9 32-bit simultaneous with the 64-bit version (as was the case with IE8)?  In that case, how does one toggle between them--select one's default version?

    WRONG, WRONG, WRONG--I was running IE9 32-bit in the first place!  When IE9 is downloaded and installed, both the 64-bit and the 32-bit versions are installed and the 32-bit version is the default!  So now I am really at a loss.  Why isn't flash working anymore?  One guy in another thread suggested using Internet Options, Advanced, Reset, Delete Personal Settings to wipe everything back to zero/default.  I suppose that I can create a restore point first.... (I should note all the "personal settings" so that I can try to figure out which one(s) were the culprit(s), assuming that this works.

    Okay, #1 I jumped to wrong conclusion: that I was running IE9 64-bit and that was cause of "problem."  Also sorry about any wrongful inferences about MS, etc.--they are trying to force Adobe to come out with 64-bit flash, etc.  In fact, when downloading and installing IE9 on 64-bit OS, you get both versions of IE9, 64-bit and 32-bit, just as with IE8.  And the 32-bit version is the default version.  So the short answer to why flash wasn't working is simple: Under the browser Safety settings I had turned on Active-X Filtering!  (Didn't have to go through all my settings, add-ons, etc.  Not that there might not be something else that I might find later that also disables flash...if I find anything else, I will come back here.)  Playing with new settings in IE9, I had set Active-X Filtering on and that disables flash.  Duh.

    Is this the only and definitive reason flash may not work with IE9?  No, but check this before jumping to other more complicated conclusions.


    X
    Tuesday, March 22, 2011 6:05 PM
  • Here are some things for RCMAN2 and XB77 to try.

     

    First go into Manage addons and check to see if the Adobe Addons are 1) present and 2) enabled.

    Second have you set either Tracking Protection or ActiveX filtering to on? If the site doesn't have fallback content or does not pick up on the ActiveX event then the message about not having the right version or needing to install Flash is observed. Same would apply to Silverlight or any active plugin.

     

    hth.

    Mark

    Wednesday, March 23, 2011 9:10 PM
  • A simple solution

    You must have done what I did, that is disable the adobe pdf link helper and/or adobe flash in the browser add-ons. By re-enabling it, the flash player will work with 64 bit internet explorer.

     

    1) Go to internet options in IE9.

    2) Click on programs.

    3) Go to manage add-ons.

    4) Enable Adobe PDF Link Helper and/or Adobe Flash Player

    Sunday, March 27, 2011 1:13 AM
  • I enabled the Adobe PDF Link Helper and I was able to watch the videos on MarketWatch, but they moved to the upper left-hand corner of the screen and strobed a bit between frames.  It is positive progress.   I am still not going to cave in and use Chrome, which works, but if I have to, I will...and have my browsing recorded, analyzed, and archived by google geeks.  There is a price for everything.
    Sunday, June 12, 2011 3:36 AM
  • I enabled the Adobe PDF Link Helper and I was able to watch the videos on MarketWatch, but they moved to the upper left-hand corner of the screen and strobed a bit between frames...


    See http://answers.microsoft.com/thread/21e2ae05-8782-e011-9b4b-68b599b31bf5

    ...and/or my reply to this thread: http://answers.microsoft.com/thread/df686b40-1b83-e011-9b4b-68b599b31bf5


    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft
    Sunday, June 12, 2011 4:12 PM