none
IE 9 cannot display the webpage, but Firefox can

    Question

  • NOTE: Please see attached images, as post had to be trimmed due to images:

    We are deploying a large amount of Windows 7-64bit machines through out or company.  Every new installation we have rolled out has IE9 installed.  IE9 fails constantly with"

    "Internet Explorer  cannot display webpage"

    We have also rolled out some old XP SP3 machines from inventory, with IE7 and IE8 installed and IE on them works fine.  Nothing on the network has changed.

    Every version of Firefox and Google Chrome work fine with NO customization and continue to work.  We have had to push out Firefox as a replacement for IE9, but I'm trying to understand why IE9 continues to have this problem fresh out of the box. 

    Here is what IE9 displays when accessing our Intranet site:

    Here is the same site in Firefox:

    I'm not even going to bother displaying Chrome, but you get my point.

    The only way I can IE9 to display the page is by doing a "Reset Internet Explorer's setting".

    We have tried all the suggested articles, and info found in searching Google, and Microsoft, but I need a real solution.  No proxy is being used.

    My users are getting really annoyed, and like I stated, for now we are using Firefox as a workaround. However, this is not a permanent solution.  We are a Microsoft shop.....What do I need to do to get IE9 to work properly?

    Thanks for your help!

    Monday, February 27, 2012 5:54 PM

Answers

  • Hi max,

    First up... what are you doing on server 2008 r2 using IE.... It operates in a protected mode and its behavior on s2008 is quite different to that of IE9 on a windows client. Your  servers should be secured in the comms room and only accessed remotely. Browse to your intranet sites from your client workstation's browser...

    If you are using IIS, use the links on the IIS management console to launch your web browser at the chosen site under management.

    do you have \\intranet or localhost listed in IE's Intranet Sites list? or any other security zone? IE8/9 clients have intranet auto-discovery... there is no need to list them in the IE' security zones.

    Tools>Internet Options>Security tab, Security Zone icons, 'Sites' buttons...

    You should also be accepting the default security zone settings...

    Tools>Internet Options>Security tab, click "reset ALL zones to default".... use the GPO Security Zone templates to customize any zone to your network requirements.

    You may also have Tools>Compatibility view settings, "Display all sites in Compatibility view" or "Display Intranet sites in compatibility view" checked....

    You can use the Netork tab of the IE9 Developer tool to inspect your resquest and response headers and content or download an install the fiddler tool from http://www.fiddlertool.com

    Regards.


    Rob^_^

    Tuesday, February 28, 2012 12:57 AM

All replies

  • Scroll down the advanced sections page and post it here as well,

    The very bottom sections, you can also compare these settings with ie8's

    Monday, February 27, 2012 7:49 PM
  • Here are the image as requested..... and will compare and report back.

    Thanks!

    Monday, February 27, 2012 9:03 PM
  • A few things I would change,

    Check the boxes for,

    Use ssl 2.0,

    Enable smart screen filter,

    Warn about certificate address mismatch,

    Do not save encrypted files to disk,

    Things I might uncheck,

    Enable DOM storage,

    Post another page and we can review them as well,

    I'll add that on the top of the first advanced section you provided,

    Check the top box,

    Use software rendering instead of gpu rendering. it will speed up surfing and make simple tasks more user friendly. you are using the 32 bit version of ie9 (that's a wise choice).


    • Edited by ThrashZone Monday, February 27, 2012 10:00 PM
    Monday, February 27, 2012 9:17 PM
  • I'm trying to uninstall IE9 and reinstall IE8 on server 2008 r2 but when I install IE8 it reverts back to IE9 on download. Any reason for this ?

    Really need to get rid of IE9 as above, the page keeps timingout and showing page cannot be displayed for no reason. I'v come accross some

    real rubbish Microsoft has released in my time but this one really takes the cake, never come across such rubbish as IE9 before in my life.

    Now I'm convinced that MS do not do any form of actual test before releasing crap like this to the point where next upgrade time it will be

    Ubuntu seen as MS hide their head in the sand and swear blind that their products are brilliant and then tell you to go to hell when you need

    help fixing it...

    Monday, February 27, 2012 11:12 PM
  • Hi max,

    First up... what are you doing on server 2008 r2 using IE.... It operates in a protected mode and its behavior on s2008 is quite different to that of IE9 on a windows client. Your  servers should be secured in the comms room and only accessed remotely. Browse to your intranet sites from your client workstation's browser...

    If you are using IIS, use the links on the IIS management console to launch your web browser at the chosen site under management.

    do you have \\intranet or localhost listed in IE's Intranet Sites list? or any other security zone? IE8/9 clients have intranet auto-discovery... there is no need to list them in the IE' security zones.

    Tools>Internet Options>Security tab, Security Zone icons, 'Sites' buttons...

    You should also be accepting the default security zone settings...

    Tools>Internet Options>Security tab, click "reset ALL zones to default".... use the GPO Security Zone templates to customize any zone to your network requirements.

    You may also have Tools>Compatibility view settings, "Display all sites in Compatibility view" or "Display Intranet sites in compatibility view" checked....

    You can use the Netork tab of the IE9 Developer tool to inspect your resquest and response headers and content or download an install the fiddler tool from http://www.fiddlertool.com

    Regards.


    Rob^_^

    Tuesday, February 28, 2012 12:57 AM
  • So I applied the changed suggested (see image). This is what's displayed after a restart.  Nothing changes.  I can close the browser, and re-open it, but it displays the same thing over and over again.  It should not do this fresh out of the box.

    But this happens on my workstation, and any workstation running IE9.

    The only way to get it to display correctly after a reboot is "RESET" in the IE settings.  It's good until you reset, which is pretty much everyday or when  apply Windows updates to the system.

    If you wondering, the tabs not being shown is our Intranet on the other is the default MSN page.

    Any other ideas?

    Tuesday, March 06, 2012 4:44 PM
  • Here is IE9 AFTER a RESET of IE settings:

    Tuesday, March 06, 2012 5:03 PM
  • Hi,

    Generally, if a web page loads in FX or Safari or Opera but not in IE then the issue is being caused in IE by IE's security zone settings (the other browsers do not use the same security zone model as IE)..

    You can easily test this by adding the IETabs extension to either FX or Chrome.... The IETabs extension does not use the IE Security Zone settings (it is actually a hosted WBC inside the browser chrome)... If a page DOES load in IETabs extension then the problem is being caused by IE's security zone settings or one of your Addons in IE.

    IE Reset also resets the IE Security zone settings back to their defualts, and disables all Addons (see Tools>Manage Addons), COM and ActiveX (Flash)... etc.

    now.. dell.msn.com uses ActiveX detection to detect if the Bing bar is installed on the client browser...

    So....

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    Trusted Sites Icon>'Sites' button.... if using a server version of windows, you should already have www.microsoft.com ONLY listed... add *.live.com so that all technet and msdn domains and the live login verification domain are in the same security zone. On secure server versions of windows you can only download from sites in the Trusted Sites list...

    If you are using a client version of windows, Remove any MS or live domains.

    If you are finding that your IE Security Zone settings are changed from the default when you reboot, then contact your system administrators... they will have to use GPO to troubleshoot their security zone templates... probably they have custom settings for "Scripting ActiveX controls" (probably set to prompt instead of allow)

    To rule out IE Addons go

    Tools>Internet Options>uncheck "Enable third-party browser extensions"... restart IE for the changes to take affect... this STOPS COM addons from being loaded when IE is started or a new tab/window is opened from a link on a web page, but leaves scripted menu and command bar extensions , and ActiveX enabled. and usable...

    If you want to load PDF from links on web pages, you HAVE to configure your Adobe PDF reader to not use the Web Browser to open PDF (becuase the Adobe PDF link helper BHO is not loaded).

    Start>Adobe Reader>Edit>Preferences>Internet, uncheck "Use browser to open PDF"

    Keep an eye on your IE Security Zone settings... always accept the defaults (especially on server versions of windows/IE)...if they change on reboot, contact your System Adimins (they should only be customizing the Intranet Zone)

    on server versions of Windows/IE you should never install Addons except for Search Providers or accelerators. I would advise you not to use other browsers on server versions of windows... use your client browsers to search the web or access the web sites on your servers.

    On client versions with third-party extensions disabled you can use Search Providers and Accelerators too... Not using the Browser to open PDF is the safest... there are known security issues with scripting and PDF documents.


    Rob^_^


    Tuesday, March 06, 2012 8:40 PM
  • Thanks, appreciate the information, I'll check it out.  Just got some new information, this only occurs when a new computer joins the domain, and any subsequent shutdown/power back on.

    Users on the Guest network do not experience this phenomena. So I'm going to check AD, GPO, FW, and report back with findings.

    Thanks again,

    Adrian

    Tuesday, March 06, 2012 9:08 PM
  • I have been getting this for a while as well, only with the occasional website. I also get some newspaper websites with comments section that do not display in IE9I too guessed it was a security setting and have disabled add-ons and turned off firewalls to no avail. The problem is on a win7 ultimate 64 bit machine in both 32 and 64 IE9

    I actually have gone around so many times on this I am crazy. We too are a Windows shop (certified) so if my customers start having related problems we are in trouble. Someone needs to understand the problem not just try this try that - there is little I haven't tried.

    As an addendum: just after posting this I tried one more thing I turned off protected mode and this time the url flipped to res://ieframe.dll/dnserror.htm

    It seems most give as a solution "try everything" from re-installing to viruses to addons to etc etc - we need something better - this is a MS dll it should behave better.

    Friday, March 09, 2012 8:47 PM
  • This must be a bug, either in javascript or IE - I tried all of the above - enabled, disabled plugins, changed the protected mode, Reset etc. NADA. I thought I would give it one more try only this time a lot more logically. Start from the simple and progress.

    First thing I did was go from the security default Medium high to Medium. close and restart - nothing. Then I turned off protected mode, close and restart - nothing - except when going back the protected mode was checked again? Thought maybe IE resets to this default? Unchecked and restarted again - problem fixed - looked at protected mode and still unchecked.

    Went through plugins disable - enable - close/restart - no plug in caused a change or problem.

    Changed the zone back to Medium High - close/restart - problem still fixed.

    Changed the protected mode to checked - closed/restart - good. Reboot - re-run - Good

    There is no explaining this except a bug - javascript or IE.

    The protected mode also is dependent on UA so the domain problem may be related - this is where I would look in the code for the bug -  but I did not try trouble shooting this. I was running IE9 64 on a 64 Ultimate machine that is part of a domain. I do the bug testing for our app of 2 million lines of code - this is a bug, 100%

    Thursday, March 22, 2012 4:58 PM
  • It's controversial but ie9 64 bit version is a no go,

    On most machines gpu rendering is also a no go,

    And all of the mother hen filtering is a no go,

    The best thing you can try to to disable xss filtering in the security section custom level button.

    Don't use safe sites lists, and disable content advisor.

    Advanced section make sure ssl 2.0 and 3.0 are checked.

    Thursday, March 22, 2012 7:41 PM
  • @scriptnetics

    the quality of our answers depends apon the quality of your question...

    if you include the url of the webstite(s) you are having trouble with, WE can test for ourselves and rule out things like dns errors or server error codes > 502

    we can't read minds, so include some url's. Written descriptions of your machines symptoms are not detailed enough as there can be a number of reasons, beyond your IE settings or your IE Addons why a blank page is displayed when you try to navigate to a site.

    Regards.


    Rob^_^

    Thursday, March 22, 2012 11:54 PM
  • One would think that patience would be a requirement especially in a forum where you are sure to encounter extremely frustrated users.

    having the exact same issue with just about any website at any given time. 

    Today it happened with Chase.com..... It has been going on for quite a while with many different websites including this one......

    having read numerous forums on the subject I've tried completely removing antivirus software, resetting explorer, removing and reinstalling explorer, to changing internet carrier from cable to fios......... same websites using firefox or chrome work without issue. 

    This does make it appear as if it is a microsoft issue..........regardless there are a great many people out there with vastly more computer knowledge than myself seeking a remedy for this same problem.  The only one that consistently works is changing to another browser........

    Would love to keep internet explorer perhaps someone can give this a serious look


    • Edited by NjTeddy Sunday, January 13, 2013 1:39 PM
    Sunday, January 13, 2013 1:39 PM
  • Did anyone find a fix for this?

    We have this issue on a couple of new windows 7 x86 machines when working on the wireless network and using IE9 they cannot get onto any web site, but as soon as we installed Chrome and used that it works fine with all sites.

    We use a proxy pac file but i dont think that is an issue as when we plug a network cable in to the laptops they can get onto sites fine in IE9, the problem is when we reboot a laptop just on the wireless it cannot get to any sites in IE9

    Thanks

    Friday, June 28, 2013 2:07 PM
  • is your wireless router ipv6 capable?

    would it by chance be from Cisco, purchased in the last two years?


    Rob^_^

    Saturday, June 29, 2013 5:37 AM