none
Target website says my browser isn't supported and says I need to upgrade to latest version

    Question

  • I tried to go to target.com and it said I could not view their website because I needed to upgrade my browser.  I am already using Internet Explorer 9, and I have visited that website many times without any problems.  I thought I would go ahead and try to download IE 9 again, but when I tried to do that it said it could not do it because a newer version was already being used.  What could the problem be?
    Friday, January 06, 2012 6:11 PM

Answers