locked
Internet Explorer 7 runonce page keeps displaying

    Question

  •  

    Internet Explorer 7

    http://runonce.msn.com/runonce2.aspx

    page keeps displaying.............

     

    I found this page kept displaying on our computers other 'user accounts'. 

    It was ok on the main administrators account where I originally installed IE7.  We are on Ntl Broadband and have Netguard Anti-virus.

    To fix this error........

    >individually go into each 'users account'.

    >disable Anti-virus, firewalls, add-blockers and pop-up blockers and parental controls, and exit the anti virus .

    >click on Internet explorer 7 icon and instead taking you to the irritating Blue screen it will show 'connecting' and will take you to "windows live toolbar customisation wizard"

    > the box will show "windows live toolbar set up"

    > click "next"

    > select

    >go through the options checking the boxes you require

    > click "finish"

    > screen will show --- connecting

    > it will take you to Microsoft phishing filter - select if you want it on or off (I recommend ON)

    > select ok - you will see "THANKS FOR INSTALLING WINDOWS LIVE TOOLBAR"

    > exit (click on X top right corner)

    This takes you to another page

    > scroll down and fill in the settings

    > click save settings  at the bottom

    >it will show "Settings sucesully saved"

    > Click on 'Go to home page'

    Voila!

    REMEMBER TO RE-SET your Anti Virus, and pop-up blockers etc before you browse the net!

    Monday, November 13, 2006 8:27 PM

All replies

  • Edited the registry as detailed below - all works fine now

     

    Many Thanks guys

    Saturday, November 25, 2006 11:22 AM
  • Another quicker way to fix this problem is to right click on http://runonce.msn.com/runonce2.aspx which is the target.  Once right clicked, choose open in new window or new tab.  The target should open correctly.  Customize the page as you want it and save changes.  Close all IE windows and click IE7, your home page should open correctly.

     

    Mike

     

    Sunday, November 26, 2006 9:06 PM
  • Many thanks - this worked for me too.

    I have Telewest (affiliate of NTL) broadband and also use PCGuard (which is supplied free by Telewest for some customers)

    I have 2 PCs using XP Pro on a home network, both at latest level according to Microsoft Update. One PC ran into this problem but the other updated cleanly - don't know why.

    Both now working fine - thanks again.

    Simon

    Monday, November 27, 2006 8:24 AM
  • the page gives error and only i can see the blue background what can i do? the page never opens
    Thursday, December 07, 2006 1:44 AM
  • I was wondering if there's another way to solve this problem?  I am getting this screen every time I open IE and yet both the resolutions do not help.  Any ideas?

    Thanks.

    Saturday, December 23, 2006 2:00 AM
  • how do you edit the registry?
    Sunday, December 24, 2006 5:15 PM
  •  

    All,

    After fighting with IE7 for two days, I found the only solution that worked for me. Remove IE7 and go back to IE6. IE 6 may not be as fancy IE7, but it has the advantage of working on all my accounts.

    Jim in MA

    Tuesday, February 13, 2007 12:53 AM
  • Runonce fix

     

    Go to  Start,   All Programs,  Accessories,  System Tools,  Internet Explorer (No Add-ons)

    then using this browser page go to the runonce (copy and paste this link or type it in)

     http://runonce.msn.com/runonce2.aspx

     

    This will open the runonce page and allow you to select your IE Search Utility to Google or what ever you prefer. Once you’ve done this, click the save button at the bottom and close. When you fire up IE 7 it will go directly to your home page.
    Tuesday, March 20, 2007 10:43 PM
  • This does not work with Temporary Profiles that are downloaded to workstations in a Domain.   The "so called  "saved" settings from "Run Once" are deleted everytime the user logs off.   I have 17,000 unique users! 

    Any suggestions on how to disable the "run once " dialog screen everytime someone logs on and opens Internet Exp 7.  I really don't want to go back to IE 6. 

    First person to figure this out correctly gets a free beer!

     

      

    Thursday, March 22, 2007 6:26 PM
  • edit your registry

     


    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "RunOnceHasShown"=dword:00000001
    "RunOnceComplete"=dword:00000001

     

    works for me Big Smile

     

    you can use this in your logon script for all users

    Wednesday, April 11, 2007 9:25 PM
  • Very good solution

    Thanks

     ITim wrote:

    Runonce fix

     

    Go to  Start,   All Programs,  Accessories,  System Tools,  Internet Explorer (No Add-ons)

    then using this browser page go to the runonce (copy and paste this link or type it in)

     http://runonce.msn.com/runonce2.aspx

     

    This will open the runonce page and allow you to select your IE Search Utility to Google or what ever you prefer. Once you’ve done this, click the save button at the bottom and close. When you fire up IE 7 it will go directly to your home page.
    Thursday, June 07, 2007 8:58 PM
  • I tried this and ran Sysprep afterwords.  The runonce page still came up after I reimaged a machine.  I am not sure what else needs to be done.  Any assistance would be greatly appreicated. 

     

     

    Thanks. . .
    Wednesday, June 20, 2007 9:22 PM
  • I had the same problem and it didn't go away until I edited every instance in the registry where there's an Intenet Explorer\Main container. There's one in HKEY_LOCAL_MACHINE (same drill-down as HKCU) and there were several in HKEY_USERS, in the S-* containers (but not the ones that end "_Classes"). After I added the two dwords to all of the containers, it stopped trying to go to that page.
    Wednesday, June 27, 2007 5:20 PM
  • So let me get this straight, if you add the following:

     

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceHasShown

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceComplete

    Created them both (Right click where they should be, new DWORD) and changed their value to "1".

     

    in all of the containers, when I run Sysprep again, the Internet Explorer 7 runonce page will not pop up?

     

     

     

     

     

    Monday, July 02, 2007 2:10 PM
  • Yes, this regedit trick really works.  I just reimaged a system and ran into this problem for the first time.  Adding the two DWORDs and Modifying value to 1 did the trick.  Many thanks.  What an annoying feature.

     

    Monday, August 20, 2007 2:29 AM
  • I tried everything you suggested but I still cannot load the 'settings' page and only get 'Errors on Page' msg.

     

    Any other suggestions?

     

     

    Tuesday, September 25, 2007 9:04 AM
  • i solved the problem buying another xp cd there are problems with a version of the xp CD i ll send mine soon...

    Tuesday, September 25, 2007 11:27 AM
  • To get rid of the "runonce" screen (and the "An scripting error..." message):

     

    Go to Tools > Internet Options > Advanced and UNCHECK the box "Disable script debugging (IE)"

     

    Then close IE and reopen and it will open to the Home Page you have chosen (Tools > Internet Options).

     

    Trish42

     

    Sunday, September 30, 2007 3:22 AM
  •  

    To get rid of the "runonce" screen (and the "An scripting error..." message):

     

    Go to Tools > Internet Options > Advanced and UNCHECK the box "Disable script debugging (IE)"

     

    Then close IE and reopen and it will open to the Home Page you have chosen (Tools > Internet Options).

     

    Trish42

    Sunday, September 30, 2007 3:22 AM
  • I did what you suggested and now I get a message ' A RUNTIME ERROR has occurred.

    Do you wish to debug@

    Line 55.............

     

    I answer Yes and No but IE7 still shows a blank blue screen.

     

    Any other suggestions?

     

    Thanks

     

    Jeff Dean

    Monday, October 01, 2007 2:26 PM
  • JUST PRESS CRTL-N on the runonce and its done !!!

     

    Thursday, October 04, 2007 3:52 AM
  • Fixed thanks appreciate that cheers Pete

     

    Sunday, October 21, 2007 10:03 AM
  • Hi Leandro works for me, but only after creating both dwords. If I reset IE7 then it's go back to the runonce.msn, and again with error on that page. But I opened the regedit, and again I created the dwords which you described above. Valeu, Obrigada!

     

    Christina 

    Thursday, November 08, 2007 9:50 PM
  • Hi everyone.

     

    On my computer "Main" -directory for IE7 in registry does not exist. How can I remove the annoying runonce from IE7? Make the directory and make settings in it?

     

    Hope for reply.

    Thursday, December 06, 2007 3:00 PM
  • Leandro Cascao, instructions: 

    edit your registry

     

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "RunOnceHasShown"=dword:00000001
    "RunOnceComplete"=dword:00000001

     

    Works for me!

    Friday, December 07, 2007 12:23 AM
  • I tried all the above solutions but none worked. Follow this link for the solution that worked for me http://support.microsoft.com/kb/945385/en-us

     

    Cheers.

    • Proposed as answer by JFThome Monday, June 15, 2009 10:44 PM
    Friday, December 07, 2007 11:40 AM
  • The solution is simple and work!

    Don't afraid to edit registry and it save much time to search other solution and click it every time.

    Monday, December 17, 2007 1:14 PM
  • Try following the following link to download.com it takes about ten seconds and has cured my runonce problems totaly, though you may have to follow the steps in all user accounts.

     

     

     

    http://www.download.com/3001-8022_4-10683033.html?spi=8f92d268255d78b52f200c831bc8a5ad?idl=n
    Sunday, December 30, 2007 12:28 PM
  • This solution is the BEST. Everything else I tried did not work. Its all in the registry and you need to add the runonce junk in it. Best of Luck to all and no need to be annoyed anylonger.

     

    Tuesday, January 01, 2008 10:02 PM
  • After installing msn messenger which I am able to use I find I cannot access internet. a message appears reading

     

    http/runoncemmsn.com/?v=msgrv75

     

    any ideas what it means and can I  repair whatever it is saying

    Tuesday, January 15, 2008 1:47 PM
  • Well .... I think I have the solution!

    Using Group Policy, go to Computer Configuration > Administrative Templates > Windows Components > Internet Explorer

    There is a setting called "Prevent performance of First Run Customize Settings". Enable this setting and change your choice to "Go directly to homepage". This will prevent the customize page to display and if you change the setting on your Default Domain Group Policy, all users will benefit from the change.

    Email me if this doesn't work.
    Friday, January 25, 2008 5:01 AM
  • Hi

     

    Ive tried to find that setting and cannot find it!...

     

    Could you please tell me if is there anything (administrative templates) that need to be updated? Where can I download/update them?

     

    I'm runnig a W2K3 AD with XP clients.

     

    I need to apply it to my terminal server. This machine only browse internal sites, and this initial forwarding is really anoying...

     

    Thanks for any help.

     

     

    Friday, January 25, 2008 11:19 AM
  • You can find the setting in User Configuration \ Administrator Template \ Windows Components \ Internet Explorer \

    I just set the Prevent performance ot First Run.... etc

    Do not know if it works just jet.

    Friday, January 25, 2008 11:35 AM
  • Thank You..  this is the best solution..  just add these registry keys and you wont get that runonce error anymore..  Even better, enter these registry entries,  then export the registry key..   cut out all the other junk, and just leave the 2 RunOnce entries,  then save it..  then all you have to do is just run the reg file on any new machine and it will automatically input the correct registry entries..

     

    Thanks for the great tip!

     

    Friday, January 25, 2008 1:48 PM
  • Hi

     

    Thank's for clarifying. Unfortunatly I can't find that specific setting in my domain GPO.

    Under "User settings \ Administrative Templates \ Internet Explorer " I can't find "Prevent performance of First Run Customize Settings" or anything like that ...

     

    Does anyone know if it is necessary to update something in order to be able to "see" this in the GPO?

    Thank's

     

    Monday, January 28, 2008 2:34 PM
  •  austbear wrote:
    Well .... I think I have the solution!

    Using Group Policy, go to Computer Configuration > Administrative Templates > Windows Components > Internet Explorer

    There is a setting called "Prevent performance of First Run Customize Settings". Enable this setting and change your choice to "Go directly to homepage". This will prevent the customize page to display and if you change the setting on your Default Domain Group Policy, all users will benefit from the change.

    Email me if this doesn't work.

     

    This method works well. The instructions this page http://blogs.chron.com/helpline/archives/2006/12/ie7_runonce_pag.html are the easiest way to get to the correct file. Don't touch anything else.

     

     

    Wednesday, February 20, 2008 3:30 AM
  • Thanks for this. It works perfectly now. I actually couldn't launch IE at all, it would terminate immediately with a script error. I could only launch it if I clicked on a link from an email or document. Odd. MS should remove this script, seems to cause a lot of people problems. Thanks again! Sonja

     

    Friday, February 22, 2008 10:20 PM
  • Just wanted to let you know that I tried your suggestion and it work where the others din't.  Thanks allot.

     

     

     

    Monday, February 25, 2008 1:49 PM
  • Great!  It worked for me!!!!

     

    Thanks!

     

    Elyse-Quebec

     

    Friday, February 29, 2008 5:52 PM
  • Thanks Leandro, your solution was the only one which relieved me from this annoying window!
    Saturday, March 22, 2008 9:21 AM
  •  

    This is the fix that worked for me:

    Problem: IE always goes to http://runonce.msn.com/runonce2.aspx instead of your homepage

    If IE7 always goes to the RunOnce page on startup, even after you've tried to save the first run settings, it's possible that the mechanism that IE is using to save the settings does not work for some reason. 

    You can prevent IE from going to the RunOnce page and cause it to go directly to your homepage by running this script.

    For more info, check out this Knowledge Base article.

    Tuesday, May 06, 2008 9:13 PM
  • Thank you so much Seathwood. Your solution worked for me perfectly.

    Saturday, May 24, 2008 3:20 AM
  •  shariMcG wrote:

     

    This is the fix that worked for me:

    Problem: IE always goes to http://runonce.msn.com/runonce2.aspx instead of your homepage

    If IE7 always goes to the RunOnce page on startup, even after you've tried to save the first run settings, it's possible that the mechanism that IE is using to save the settings does not work for some reason. 

    You can prevent IE from going to the RunOnce page and cause it to go directly to your homepage by running this script.

    For more info, check out this Knowledge Base article.



    None of these solutions work with IE7 installed as part of SP3.  The script works for awhile to modify the registry, as do other registry modifications. It might seem to work 2 or 3 times, but eventually it will revert to runonce. It will always revert to runonce after a different browser has been used.

    In addition, IE7 cannot be removed using the control panel.  After two days fighting this nonsense, I just want IE7 gone forever.
    Friday, May 30, 2008 5:57 AM

  •  
     

    edit your registry

     


    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "RunOnceHasShown"=dword:00000001
    "RunOnceComplete"=dword:00000001

     

    works for me

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    This fixed the following problem for me on Internet Explorer 7. Thanx Leandro

     

    http://runonce.msn.com/runonce3.aspx
    Wednesday, July 30, 2008 5:20 AM
  • Go here... Download this registry and it will be fixed!

    http://www.enhanceie.com/dl/NoRunOnce.reg

     

    Tuesday, August 12, 2008 1:49 AM
  • Go here... Download this registry. It automaticly fixes it.

    http://www.enhanceie.com/dl/NoRunOnce.reg

    Tuesday, August 12, 2008 1:52 AM
  • the registry edit worked for me.

     

    Thursday, August 14, 2008 2:36 AM
  • Worked like a charm.

    Saturday, August 30, 2008 6:44 PM
  • The problem started for me when IE 7 came back up after I uninstalled IE 8 beta 2.  I lost patience after trying everything short of editing the registry and simply downloaded the latest version of IE7 and installed it on top of the older version.

     

    I got the runonce once and ran it off by choosing the search provider, etc. IE finally saved the settings and let me go back to my preferred home page. This was a quick and simple solution for me; so far everything is in place and working.

    Wednesday, September 24, 2008 10:22 PM
  • I was able to solve this by going to http://norun.notlong.com and running the applet. It installs a regisrty key that solves it.

    Monday, October 06, 2008 9:33 PM
  • FAIL
    Wednesday, May 06, 2009 11:48 PM
  • The below registry keys worked for me.

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceHasShown

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceComplete

    Created these new DWORD and changed their value to "1".

    Saturday, October 30, 2010 7:10 PM