none
IE10 on Windows 7: every new tab or page opens with a script error Unable to get property 'style' of undefined or null reference

    Question

  • Just upgraded from IE9

    Since the upgrade every new tab or page generates a script error:

    Line: 1

    Error: Unable to get property 'style' of undefined or null reference

    I have :

    reset internet explorer, disabled all addins, run as administrator

    Any other ideas?


    CarolChi

    Monday, November 19, 2012 5:46 PM

Answers

  • I have this issue also while running IE10 on W7 x64. However, when I set it to "Display all websites in Compatibility View", the prompt went away.

    IE10 -> Tools -> Compatibility View Settings -> Check "Display all websites in Compatibility View"

    Monday, November 26, 2012 10:46 PM
  • Hello Carol,

    I believe this happens because IE10 is more strict about requiring certain markup in web pages, which includes things like style and doctype.  When you open a new tab or window, IE loads the URI about:blank first, which doesn't have nearly any markup in it, because it's, well, blank.

    You can workaround this issue by turning on Compatibility View for all webpages.

    1. Right-click the window header and select Command Bar.
    2. Click Page, then click Compatibility View Settings.
    3. Check the "Display all pages in Compatibility View", and click Close.

    You shouldn't get the error anymore.

    Tuesday, November 27, 2012 10:30 PM
  • I saw another blog that it might have something to do with McAfee SiteAdvisor plug-in is not compatible, but I'm not sure.

    I can confirm that. Disabling the McAfee SiteAdvisor add-in helped me to solve the issue.

    Friday, March 15, 2013 12:19 PM

All replies

  • Hi,

    what happens when you type about:tabs in the IE Address bar?

    Tools>Manage Addons>Tracking protection, disable any tracking protection files or

    tools>internet options>Advanced tab, uncheck "Display notification about every script error".

    failing that try a restart of your computer, making sure that all updates are processed.

    Regards.


    Rob^_^

    Tuesday, November 20, 2012 6:57 AM
  • about:tabs gives me a set of blank suggested tabs and no error

    As long as I stay in the same tab all is well.

    I have only a "Your Personalised List" in do-not-track and it is disabled (this does not make any difference)

    Display notifications about every script error is not checked. I have tried several debugging options and restarts.


    CarolChi

    Tuesday, November 20, 2012 8:14 AM
  • Hi,


    Let us reset Internet Explorer settings for a test.


    If the issue persists, please boot into Clean Boot environment.

    http://support.microsoft.com/kb/929135


    Kim Zhou

    TechNet Community Support

    Wednesday, November 21, 2012 9:27 AM
  • Issue does not happen in clean boot, nor in clean boot with network.

    Internet Explorer reset has no effect.

    I suppose I now have to go through everything in the boot menu.

    I'm getting a new computer this week I will see if that is better.


    CarolChi

    Wednesday, November 21, 2012 5:14 PM
  • I have this issue also while running IE10 on W7 x64. However, when I set it to "Display all websites in Compatibility View", the prompt went away.

    IE10 -> Tools -> Compatibility View Settings -> Check "Display all websites in Compatibility View"

    Monday, November 26, 2012 10:46 PM
  • Works for me too, but we must have something somewhere that is not compatible with IE10. I can't understand what that incompatible element is.

    CarolChi

    Tuesday, November 27, 2012 10:10 AM
  • Hello Carol,

    I believe this happens because IE10 is more strict about requiring certain markup in web pages, which includes things like style and doctype.  When you open a new tab or window, IE loads the URI about:blank first, which doesn't have nearly any markup in it, because it's, well, blank.

    You can workaround this issue by turning on Compatibility View for all webpages.

    1. Right-click the window header and select Command Bar.
    2. Click Page, then click Compatibility View Settings.
    3. Check the "Display all pages in Compatibility View", and click Close.

    You shouldn't get the error anymore.

    Tuesday, November 27, 2012 10:30 PM
  • Yes this does indeed stop the error appearing.

    BUT other sites then complain and tell me they are better if I turn off compatibility mode. I do not get all the benefits of IE10!

    I thought about:blank was part of IE10. I cannot see why it should not be compatible.


    CarolChi

    Friday, November 30, 2012 6:45 AM
  • Thanks for this post. It helped me to solve the same issue.
    Thursday, January 10, 2013 11:41 AM
  • I have the same error  IE10 on W7 x64

    script error:

    Line: 1

    Error: Unable to get property 'style' of undefined or null reference.

    I saw another blog that it might have something to do with McAfee SiteAdvisor plug-in is not compatible, but I'm not sure.

    The issue occurs when opening a new TAB (about:blank) - this problem is not about IE10 being more strict.

    Please advise if you have a resolution.


    Objects - first class citizens: identity, public interfaces and the authority for their own behaviour and state




    • Edited by ToServe Friday, March 01, 2013 1:07 AM
    Wednesday, February 27, 2013 8:50 PM
  • I saw another blog that it might have something to do with McAfee SiteAdvisor plug-in is not compatible, but I'm not sure.

    I can confirm that. Disabling the McAfee SiteAdvisor add-in helped me to solve the issue.

    Friday, March 15, 2013 12:19 PM
  • I can confirm that disabling the McAfee SiteAdvisor add-in does NOT solve the issue. I did not try removing SiteAdvisor completely, but disabling it was done and tested. The script errors remained.

    None of the other solutions offered here work, either.

    I noticed that most of the previous answers were based on the pre-release version of IE 10, not the production release we are using. In any case, disabling SiteAdvisor across the enterprise is not a viable option. Disabling IE 10 is, however.



    Wednesday, April 03, 2013 1:57 PM
  • It's Working Good

    Thursday, April 04, 2013 12:08 PM
  • I am also seeing this issue and noticed that there does not seem to be a documented resolution. Does Microsoft have a formal position on this issue?
    Thursday, May 09, 2013 7:28 PM
  • The change in Compatibility View Settings does work.
    Thanks a lot for putting this post. Very helpful.
    • Edited by ora_balan Monday, May 27, 2013 12:56 AM
    Monday, May 27, 2013 12:55 AM
  • FYI...

    I have now been able to get this to work on my Windows 7 machine without having to set the Compatibility View Settings for all web sites.

    In Internet Explorer 10, navigate to Tools/Internet options/Advanced Tab

    Click the Reset... button under the Reset Internet Explorer settings section to Reset Internet Explorer's settings to their default condition.

    Note: this will require you to restart your computer when done before they take affect.

    PS: I also have all of the latest Windows updates installed.

    Good Luck :-)


    Objects - first class citizens: identity, public interfaces and the authority for their own behaviour and state

    Monday, May 27, 2013 7:55 PM
  • As Petr Moskor suggested I disabled McAfee SiteAdvistor plug-in, it works fine for me.

    Thanks


    Please mark as answer, if it solves your problem or Vote as helpful if you find helpful

    Tuesday, July 16, 2013 12:29 PM
  • Thanks KennPau.  After scouring the internet for awhile,...... I came upon your answer and it worked like a charm.  Thanks again!!!
    Tuesday, August 20, 2013 9:57 PM
  • This is what the problem was for me.  Thank you for posting this!  You helped me to resolve this issue.  To fully disable it I had to click on internet options, programs, manage add-ons, and then disable McAfee site advisor toolbar, scriptproxy, and McAfee site advison bho.
    • Edited by EAF212019 Monday, October 28, 2013 5:12 PM
    Monday, October 28, 2013 5:09 PM
  • So IE11 also does this.  But they have removed the "Display all websites in Compatibility View" option. So now I'm pooched. Any suggestions?

    Jack Schueler


    • Edited by jbschueler Thursday, November 14, 2013 4:09 PM
    Thursday, November 14, 2013 4:08 PM
  • I have the same problem with IE11. Looking for any suggestions to fix this. If not, I will need to go back to IE10.
    Friday, November 22, 2013 5:57 AM
  • After trying all possible solutions here, I decided to switch back to Chrome.
    Saturday, November 23, 2013 2:17 AM
  • Good luck with reverting to IE10. You can't uninstall IE11 so you have to do a system restore to a previous savepoint.

    Jack Schueler

    Saturday, November 23, 2013 5:30 PM
  • Thanks. This helped. Disabling the McAfee SiteAdvisor add-on made the error disappear.
    Wednesday, December 25, 2013 3:26 AM
  • You can actually remove it by going to the installed updates section of Windows Update.  This will revert you to IE 10.
    Friday, January 17, 2014 7:10 PM
  • Site Advisor had originally not worked with IE 10 and Windows 7.  However, McAfee has since posted a hot fix for Site Advisor (Enterprise) 3.5.  Hotfix 2.

    The link is below

    https://kc.mcafee.com/corporate/index?page=content&id=KB79563

    Cheers!

    • Proposed as answer by kswags Wednesday, March 12, 2014 2:00 AM
    Wednesday, March 12, 2014 2:00 AM
  • Mcafee site advisor seem to be the culprit, see https://kc.mcafee.com/corporate/index?page=content&id=KB78225 

    Naija geek

    Thursday, June 26, 2014 3:03 AM