none
Internet Exporer 11: Disable search from address bar (entirely)

    Question

  • When we try to use internal websites (sites like hostname.some.subdomain.com:NNNN/some/path/ ) internet explorer 11 shows autocomplete entries for previous visits to those websites, but, when selected, it then searches bing for those URLs, and that makes very little sense to do.

    it's an address bar. it's where addresses are typed in. I don't want internal website addresses (frankly, any website addresses) to turn into a bing search. I don't search from the address bar. Ever. In previous versions I could disable that, and in this version that option seems to have been replaced with "go directly if a single word is typed in [intranet site like "home" or "intranet" or "sharepoint", etc.] ", but that doesn't disable the search feature enough to avoid still continuing to search when internal websites are entered/selected in the address bar.

    Is there some other place to disable the search, so that addresses typed into the address bar work?

    Monday, November 25, 2013 3:58 PM

All replies

  • Hi,

    Internet Options>Advanced tab, check "Go to an intranet site for a single word entry in the address bar"

    Regards.


    Rob^_^

    Tuesday, November 26, 2013 12:11 AM
  • Hi,

    Internet Options>Advanced tab, check "Go to an intranet site for a single word entry in the address bar"

    Regards.


    Rob^_^

    Yep, as I said, that option is checked, and the behavior still continues.  I'm not just typing in a single word, which is what that option seems to be intended to detect.  When we enter a hostname, port number, and path to an intranet site, it searches bing for that entire URL instead of attempting to connect to the site.

    I'm looking for a way to never have the address bar perform a search, if there's no way to have IE11 try to connect to what I typed, first, before continuing on to bing.

    I do understand people wanting the option to search from the bar, but I'm not seeing any option to -not- search from the bar, and to instead have the browser try go to the URL entered first.

    For example, I enter something like:    "testsite.int"... and IE11 immediately auto-suggests:  testsite.internal.domain.name:8080/some/valid/path/  and when I click that (or press enter), it then searches bing for testsite.internal.domain.name:8080/some/valid/path/     I'm not seeing any option to have IE11 just GO to the site I entered.  It seems strange to have it specifically auto-suggest the full url, and then not go there.


    Tuesday, November 26, 2013 4:11 AM
  •  It seems strange to have it specifically auto-suggest the full url, and then not go there.


    Your examples are not exactly "full url".  E.g. no protocol prefix.  What happens if you insert that?  Otherwise your match may only be earlier typing that was saved in TypedURLs which only resulted in a search from the Address bar  too.

    Also, the search from the Address bar may be due to poor DNS performance, so a workaround for that can be to try caching the lookup first, e.g. by using  ping -n 1 -w 1  <hostname>   and then assuming you can make IE try its request before that entry's Time To Live expires you can either avoid the symptom or prove that slow DNS is not the cause.  Note that you can use  ipconfig  /displaydns   to check on TTL and also that you are getting a full lookup cached, e.g. not just a CNAME which needs to be resolved further to find an IP address for it.



    Robert Aldwinckle
    ---

    Tuesday, November 26, 2013 9:25 PM
    Answerer
  •  

    Your examples are not exactly "full url".  E.g. no protocol prefix.  What happens if you insert that?  Otherwise your match may only be earlier typing that was saved in TypedURLs which only resulted in a search from the Address bar  too.


    Robert Aldwinckle
    ---

    Yes, you're correct; the http:// or https:// protocol portion does force success, and in prior versions (a few ago), you couldn't go to "somehostname:8080/" -- the browser would immediately return an error message, unless you prefaced that with http://.   The current behavior avoids an error message by searching bing, but I'm trying to understand if there's a way to make it try that url first.

    To be fair, going back to the error message isn't necessarily any better, though it does avoid exposing our internal URLs to bing.

    As a different example, you can type in just "www.microsoft.com/" and be directed to the main site -- it assumes you wanted http:// and port 80, and it goes there without error (and without searching).  If you type "www.microsoft.com:80/" i would expect it to do the same thing, but that turns into a search.

    Tuesday, November 26, 2013 10:36 PM
  • Hi,

    Based on your description, I would like to suggest you turn off following to check the issue:

    1. AutoSearch

    a. Open the desktop, and then tap or click the Internet Explorer icon on the taskbar.
    b. Tap or click the Tools button, and the tap or click Internet options.
    c. On the Advanced tab, under Browsing, select the Do not search from the Address bar check box.

    2. Enhanced suggestions

    a. From the Start screen, tap or click Internet Explorer to open Internet Explorer.

    b. Swipe in from the right edge of the screen, and then tap Settings.
    (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)

    c. Tap or click Privacy, and turn Show enhanced suggestions as you type to Off.

    3. Search suggestions

    a. Open the desktop, and then tap or click the Internet Explorer icon on the taskbar.
    b. Tap or click the arrow to the right of the address bar, and tap or click Turn off search suggestions.

    4. Suggested Sites in the desktop

    a. Tapping or clicking the Tools button, tapping or clicking File, and then clearing Suggested Sites.

    For more information, you may refer to:

    Get browsing suggestions in Internet Explorer

    http://windows.microsoft.com/en-us/internet-explorer/get-browsing-suggestions#ie=ie-11

    I also would like to suggest you reset IE settings to see the results.

    Reset Internet Explorer settings

    http://support.microsoft.com/kb/923737

    Please understand that reset Internet Explorer to its default configuration. This step will also disable any add-ons, plug-ins, or toolbars that are installed.

    Hope it works.

    Regards.

    Blair Deng


    Blair Deng
    TechNet Community Support

    Wednesday, November 27, 2013 2:46 AM
    Moderator
  • Me too.  If I want it to search, I'll click the search glyph.

    Seems to me we have had this conversation before.  E.g. turning off search from the Address bar turns off  Search in the Address bar.  Unfortunately.



    Robert Aldwinckle
    ---

    Wednesday, November 27, 2013 3:48 AM
    Answerer
  • Yes, you're correct; the http:// or https:// protocol portion does force success

    Ok.  So now that it is in TypedURLs with a protocol prefix, does it not match as soon as you start typing the first character?  Or, for a related workaround, you could make it a Favorite, and get a match after the first two characters.



    Robert Aldwinckle
    ---

    Wednesday, November 27, 2013 3:55 AM
    Answerer
  • Say, I just typed  Robert Aldwinckle  into File Explorer address bar, and it launched IE11 to Wikipedia.

    If that works with Search from the Address bar disabled that would be a useful workaround.  You could even do it from the Address bar in the Taskbar I suppose?...  FWIW it doesn't work for me.  E.g. typing new search there and getting no matches and then pressing Enter resulted in This page can't be displayed 

    My point was that as soon as you disable Search from the Address bar the Search icon ("glyph") goes with it.

    Wednesday, November 27, 2013 5:52 PM
  • It would seem that using the protocol prefix would be that solution.  Just considering this it doesn't seem to make much sense to expect them to tweak the way the address bar works for the general audience.  Your example about entering the port 80 after the URL but without the protocol is only valid if you assume that port 80 is http and not someone who decided they'd use a different protocol like FTP on port 80 because they felt like it that day or whatever reason.  You could make the assumption that 80 was HTTP but if you can type the full address (or even the local internal address, then typing the extra few characters to let the browser know how to try and contact the other endpoint doesn't seem too unreasonable. 

    I personally understand how you feel it should work but if you look at the bigger picture, they (MS) are likely trying to make browsing more friendly for the average user who's never heard of ports or protocols as they relate to internet usage.  So the option to turn it completely off or to type in the full url with protocol seem to be the options for "advanced" users.  You also have the option possibly of downloading a search bar (I believe the bing search bar still exists as I see it in Win Update on several systems as an optional download) which would keep the functionality separate the way it used to be and may be more along the lines of what you're trying to accomplish.

    Saturday, December 07, 2013 8:36 PM
  • Windows 7 Ultimate x64 with all patches
    IE11 with all patches

    >c. On the Advanced tab, under Browsing, select the Do not search from the Address bar check box.
    The above option is not present.  How do I turn off searching from the Address bar?


    http://www.saberman.com

    Thursday, January 02, 2014 6:57 PM
  • Which is why I opened this question -- because they took that option away, and I'd like it back. :)
    Thursday, January 02, 2014 7:09 PM
  • Do you know what the option set in the registry for IE10?  The registry entry may still work.

    http://www.saberman.com

    Thursday, January 02, 2014 7:25 PM
  • this seems to work ok for me:

    IE11 on Win7:

    Tools, Options, Programs, Manage add-ons, Search Providers
    Select/highlight your Search Provider
    enable/disable "Search in the address bar"


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Proposed as answer by saberman Friday, January 03, 2014 5:19 AM
    Thursday, January 02, 2014 11:52 PM
  • Thank you Don, that worked!
    Tuesday, February 11, 2014 2:35 AM
  • I dislike the merging of address widget and search box.

    If they were separate would these problems go away?

    Bad design to force us into using something we don't want.  One answer is to find a browser that works the way you want it to!

    Thursday, June 12, 2014 8:07 PM
  • Don! I did what you suggested but the 1st issue is that the "I" bar pops up automatically in the address bar and then I have to manually move it to the search bar. I'd hope your suggestion was what I was looking for but not  quite. Any ideas on how to stop the "I" bar from starting in the address bar and instead starting in the search bar instead?

    Much Thanks!

    Monday, June 16, 2014 3:49 AM
  • Thank u, been trying to figure this prob out for awhile your suggestion worked
    Monday, September 01, 2014 4:16 AM