locked
HTTP 400 bad request

    Question

  • Hi!

     

    Recently after reinstalling Vista I am not able to config my network printer by using local IP address (192.168.x.x) in IE7. Ii keep getting HTTP 400 bad request. Check almost everything but couldn’t find solution to this problem.

    Is there any one whom can share any experience in this matter?

     

    /thanks
    Sunday, March 09, 2008 8:54 PM

Answers

  • Hi,

     

    Could you make sure that your network printer works smoothly on other computers? If yes, you can update the printer firmware to the latest version and try again.

     

    Besides, there is a workaround for a similar issue on Windows XP, which may be helpful for your scenario.

     

    Note: Backup the registry before you modify it.

     

    Delete everything under this key but leave the “default” value: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents

     

    Hope it helps.

    Tuesday, March 11, 2008 10:23 AM

All replies

  • Hi,

     

    Could you make sure that your network printer works smoothly on other computers? If yes, you can update the printer firmware to the latest version and try again.

     

    Besides, there is a workaround for a similar issue on Windows XP, which may be helpful for your scenario.

     

    Note: Backup the registry before you modify it.

     

    Delete everything under this key but leave the “default” value: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents

     

    Hope it helps.

    Tuesday, March 11, 2008 10:23 AM
  • Thansk for your help.

    But unfortunately it didn’t help me.

    I did try with other computer and same problem there. I took printer to my work and I could come in via writing IP address in IE and make changes and then take it home and it  I dose work with all of pc in my network. The only problem is I can get in to it by IE and see my configuration at web, which I had even with XP before.

    What I don’t get it is it does work with my old printer which also was HP even with my printer server which I had before that.

    Friday, March 14, 2008 2:29 PM
  • Hi,

     

    If all machines cannot visit the printer, could it be a networking problem? Or could it be a configuration error?

     

    Thanks.

    Monday, March 17, 2008 10:05 AM
  •  

    Hi!

    Non of machines can't visit the configuration site to change printer configuration. But all machines can print by local IP address and it does work as it should. I just don’t understand which configuration needs to change at my network or printer. It’s work before with print server and other printer also HP but not with this one (HP laserjet 1022n)

    Friday, March 21, 2008 11:14 AM
  • Hi,

     

    If you make sure the IP address is correct and supported on the network, it should be the printer's issue for no machine can visit it. Perhaps the HP service should be a better resource for you.

     

    Thanks.

    Monday, March 24, 2008 10:21 AM
  •  

    It’s .NET 3.0

     

    I had the same problem trying to view several of my HP LaserJet’s using HTTP on IE using either Windows 2003 Server or Win XP (some worked, some didn’t). The machines that DIDN’T have the HTTP issue all had .Net 2.0 on. The machines that DID have the HTTP issue all had .NET 3.0 on.

     

    I even un-installed .NET 3.0 from an XP workstation that was getting the HTTP error and after a re-boot, hey presto … it worked OK. (NOTE: I also tried installing the SP1 .NET 3.0 patch on another XP workstation, not only did that NOT work, but when I un-installed .Net 3.0 – I STILL had the HTTP error – so now I have no way of getting it to work)!

     

    However, an additional problem you have is that .NET 3.0 is part of Vista (i.e. built into the OS) so you cannot remove it! I’m about to look on the HP website to see if there is a firmware update for the 1022’s to see if that fixes the problem. If not, I found that you can view HP’s OK via HTTP using Firefox portable. I think (unless MS produce a fix for .NET 3.0), these are your only options…

    Thursday, March 27, 2008 10:15 AM
  • I was getting an HTTP 400 error when trying to connect to my HP LaserJet 1022n from IE8 in Windows 7.

    Figuring that the error might be related to IE8 or .NET 3.0, I instead tried to connect using Firefox, and it worked fine.


    Jeff Day, Social Platform GPM
    Friday, February 27, 2009 8:00 PM
  • I have the same problem. I am able to resolve it by uninstalling the Microsoft .NET Framework 3.5 SP1 and by following Yog Li's tip of "Delete everything under this key but leave the “default” value: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents" My question is what does this reg key do and will I run into other problems down the road after deleting the values?
    Wednesday, January 13, 2010 5:57 PM
  • I have the same problem. I am able to resolve it by uninstalling the Microsoft .NET Framework 3.5 SP1 and by following Yog Li's tip of "Delete everything under this key but leave the “default” value: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents" My question is what does this reg key do and will I run into other problems down the road after deleting the values?
    This registry key helps auto-generate an automatic string that goes out whenever you use Internet explorer.  It's called the "accept" string.  The string tells a web server what kind of page you prefer to get if the server is hosting two different versions of a page at a given URL. You can read all about it at this address:

    http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html

    For a much simpler version, go here:

    http://www.newmediacampaigns.com/page/browser-rest-http-accept-headers

    Trimming this string should not cause major problems, since it's just a list of formats you prefer to get.  Usually, at the end of the string, there is a catch-all that will tell the web server to send whatever it has if it can't find documents in the format you prefer.  In fact, cutting down this string may lead to a boost in performace in Internet Explorer.

    I also figured out why .NET 3.0 causes the HTTP 400 error for HP 1022n printers.  According to this website:

    http://www.enhanceie.com/ie/troubleshoot.asp

    this error will occur if your Accept or your User Agent strings are too long.  .Net tends to make both strings very long, causing the issue.  You can cut down your Accept string by following the instructions listed here.  To manually cut down your User Agent string go to the above website and scroll down to the part that says

    Problem: Overlong headers result in HTTP/4xx or HTTP/5xx errors, particularly on devices like routers or webcams

    Follow the instructions, restart Internet explorer, and your problem should be solved.  Following those instructions should solve the issure without having to uninstall .Net 3.0
    • Edited by -BnB- Monday, February 22, 2010 5:00 AM you probably have to restart ie for the changes to take effect
    Monday, February 22, 2010 4:59 AM
  • Wouldn't work with IE7.. Installed Safari, worked fine!
    Thursday, May 06, 2010 8:55 AM