none
IE11 (desktop), Win8.1: Java not working / compatible since update!

    Question

  • Hi there,

    Prior to the 8.1 update I was able to run java fine on the desktop IE10.  For work this is essential, as I access dropbox to upload files, etc.  I'd much rather keep using IE, however since 8.1 I get an alert that some of my add-ons are not compatible with the new enhanced security features, etc.

    I turned off "Enhanced Protected Mode", toggled various settings, uninstalled/reinstalled latest java, etc.  Still nothing working.  I'd rather not get a new browser as I love IE... any solutions?

    I'm running a 64bit OS & processor, high-end machine.

    Many, many thanks!

    Andrew

    Sunday, October 20, 2013 11:07 PM

All replies

  • Hi,

    when I download the latest version from

    http://java.com/en/download/windows-64bit.jsp

    the download gets saved with a .com extension instead of a .exe extension.

    Save the Java Update to your hard disk and rename it with a .exe extension instead of .com

    I have tried opening a support ticket at Java.com but it did not take (server error)...

    On the above download page (http://java.com/en/download/windows-64bit.jsp) you will find links to their help and support pages.

    You may have to first uninstall you previous versions of Java RTE before installing the upgrades.

    By default IE11 runs in Enhanced Protected Mode and you will need to install Both the x86 and x64 versions of Java RTE for it to work in all web pages.

    Post consumer questions about IE to http://answers.microsoft.com (Help>Online Support menu)

    Post questions about third-party software to their Website support forums.

    this forum is for questions about IEAK and GPO administration of domain networks using MSIE browsers.

    Regards.


    Rob^_^

    Monday, October 21, 2013 7:04 AM
  • Hi Rob!

    Thanks for the reply; I did as you suggested but sadly still nothing... there seems to be a long hang on Gmail loading now, as well as Dropbox uploader still not working.  I was trying to attach screens but it says my acct. here is not verified...

    Anybody else get this?

    Monday, October 21, 2013 7:08 PM
  • Hi Andrew,

    Based on your description, I would like to suggest you try the following:

    1. Check the add-ons. Open Internet Explorer, on the Tools menu, click Manage add-ons>Show all add-ons, locate and enable the java RTE add-ons

    2. Deselect the “Automatically Detect Settings” to check how it works.

    And enable the scripting of Java applets settings:

    a. Click "Tools" --> "Internet Options" 

    b. Next, select the Security Tab, and select the "Custom Level" button

    c. Scroll down to "Scripting of Java applets"

    d. Make sure the "Enable" radio button is checked.

    e. Click OK to save your preference.

    3. Check if the java script is enabled or not.

    How to enable JavaScript in a web browser?

    http://support.microsoft.com/gp/howtoscript

    4. Reset Internet Explorer settings to see the results.

    Reset Internet Explorer settings

    http://support.microsoft.com/kb/923737

    Please understand that reset Internet Explorer to its default configuration. This step will also disable any add-ons, plug-ins, or toolbars that are installed.

    5. Uninstall the older version of Java and install the latest version by follow the steps in the below link and let us know the status of the issue.

    Install Java in Internet Explorer:

    http://windows.microsoft.com/en-IN/internet-explorer/install-java#ie=ie-10-win-7

    In addition, I would like to share the link below with you:

    How to reinstall or repair Internet Explorer in Windows 7, Windows Vista, and Windows XP

    http://support.microsoft.com/kb/318378/en-us

    Regards,

    Blair Deng


    Blair Deng

    TechNet Community Support

    Wednesday, October 23, 2013 2:02 AM
  • Go to the C:\Program Files\Internet Explorer\iexplorer.exe and right-click it, Run as Administrator. Wow, java is enabled and works. I made a new shortcut to the EXE on my desktop and then changed the properties to always run As Administrator. I get the UAC prompt when you first open IE but big deal. Also MS just came out with KB2901549 that fixes the issue with the Adobe Reader IE plug-in. I imagine that the java issue will get fixed eventually so we don't have to do this workaround.

    Rick Faria / RDF Technical Services, LLC / SBSC

    Friday, October 25, 2013 2:33 PM
  • Hi Blair, Rick,

    Thanks for your suggestions!  I've been busy with work the past few days so apologies for my delayed response here.

    @Blair, I'll give that a shot.

    @Rick, sounds like that might be the easiest / direct answer until a fix or update is released (I too think it won't be a problem for more than a month tops).

    I'll try both tonight!!! Thanks you two!

    Best wishes,

    Andrew

    Friday, October 25, 2013 4:16 PM
  • As of Java 7u45 here is what I've observed with IE11 on Windows 8.1

    When you first install Java, IE disables the two SSV Helper Add-On's as incompatible.  When you try to access a site that uses Java, it seems to take a very long time as it downloads a third add-on called Java Plug-in 10.45.2.  This leads me to believe that IE is now supporting extensions that used to only work on Firefox/Chrome.  Once this install finishes, you should be able to access your site.  When you close IE, the add-on seems to disappear.  The next time you visit the site that requires Java, it seems to load a little quicker.  

    We have changed a setting in the Java control panel so that Check for certificate revocation using is set to Certificate Revocation Lists (CRLs) only.  Whatever process the OCSP check uses lags Java really, really badly and triples the loading time of every page load.  

    In addition, IE11 continues to inform you that you have incompatible add-ons but you cannot disable or remove them without breaking Java.  For whatever reason the 10.45.3 plugin won't download unless Java is installed and I cannot seem to prevent the incompatible add-ons from installing.

    Monday, November 04, 2013 6:24 PM
  • Go to the C:\Program Files\Internet Explorer\iexplorer.exe and right-click it, Run as Administrator. Wow, java is enabled and works. I made a new shortcut to the EXE on my desktop and then changed the properties to always run As Administrator. I get the UAC prompt when you first open IE but big deal. Also MS just came out with KB2901549 that fixes the issue with the Adobe Reader IE plug-in. I imagine that the java issue will get fixed eventually so we don't have to do this workaround.

    Rick Faria / RDF Technical Services, LLC / SBSC


    It's been months and the issue hasn't been fixed. Mike Plichta's workaround doesn't work for me. The only way for me to have a Java applet running in IE11 is indeed to run IE11 as an administrator. For the record I use IE11 in desktop mode with the latest JRE and Microsoft patches.
    Thursday, December 19, 2013 1:57 PM
  • I've been wondering why Java no longer worked in IE11.  What a mess.  I hope MS would have the good grace to fix it someday before Windows goes out of fashion!

    Ron

    Thursday, January 16, 2014 6:13 AM
  • Hey I had the same problem.

    I needed to remote login to a clients server that was set up for IE 7!

    Here's how I fixed it...

    1. I downloaded the latest Java RE- 32bit version
    2. (so I have both the 64bit and 32bit installed)
    3. Then I went to the Compatibility View and added the sites I needed to go to
    4. Then I made sure ActiveX filtering was NOT checked

    I have been able to remote without incident ever since.

    Hope this helps!

    (Big Ups to Rob^_^ for the initial Java Install advice!)
    • Proposed as answer by SCSTeve Friday, January 24, 2014 7:18 PM
    • Edited by SCSTeve Friday, January 24, 2014 7:23 PM
    Friday, January 24, 2014 7:17 PM
  • check out my post above
    Friday, January 24, 2014 7:24 PM
  • There are some clever people answering this post and we are all doing the same logical things and they simply don't work. I don't think we are actually doing anything wrong. We probably just need to look outside the box rather than in it.

    I will throw one in as a possible. Nothing to do with Onedrive by chance?

    I have a test applet on a web site and it works just fine in virtually all other scenarios. When I run it with the 8.1, IE11 combination the Java icon appears at the bottom and it just seems to time out. I did notice the Onedrive symbol flashed beside the Java icon as though it was doing something.

    The Java is fine as I can run Java desktop programs on the same machine.

    Got to be something like this. How can we all experience the same problem and not be able to resolve it by tweaking the systems?


    Norman

    Thursday, May 15, 2014 9:34 PM
  • I have now had the time to experiment with this further. This is an observation on what I see.

    I went into Group Policy using gpedit.msc and disabled Onedrive from operating. I then removed the Onedrive startup sequence. After a reboot I could immediately use Java Applets everywhere without any changes to anything else, this included the test site that I was using before.

    Apparently temporary files (which Java Applets actually are) and other files are copied into Onedrive first. I suppose the logic is that if they end up there then they are not local any more and you cannot run them.

    If you, like me, were one of the people who were very frustrated over this problem then could you please repeat this sequence and just confirm that this resolves this particular issue?


    Norman

    Wednesday, May 21, 2014 10:43 AM