none
Problems with Secure sites (HTTPS) with Internet Explorer 10 on Windows 8

    Question

  • I continue to have issues with secure websites when using IE 10 on Windows 8.  Any https site I go to, my page displays nothing.  It basically won't ever load the page.  Non secure websites don't seem to load completely either. I have reset my setting and have also done many different things based on the other forums where I've seen fixes, but those have not fixed the problem.  I also have not seen any Microsoft KB item that addresses this issue.  What is the fix for this??  Is there one??
    Monday, February 25, 2013 3:17 PM

Answers

  • Any https site I go to, my page displays nothing.

    What do you have for secure protocol re-negotiation?   FWIW I found recently that many sites will exhibit the symptom you are describing if just  Use TLS 2.1  is checked.   So, try checking them all and that will mean that they will all be tried, presumably in descending order, if necessary.

    Tuesday, February 26, 2013 1:25 PM

All replies

  • Hi,

    when asking a question in an internet related forum it is helpful for us if you can include the addresses of any websites you are having problems with, so that we can investigate the site.... apparently web programmers make mistakes.

    Questions regarding Internet Explorer 8, 9 and 10 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us

     

    a common mistake made by 'users' is to add domains to their Trusted Sites list and check the secure protocol checkbox..... sites like google, Microsoft, facebook and yahoo and now many others use an authentication sub domain... IE has a security setting to prevent navigation into a zone of lower integrity.

    web sites work just as well if they are not placed in the Trusted Sites list... the trusted sites list is mostly used by company networks for B2B commerce...

     


    Rob^_^

    Tuesday, February 26, 2013 3:07 AM
  • Any https site I go to, my page displays nothing.

    What do you have for secure protocol re-negotiation?   FWIW I found recently that many sites will exhibit the symptom you are describing if just  Use TLS 2.1  is checked.   So, try checking them all and that will mean that they will all be tried, presumably in descending order, if necessary.

    Tuesday, February 26, 2013 1:25 PM