none
How can I disable Suggested Sites feature in IE 10?

    Question

  • I have unchecked the Enable Suggested Sites feature in Tools > Advanced > Browsing.

    Yet, IE 10 keeps suggesting web sites to my while I'm typing web addresses into the address bar.

    How can I reliably disable this behaviour? I don't want to feed search engine robots.


    Vote here for a Microsoft Connect feedback channel on Windows - and win a better Windows!
    Vote here for a consistent keyboard shortcut support in Visual Studio and other Microsoft products!


    • Edited by BetterToday Saturday, September 29, 2012 12:43 PM
    Saturday, September 29, 2012 12:43 PM

Answers

  • How can search from the address bar be disabled?

    In the Manage Add-ons Search Providers dialog you could disable Search Suggestions for your default search provider and optionally uncheck:  Search from the Address bar.   Related to this from the Options Contents tab you could navigate to Autocomplete Settings and uncheck Use AutoComplete for Address bar.   I think it is probably Search Suggestions that is bothering you the most but you might not be liking the AutoComplete for Address bar feature too.  Otherwise I think disabling Search from the Address bar means that you can't use the IE search feature at all, even trying an explicit question mark space (? ) prefix, which I think is more drastic than one might expect.  Disabling Search from the Address bar also has the quirky effect of forcing the feature of allowing single-word Intranet names to be used without a protocol prefix, which is otherwise needed to bypass the user's default search provider when such connections are slow.

     
    FYI

     
    Robert
    ---

    • Marked as answer by BetterToday Saturday, September 29, 2012 10:14 PM
    Saturday, September 29, 2012 10:01 PM
    Answerer
  • That's it! Excellent.

    Following your suggestions I tested which option is responsible for web site suggestions:

    It's basically Internet Options > Contents > AutoComplete Settings > Suggesting URLs, just like you said.

    With this information I could even find a blog entry explaining this setting. Perhaps this information will help others facing the same problem.

    Thanks a lot, Robert!

    Regards,
    Axel


    Vote here for a Microsoft Connect feedback channel on Windows - and win a better Windows!
    Vote here for a consistent keyboard shortcut support in Visual Studio and other Microsoft products!

    • Marked as answer by BetterToday Saturday, September 29, 2012 10:14 PM
    Saturday, September 29, 2012 10:14 PM

All replies

  • How can I reliably disable this behaviour? I don't want to feed search engine robots.

    Disable search from the Address bar or use a default search which does not do Search Suggestions, such as Microsoft Search, instead of BING or Google.
     



    ---
    Saturday, September 29, 2012 4:07 PM
    Answerer
  • How can search from the address bar be disabled?

    I already have disabled every autocomplete option in IE that seems available:

    (I'm sorry but I have IE available only in German.)


    Vote here for a Microsoft Connect feedback channel on Windows - and win a better Windows!
    Vote here for a consistent keyboard shortcut support in Visual Studio and other Microsoft products!

    Saturday, September 29, 2012 8:59 PM
  • How can search from the address bar be disabled?

    In the Manage Add-ons Search Providers dialog you could disable Search Suggestions for your default search provider and optionally uncheck:  Search from the Address bar.   Related to this from the Options Contents tab you could navigate to Autocomplete Settings and uncheck Use AutoComplete for Address bar.   I think it is probably Search Suggestions that is bothering you the most but you might not be liking the AutoComplete for Address bar feature too.  Otherwise I think disabling Search from the Address bar means that you can't use the IE search feature at all, even trying an explicit question mark space (? ) prefix, which I think is more drastic than one might expect.  Disabling Search from the Address bar also has the quirky effect of forcing the feature of allowing single-word Intranet names to be used without a protocol prefix, which is otherwise needed to bypass the user's default search provider when such connections are slow.

     
    FYI

     
    Robert
    ---

    • Marked as answer by BetterToday Saturday, September 29, 2012 10:14 PM
    Saturday, September 29, 2012 10:01 PM
    Answerer
  • That's it! Excellent.

    Following your suggestions I tested which option is responsible for web site suggestions:

    It's basically Internet Options > Contents > AutoComplete Settings > Suggesting URLs, just like you said.

    With this information I could even find a blog entry explaining this setting. Perhaps this information will help others facing the same problem.

    Thanks a lot, Robert!

    Regards,
    Axel


    Vote here for a Microsoft Connect feedback channel on Windows - and win a better Windows!
    Vote here for a consistent keyboard shortcut support in Visual Studio and other Microsoft products!

    • Marked as answer by BetterToday Saturday, September 29, 2012 10:14 PM
    Saturday, September 29, 2012 10:14 PM