none
Java will not run in IE9

    Question

  • I find this problem posted all over the internet -- however, I have found few answers and no solutions that work.

    Java will not run in IE9 

    In the last three days I have installed Java 7.5 at least five times (after total uninstalls).

    I have Windows 7 Home premium with all updates installed.  Anti-virus programs are installed.

    Even the java website   http://www.java.com/en/download/testjava.jsp cannot detect the Java program in IE9.  It displays the following message:  “No working Java was detected on your system.  Install Java by clicking the button below.”

    I know you don’t want to hear about other browsers, however, this is part of the diagnoses – Java works fine in Chrome.  (Obviously, there are some programs that can only be accessed in IE.)

    I have tried turning off the firewall, anti-virus AVG, active x filtering, and every other program.  I have cleared the browsing history, cookies, etc.  50 times = nothing works.

    I experienced that Java did work once and only once in IE9 after each of two new reinstallations of Java 7.5.

    Process Explorer shows that Java is running, I’ve included a screen- shot (hope it shows up)

    All knowledgeable answers are appreciated.

    Java running in Process Explorer

    Tuesday, June 26, 2012 10:34 PM

Answers

  • Dear Vincent Wang and all readers,

    I found the solution to this problem (shown below) to be that the UAC must be turned ON to get the permssion to "perform the action"

    Fix a corrupted user profile

    When I get to step 10 of this process (pasting the files into the new user folder), I keep getting this message: "You need permission to perform this action"

    ----- so now I am in the 8th+ hour of applying all the user customization to the "new" User account, after taking 4 hours to copy all the files from the "old" User account as prescribed in Fix a corrupted user profile article.

    Hope Java or Microsoft can find a better solution to this problem than this.  Java will not run in IE9.  Which apparently is connected to something in the UAC (user account control).

    Thanks to Vincent Wang for all his help!!

    I consider this case closed.

    • Marked as answer by Nmex Ron Sunday, July 08, 2012 12:08 AM
    Sunday, July 08, 2012 12:07 AM

All replies

  • Hi,

     

    Have you tried the compatibility mode in Internet Explorer 9? Or does this issue occur to previous Internet Explorer versions?

     

    For reference about compatibility mode:

    http://blogs.msdn.com/b/ie/archive/2010/10/19/testing-sites-with-browser-mode-vs-doc-mode.aspx

    How to use Compatibility View in Internet Explorer 9


    You could try to deselect the “Automatically Detect Settings” to check how it works.

     

    And enable the scripting of Java applets settings:

     

    1. Click "Tools" --> "Internet Options"  

    2. Next, select the Security Tab, and select the "Custom Level" button

    3. Scroll down to "Scripting of Java applets"

    4. Make sure the "Enable" radio button is checked.

    5. Click OK to save your preference.

     

    Or you could try to change the settings in group editor:

     

    Computer Configuration\Administrative Templates\Windows Components\Internet Explorer\Internet Control Panel\Security Page\Internet Zone\Java Permissions

     

    Meanwhile, I suggest you could reset Internet Explorer settings to see the results.

     

    Hope this helps.


    Vincent Wang

    TechNet Community Support

    Thursday, June 28, 2012 9:13 AM
  • Dear Vincent Wang,

    I tried “Compatibility Mode” it only produced a box with the red X in it, but no other result.

    I tried to load IE8, however Windows 7 will not load/ accept it.

    You said:

    You could try to deselect the “Automatically Detect Settings” to check how it works.

    I am not sure where you are referring to this setting.

    You next said:

    • And enable the scripting of Java applets settings:

    1. Click "Tools" --> "Internet Options"

    2. Next, select the Security Tab, and select the "Custom Level" button

    3. Scroll down to "Scripting of Java applets"

    4. Make sure the "Enable" radio button is checked.

    5. Click OK to save your preference.

    This was already set to enable.

    You next suggested:

    • Or you could try to change the settings in group editor:

    Computer Configuration\Administrative Templates\Windows Components\Internet Explorer\Internet Control Panel\Security Page\Internet Zone\Java Permissions

    I am not sure where this is.

    You then said:

    Meanwhile, I suggest you could reset Internet Explorer settings to see the results.

    I am considering this, or just uninstalling IE9 and reloading it.

    I appreciate your advice and await your clarification of where to locate “Computer Configuration” and the “Automatically Detect Settings”.

    For additional information, I have also sumbitted this problem to JAVA, however so far I have not heard from them.

    Thanks for your help!


    • Edited by Nmex Ron Friday, June 29, 2012 5:14 AM Clarification
    Friday, June 29, 2012 5:12 AM
  • Hi


    Regarding the “Automatically Detect Settings”:


    1. Click "Tools" --> "Internet Options"

    2. Next, select the Connection Tab, and select the "LAN settings" button

    3. uncheck " Automatically Detect Settings "


    The Group Policy could be found using the following steps:


    1. click start button, type “gpedit.msc” in search bar and press enter.

    2. Under  Computer Configuration\Administrative Templates\Windows Components\Internet Explorer\Internet Control Panel\Security Page\Internet Zone\Java Permissions

    And then change the settings.


    Meanwhile, also try the reset Internet Explorer settings.


    Hope this helps.


    Vincent Wang

    TechNet Community Support

    Monday, July 02, 2012 1:29 AM
  • Dear Vincent Wang,

    Thanks again for your assistance; I am sure we are getting closer.

    First in response to your latest suggestions:

    ... uncheck "Automatically Detect Settings " = This was already unchecked.

    -------------

    … click start button, type “gpedit.msc” in search bar and press enter. = Returned "no items match your search"

    -------------

    Next I reset Internet Explorer settings.  Initially this did not resolve the problem, however I then uninstalled Java, reset IE settings again, then reinstalled Java.  When restarting a security message popped up including the message:  This program will open outside of Protected mode.”

    In researching this phrase on the internet I found a case from 2008, with very similar symptoms.

    http://www.vistax64.com/vista-security/177968-ie7-vista-uac-java-snot.html

    I tried some of the things that helped in the solution in this case.

    I opened the “Guest” account to run IE and this Java program MSN Games Word Mojo, and it ran just fine!

    Then I tried Opening IE9 using Run as Administrator = program using Java would not run.  Then in addition I tried turning off “Protected Mode” and running as Administrator and the program still will not run.

    I surmise that User Account Control is keeping Java from running when I am logged in as the Administrator .

    Thoughts?

    Monday, July 02, 2012 7:23 PM
  • Hi,


    Since you could run the IE and this Java program fine using the Guest account, I suggest you can try to create a new admin account and a standard user test the issue.


    In addition, if you surmise that the UAC affect this, you can also temporarily disable UAC to check the result.


    More reference:

    Fix a corrupted user profile

    What are User Account Control settings?


    Regards


    Vincent Wang

    TechNet Community Support

    Wednesday, July 04, 2012 6:55 AM
  • Dear Vincent Wang,

    Following your latest suggestions I disabled the UAC; this did not help = still no java.

    Also, while bringing up the Java "Verify Installation" website this message appeared in a pop-up:

    “This webpage wants to run the following add-on: ‘deployJava1.dll’ from ‘Oracle America, Inc’. What’s the risk? “Allow”

    I clicked on allow.

    ------------------------------

    I did create another User profile, and that user can access programs using Java. As well as showing Java as installed when using the tool on the java website http://www.java.com/en/download/testjava.jsp

    ------------------------------

    So I attempted your next suggestion, following the instructions at:  Fix a corrupted user profile

    When I get to step 10 of this process  (pasting the files into the new user folder),  I keep getting this message:

    "You need permission to perform this action"
    "You require permission from _(the old User folder)_ to make changes to this folder."

    I have turned off all passwords and enabled all sharing under “Advance Sharing”; still the message continues, and will not allow me to copy the files from one user to another.

    Your assistance is again appreciated.

    Friday, July 06, 2012 8:01 PM
  • Dear Vincent Wang and all readers,

    I found the solution to this problem (shown below) to be that the UAC must be turned ON to get the permssion to "perform the action"

    Fix a corrupted user profile

    When I get to step 10 of this process (pasting the files into the new user folder), I keep getting this message: "You need permission to perform this action"

    ----- so now I am in the 8th+ hour of applying all the user customization to the "new" User account, after taking 4 hours to copy all the files from the "old" User account as prescribed in Fix a corrupted user profile article.

    Hope Java or Microsoft can find a better solution to this problem than this.  Java will not run in IE9.  Which apparently is connected to something in the UAC (user account control).

    Thanks to Vincent Wang for all his help!!

    I consider this case closed.

    • Marked as answer by Nmex Ron Sunday, July 08, 2012 12:08 AM
    Sunday, July 08, 2012 12:07 AM
  • Resetting the user settings solved my issue on Win7 IE9. 

    Thanks!!!

    Steve

    Thursday, August 16, 2012 2:51 AM
  • I know it might be irrelavant to extend this thread after issue is closed.But I had the same issue and above solution just did not work for me.After hours I realized that I have installed java's 64 bit version as my OS is 64bit. When I opened IE 64bit,it started working.

    Although for Chrome it still an issue...


    Parth

    Tuesday, September 04, 2012 4:27 AM
  • Well, I too wish the issue was closed.

    The problem occurred again when attempting to upload the latest version of Java. (Version 7 Update 7)

    Again, the java website http://www.java.com/en/download/testjava.jsp cannot detect the Java program in IE9, after the latest update. It displays the following message: “No working Java was detected on your system. Install Java by clicking the button below.”

    Again certain Microsoft programs dependent on Java would not work. I say "would" because I restored my computer to a point before installing the latest Java version.  I currently am back to Java 7.0.50

    I do not consider creating a new user account and profile "a fix".  I spent hours creating the new account / profile and many days re-customizing the “new account”.  Since there is no way (that I am aware of) to truly copy an existing account.

    It seems this whole UAC (User Account Control) is only an aggravation and not needed on a home computer system.

    So here we are again Java and Microsoft – it does not work – why?

    Friday, September 07, 2012 6:42 PM
  • I suggest that this is a problem totally between Java and Windows 7 UAC.

    Only Java or Microsoft can solve this one:

    I can now get the game of Microsoft Word Mojo to play by opening IE9 using “Run as Administrator”.

    The screenshot below shows Java showing it is not installed, while Control panel shows it is.

    Come on Sun and / or Microsoft let's get this fixed!

    I can now get the game of Microsoft Word Mojo to play by opening IE9 using “Run as Administrator”.

    Java says not installed Windows shows is installed

    Saturday, September 08, 2012 2:33 AM
  • Come on Sun and / or Microsoft let's get this fixed!

    That would be Oracle now, I think.   Ask them?

    E.g. in your screenshot I saw Java for Chrome but I'm not sure that would imply Java for IE.

    ---

    Saturday, September 08, 2012 7:56 PM
  • Oracle??

    Well, this is what Microsoft recently sent me:

    Solve a problem with Java

    Java has stopped working properly.

    Click 
 to go online to the Sun Microsystems Inc. website for more info and support optionsClick to go online to the Sun Microsystems Inc. website for
    more info and support options

    --------------

    I did "ask" Java -- I sent then a trouble report in June 2012 when I first posted on this site.  I have received no answer (no surprise).

    -------------------

    Why do you say Java for Chrome?  My understanding is that it is Java for Windows and should work in IE or Chrome or whatever.

    The screenshot is of IE9 not Chrome (see the little gear icon in the upper right corner? -- Chrome would have a wrench.

    ------------------------------

    A Microsoft and Java problem!

    I still am confident that this has to do with the Windows 7 UAC.

    Monday, September 10, 2012 5:58 PM
  • Why do you say Java for Chrome?  My understanding is that it is Java for Windows and should work in IE or Chrome or whatever.

    I was looking at your first screenshot--the ProcExp Find.   I think it is still the case that Java for IE is implemented as an ActiveX extension which would not be the case for Chrome.   See what happens if you use IE9's ActiveX Filtering (Alt-x,S,X).  Is Java still allowed then?   Or does it give you a message saying it is not detected (for example)?

     
    ---

    Monday, September 10, 2012 10:14 PM
  • ActiveX filtering on or off brings the same result = "No working Java was detected on your system. Install Java by clicking the button below."
    Tuesday, September 11, 2012 2:20 PM
  • ActiveX filtering on or off brings the same result = "No working Java was detected on your system. Install Java by clicking the button below."

    You would have to do that test on a normal working IE9 (or have someone else who has the same configuration--IE9 and Java and Chrome--report their results).  If you have an otherwise identical configuration which works as expected you could usefully trace both cases with ProcMon and compare the traces for their essential differences.
    Tuesday, September 11, 2012 3:14 PM
  • Robert Aldwinckle, 

    I am not sure what you mean here -- "You would have to do that test ..."  I was simply responding to your request "See what happens if you use IE9's ActiveX Filtering (Alt-x,S,X).  Is Java still allowed then? "

    My answer to your question is no, Java still does not work with ActiveX Filtering.

    Friday, September 28, 2012 3:14 PM
  • I am not sure what you mean here -- "You would have to do that test ..."

    If your system is broken you can't do a useful test to determine if Java still requires ActiveX to be seen under IE.   If it does it negates your comment about Chrome, which AFAIK doesn't use ActiveX.

     
    ---

    Friday, September 28, 2012 6:48 PM
  • A Microsoft and Java problem!

    I am confident that problem is a Windows 7 UAC problem.

    Saturday, September 29, 2012 2:16 AM
  • Finally today with the installation of Java7 update 9, and only after turning off ActiveX filtering in IE9.0.10, I recieved this message:

    Verified Java Version

    Completion checkmark

    Congratulations!

    You have the recommended Java installed (Version 7 Update 9).
    Saturday, October 20, 2012 3:14 PM
  • Just to report on my scenario.

    Running Window 7 Pro, 64 bit.

    Running the 64bit version of IE did not enable Java.

    If I run the 32 bit as administrator, Java works fine.

    If I disable Active X filtering, Java works fine.

    Tuesday, October 30, 2012 7:04 PM
  • Hi everyone,

    Java did not work in my case, either.

    All instructions are done by me as written above, moreover Active-X filtering is also disabled.

    The key for solution is that you should reset settings of all zones to default at Internet Explorer ->Tools -> Settings -> Security. Click the tab at the bottom.

    Saturday, November 17, 2012 7:15 PM
  • I beat my head against the wall with this for several months before finally fixing the problem on my wife's laptop.  She likes to play the games on Pogo.com.  One day out of the blue it started telling her that it couldn't detect Java when she tried to play using the default 32-bit IE9.  It worked fine with the 64-bit IE9 (I'd installed both  32- and 64-bit Java), on Firefox, and on Google Chrome, but not on the 32-bit IE9.  I tried everything I could think of -- doing clean reinstalls of Java, resetting IE to default settings, reverting to IE8, etc., etc., and nothing worked.  Not one to give up, I was playing around with it tonight and stumbled upon the answer, in this case at least.

    I went into IE9's Tools/Internet Options/Security/Custom Level (for Internet zone) and set EVERYTHING that would allow it under Active-X Controls and Plug-ins to "prompt."  On going to the Pogo.com page it started popping up prompts left and right, and each time it did I clicked on Allow.  It loaded the Java apps for the first tme in months.  I then went back into Tools/Internet Options/Security and clicked "Reset all zones to custom level," then exited and reopened IE9.  Java was now working again in 32-bit IE9.

    Yes, I'd done the "Reset all zones to custom level" thing at least several times before, but apparently some setting had gotten screwed up and was not being reset.  Manually allowing Java components to load apparently fixed it.

    Tuesday, April 30, 2013 4:36 AM
  • Hi,

    its' "Reset all zones to default" not "Reset all zones to custom level"

    Start>Control Panel>Java 32.... the new UI control panel for Oracle Java RT has its own security zone adjustments.

    Regards.


    Rob^_^

    Tuesday, April 30, 2013 5:55 AM
  • "I beat my head", thank you for your post!

    I have spent the last week doing the same thing that everyone above tried. I read your post about the Active-X prompts, tried it and I now have the vista machine working with java and pogo using IE9.

    The manually allowing java worked!

    Thanks

    Thursday, January 09, 2014 12:23 AM