none
Web page cannot be displayed in IE8, but displayed in Firefox

    Question

  • A certain webpage https://www2.mijnagentschapszw.nl cannot be displayed in IE8, but works fine in Firefox. I have tried to reset the IE settings, add the site to trusted sites and allowed every security option for that zone. It is possibly due to the certificate, because when I put fiddler 2 in the middle the the website works fine. Without fiddler it just gives me "page cannot be displayed" in IE8. With fiddler I get a request to accept the fiddler certificate in IE8. If i accept it I get an question to only allow the content of the page to be displayed transmitted via a secure connect (sorry it is translated from dutch). If I click on "Yes" the page is displayed fine. In fiddler I saw that the certificate is accessedhttp://trust.quovadisglobal.com/en is called qvocag2.crt. What can be the issue? I do not want to upgrade to IE9, because of the use of some webapplications and possible problems with these. Secondly, it is on a Server 2003 terminal server. It does not work on any other server (that are not TS) as well.
    Tuesday, April 10, 2012 7:40 AM

Answers

All replies

  • Hi,

    Fiddler uses its own Proxy.... see the documentation at http://fiddlertool.com for an explantion of how this works... this indicates it has something to do with your network settings....

    I get redirected to https://www2.mijnagentschapszw.nl/portaal/page/login

    on that page I get the following warning....

    SEC7111: HTTPS security is compromised by javascript:void(0) 
    

    in engine.js (to debug in IE8, F12>Script tab, "Start debugging" ...add breakpoints, then refresh the page... the debugger will now break on errors or at your breakpoints..)

    I see in engine.js you are using UAS sniffing to inject iframes into the document for safari browsers? <ifram scr="void(0)".... where the above security warning occurs....avoid iframes on secure pages...typically this is what a phishing site would use and IE has security zone settings to prevent navigation across domains in different security zones...and XSS protection.

    the page is very complex and uses IE Conditional Comments, an old version of jQuery and XMLHTTP requests on the onload event...Much more than I would expect for a simple login page...load time is just over 20 seconds.... (target 3 seconds) this may cause IE to timeout...

    the page has validation errors... use the transitional dtd i/o the strict version as IE7 browsers will probably not render as expected.

    I would suggest that you install IE9 and use its Developer tool to debug and profile your page.... IE9 has compatibility view to allow you to emulate IE8 or 7 on your web sites... there should be no reason why you cannot install it and not develope for legacy web sites.

    see the IE9 Developer Center - http://msdn.microsoft.com/en-us/ie/aa740469.aspx

    for questions about html, css or scripting post to http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads


    Rob^_^

    Tuesday, April 10, 2012 9:03 AM
  • Hi IECustomer,

    The OS of the terminal server (did I already mention that?) is W2K3 server and if Iam not mistaken IE9 is not supported on this OS. Secondly, we are running an application and the supplier does not support this version on IE9. Is there no possibility that we can get IE8 to display the website? Also your story lets me suspect that we developed the website, but that is not the case. It is a site of the Dutch government and I don't think that we will get them to change the website.

    Wednesday, April 11, 2012 10:05 AM
  • Hi,

    Also try to disable firewall for test. Or use IE compatible view to open this website.

    Furthermore, go to IE\Tools\Internet Options\Content\Certificates, remove certificate and clear SSL state for test.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Thursday, April 12, 2012 3:32 AM
  • @Niels,

    the important point to my reply was that fiddler uses its own proxy to make a connection...suggesting as Leo points out that you should disable your firewall for a test....

    we have no certificate prompts accessing the link you posted https://www2.mijnagentschapszw.nl/

    what https settings do you have for fiddler...?

    see Tools>Fiddler settings HTTPS

    I see a 302 redirect at http://www2.mijnagentschapszw.nl/  after the first request to https://www2.mijnagentschapszw.nl/  (the certificate certification occurs on the first request....)

    Now we don't have the site in any IE Security Zone..... you probably have placed it in your Trusted Sites list and have checked use a secure connection?

    and of coarse you have told us that it works fine in FX....

    so the answer probably is...

    go tools>Internet Options>Security tab, click "Reset all zones to default"

    Trusted Sites Icon, 'Sites' button...

    either

    1. Remove https://www2.mijnagentschapszw.nl/ from the trusted sites list

    or

    2. Replace it with *.mijnagentschapszw.nl and uncheck the "Require a secure connection" option....

    or

    3. Add http://www2.mijnagentschapszw.nl/ and uncheck the "Require a secure connection" option...

    there are IE security zone settings for meta redirects and navigation between sites in different security zones... so https://www2.mijnagentschapszw.nl/

    and

    http://www2.mijnagentschapszw.nl/ 

    will be mapped to different security zones in IE browsers if you have https:/www2.mijnagentschapszw.nl only in the Trusted Sites zone. 

    Your firewall may be blocking the http domain also.....

    General rule of thumb is that if a web page works in Firefox or another browser but does not work in IE, then the issue will be because of either

    IE's Security zone settings (because IE uses a different security model to the other browsers) (fix: reset your IE security zone settings to their default and remove the site from your trusted or restricted sites list)

    or

    one of your IE Addons is causing the problem (test by running IE in no-Addons mode)

    I am pretty sure that is the issue..... we have no certificate prompts when accessing the site because we do not have the site in the Trusted or Restricted sites lists....(default is Internet Zone) .... that is why it works for us both in IE and in Firefox.

    Regards.

    Rob^_^


    Thursday, April 12, 2012 8:40 AM
  • Hi IE customizer, thanks again for your long reply. I have tried something here and there:

    0. The firewall is not active on the local machine. It is a central firewall solution. It is letting firefox through, so IE8 traffic should be allowed as well?
    1. Fiddler settings are:
    - Enabled Capture HTTPS Connects
    - Enabled Decrypt HTTPS traffic
    .... from all processes
    - Disabled Ignore server certificate errors

    2. What you told me about the redirect let me notice that when I open the site in IE8 it still says the https site in the address bar instead of a redirect to http. Just for info.
    3. Yes, I have placed it in the trusted sites list. I have replaced the https to the "*...." and that does not work. I have tried all you other options as well without result.
    4. Security zones settings were already set to default
    5. I have resetted the internet explorer settings again and removed the sites from trusted zone. Restarted IE and still does not work.

    :-(((( Is there anything else I could try?

    Thursday, April 12, 2012 1:30 PM
  • Hello Leo,

    I have these options and the options from IE customizer, but :-((((( no result. Any other thoughts?

    Thursday, April 12, 2012 1:34 PM
  • Hi,

    when you say local machine, do you mean on a local intranet site?

    try removing it from the Trusted sites list...

    have you tried in noAddons mode yet?

    Regards.


    Rob^_^

    Thursday, April 12, 2012 7:40 PM
  • A certain webpage https://www2.mijnagentschapszw.nl cannot be displayed in IE8, but works fine in Firefox. I have tried to reset the IE settings, add the site to trusted sites and allowed every security option for that zone. It is possibly due to the certificate, because when I put fiddler 2 in the middle the the website works fine. Without fiddler it just gives me "page cannot be displayed" in IE8. With fiddler I get a request to accept the fiddler certificate in IE8. If i accept it I get an question to only allow the content of the page to be displayed transmitted via a secure connect (sorry it is translated from dutch). If I click on "Yes" the page is displayed fine. In fiddler I saw that the certificate is accessedhttp://trust.quovadisglobal.com/en is called qvocag2.crt. What can be the issue? I do not want to upgrade to IE9, because of the use of some webapplications and possible problems with these. Secondly, it is on a Server 2003 terminal server. It does not work on any other server (that are not TS) as well.

    I found the solution!

    It's a problem with the certificate.

    Try this hotfix: http://support.microsoft.com/kb/938397

    • Proposed as answer by xgwsroe Tuesday, July 03, 2012 1:00 PM
    Monday, July 02, 2012 11:10 PM