none
Internet Explorer 9 opens .csv instead of download

    Question

  • Hello,

    I have a problem in terms of Internet Explorer 9 handling with attachments .Txt or. Csv: On a 64 bit Windows 7 Enterprise workstation with IE9, csv files are automatically opened in a new tab without displaying the save / open options. The regular (in IE8) windos for saving files is not showing in any  other tested browsers, Firefox 21 and Chrome.

    I did a downgrade to Internet Explorer 8 and the problem was gone on all browsers, I went back to Internet Explorer 9 and again I face this problem. I reset IE settings to default, check for add-ons, tried to open the website without addons, non of this worked.  I tried also IE 10 and 11 and the problem is the same. It affects the settings for all other browsers.

    I need to make this work in Internet Explorer 9, if there is any other solution, please help!
    Thanks in advance!
    Wednesday, August 07, 2013 10:59 AM

Answers

  • Hi,

    Start>Run Regedit.exe

    HKCR\.csv

    what opener application do you have associated for files with a .csv association?

    your server should be using a application/octet-stream MIME-TYPE...

    you probably still have Office 2003 installed and IIS6 on the server.


    Rob^_^

    Wednesday, August 07, 2013 11:10 PM
  • Hi Cozmin,

    I would like to suggest you set .csv association with Excel through default program.

    Regards,

    Blair Deng


    blair deng

    TechNet Community Support

    Thursday, August 08, 2013 7:43 AM
    Moderator

All replies

  • Hello,

    I have a problem in terms of Internet Explorer 9 handling with attachments .Txt or. Csv: On a 64 bit Windows 7 Enterprise workstation with IE9, csv files are automatically opened in a new tab without displaying the save / open options. The regular (in IE8) windos for saving files is not showing in any  other tested browsers, Firefox 21 and Chrome.

    I did a downgrade to Internet Explorer 8 and the problem was gone on all browsers, I went back to Internet Explorer 9 and again I face this problem. I reset IE settings to default, check for add-ons, tried to open the website without addons, non of this worked.  I tried also IE 10 and 11 and the problem is the same. It affects the settings for all other browsers.

    I need to make this work in Internet Explorer 9, if there is any other solution, please help!

    Thanks in advance!
    Wednesday, August 07, 2013 8:25 AM
  • Hi,

    Start>Run Regedit.exe

    HKCR\.csv

    what opener application do you have associated for files with a .csv association?

    your server should be using a application/octet-stream MIME-TYPE...

    you probably still have Office 2003 installed and IIS6 on the server.


    Rob^_^

    Wednesday, August 07, 2013 11:10 PM
  • Hi Cozmin,

    I would like to suggest you set .csv association with Excel through default program.

    Regards,

    Blair Deng


    blair deng

    TechNet Community Support

    Thursday, August 08, 2013 7:43 AM
    Moderator