none
Loading a site with FQDN name is slow, with NETBIOS name it is very fast

    Domanda

  • After the migration to Windows 7 64 bits, loading de SharePoint 2010 portal with the FQDN in the IE as default page is very slow. After starting IE and waiting you can start a FireFox session en type the FQDN url and then the FireFox site is the first one that is complete on the screen.

    When you start IE with the NETBIOS name of the site, then it is loading fast. We prefere to use the FQDN site name, because of the users outsite the office.

    What is the difference for IE between the FQDN and the Netbios name ? In both ways, you get the same site from the same server, only the name difference.

    What must i do to make the loading of the FQDN site as fast as the NETBIOS site?


    Jan Vereijken Wagemaker Adviesgroep B.V.

    mercoledì 15 febbraio 2012 07:29

Risposte

  • Hi,

    check to see if the Intranet Zone sites are repopulated when you reboot. There may be GPO settings for your machine/domain. What about sites in your Restricted Sites list? Is you av installed per/machine or centrally? Disable it and Windows Firewall on your test machine and retest.

    Open mscofig (Start>run>msconfig>Startup) and disable any non-MS startup services (google toolbar updater, Apple software updates, Adobe updates or any av services) and reboot. Or boot in Safe Mode which does not use the non-ms items in the Windows startup services list.

    Download the Fiddler tool (networking tool) from http://www.fiddlertool.com and examine your network traffic when Ie is started.

    Download the low-level system tools for windows from http://technet.microsoft.com/en-us/sysinternals/default.aspx

    use procmon.exe to monitor changes to registry keys (filter on the IE Security Zone keys)

    HTH.


    Rob^_^

    giovedì 16 febbraio 2012 20:26
  • Hi Rob,

    The GPO was the last problem I had. After removing the pilot user out of that Domain Group, the problem was solved.

    So at the end the only thing I had to do is to remove the Intranet Zone security.

    Thanks very much,
    Jan


    Jan Vereijken Wagemaker Adviesgroep B.V.


    • Modificato Jan Vereijken lunedì 27 febbraio 2012 15:50
    • Contrassegnato come risposta Jan Vereijken lunedì 27 febbraio 2012 15:50
    lunedì 27 febbraio 2012 15:40
  • I think we found now the final solution. In the DNS server we had made a DNS record as CNAME and that should be a A-record. We had the following settings:

    Portal site1 -> portal.firm.nl  (FQDN), this was a cname record to flower.adname.local
    Portal site2 --> portal (netbios)
    SharePoint server -> flower.adname.local 

    After making portal.firm.nl as an A record in the DNS the problem was solved. The FQDN site is now loading as fast as the Netbios name.

    We found the sollution when we turned off the automatic logon in IE. Normaly you see the logon screen with the name of the site. In this case it should be portal.firm.nl, but it was flower.adname.local. After changing the DNS the logon screen was portal.firm.nl as it should be and the site was loading fast.


    Jan Vereijken Wagemaker Adviesgroep B.V.

    • Contrassegnato come risposta Jan Vereijken lunedì 12 marzo 2012 11:49
    lunedì 12 marzo 2012 11:49

Tutte le risposte

  • Hi,

    It is not my area, but my guess is that you are not using intranet zone autodiscovery.... Remove any intranet sites you have listed in your IE's Intranet security zone.

    You may be using Spybots immunization feature or another outdated Restricted Sites list with 1000's of entries in IE's Restricted Sites Zone. Ie has to negotiate this list Every TIME it navigates... remove/uninstall them you don't need them on Window 7. Your AV product will be using its own site validation services or IE will over-ride them with its Smart Screen Filter....Firefox uses googles site validation services. (I think... since the GTB comes bundled with FX)

    This is true for any comparison between MSIE and other browsers.... IE uses a different security model to the rest....any differences between the browsers (apart from rendering differences) can be traced back to IE's different security model...

    Physics of Security....

    More Security requires more work which takes more time. There is always a trade-off between security and accessibility and the perceived user experience.


    Rob^_^


    mercoledì 15 febbraio 2012 09:02
  • Hi,

    .... Remove any intranet sites you have listed in your IE's Intranet security zone........


    Rob^_^

    Removing the intranet zone was the solution for the first time I started IE again. Both site where quickly on the screen. But when I close IE and restart it again, again the FQDN site was realy slow.
    The second option I changed whas the "User Authentication" under "Security Settings", it was "Automatic logon only in Intranet zone" and I changed it to "Automatic logon with current user name and password". That seems to work, and it still works after serveral times restarting IE. But again after a while the FQDN site is loading slow.
    Also the other options like Spybots are not installed so that can be no problem. Also the AV is virusscanning only. At this moment the Smart Screen Filter is truned off, so that also can not be the problem.


    giovedì 16 febbraio 2012 10:07
  • Hi,

    check to see if the Intranet Zone sites are repopulated when you reboot. There may be GPO settings for your machine/domain. What about sites in your Restricted Sites list? Is you av installed per/machine or centrally? Disable it and Windows Firewall on your test machine and retest.

    Open mscofig (Start>run>msconfig>Startup) and disable any non-MS startup services (google toolbar updater, Apple software updates, Adobe updates or any av services) and reboot. Or boot in Safe Mode which does not use the non-ms items in the Windows startup services list.

    Download the Fiddler tool (networking tool) from http://www.fiddlertool.com and examine your network traffic when Ie is started.

    Download the low-level system tools for windows from http://technet.microsoft.com/en-us/sysinternals/default.aspx

    use procmon.exe to monitor changes to registry keys (filter on the IE Security Zone keys)

    HTH.


    Rob^_^

    giovedì 16 febbraio 2012 20:26
  • Hi Rob,

    The GPO was the last problem I had. After removing the pilot user out of that Domain Group, the problem was solved.

    So at the end the only thing I had to do is to remove the Intranet Zone security.

    Thanks very much,
    Jan


    Jan Vereijken Wagemaker Adviesgroep B.V.


    • Modificato Jan Vereijken lunedì 27 febbraio 2012 15:50
    • Contrassegnato come risposta Jan Vereijken lunedì 27 febbraio 2012 15:50
    lunedì 27 febbraio 2012 15:40
  • Hi Jan,

    thanks for the feedback.... I am not a MSFT, just a troll... it is always positive when I can offer the correct answer.

    YW. Regards.


    Rob^_^

    martedì 28 febbraio 2012 03:28
  • Now I implemented the solution for all users. I made the GPO in the RES-WorkspaceManager and all client start with the writhe settings (the same as in the pilot environment). But now a really strange thing happens. First of all the site is slow again. So I want to do some Fiddler tracking. Start Fiddler and then IE with as default de FQDN site. And what happens, the site is very fast. Close both and then start IE, the site is slow again. Close IE, start Fiddler and then IE and the site is Fast again.

    Is there somebody who can explain me why it is fast with Fiddler started, and what can I configure in IE so it is also fast.


    Jan Vereijken Wagemaker Adviesgroep B.V.

    lunedì 5 marzo 2012 10:09
  • why it is fast with Fiddler started, and what can I configure in IE so it is also fast.

    My guess would be that there is a timeout (perhaps multiple timeouts) happening under the covers.  You could try comparing both cases with NetMon (or WireShark).

    Good luck

    Robert Aldwinckle
    ---

    lunedì 5 marzo 2012 17:14
    Postatore
  • I think we found now the final solution. In the DNS server we had made a DNS record as CNAME and that should be a A-record. We had the following settings:

    Portal site1 -> portal.firm.nl  (FQDN), this was a cname record to flower.adname.local
    Portal site2 --> portal (netbios)
    SharePoint server -> flower.adname.local 

    After making portal.firm.nl as an A record in the DNS the problem was solved. The FQDN site is now loading as fast as the Netbios name.

    We found the sollution when we turned off the automatic logon in IE. Normaly you see the logon screen with the name of the site. In this case it should be portal.firm.nl, but it was flower.adname.local. After changing the DNS the logon screen was portal.firm.nl as it should be and the site was loading fast.


    Jan Vereijken Wagemaker Adviesgroep B.V.

    • Contrassegnato come risposta Jan Vereijken lunedì 12 marzo 2012 11:49
    lunedì 12 marzo 2012 11:49