none
IE9 forgets visit history very quickly

    Общие обсуждения

  • IE9 64bit, I set browse history to keep 20 days. But it forgets the history very quickly. I never counted, but I feet after 5 days or so I am no longer able to bring the URL from address bar history.

    Any clue?


    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    10 февраля 2012 г. 1:14

Все ответы

  • Hi,

    you can tell how many days history your browser is keeping very easily...

    Ctrl+shift+H to display the History panel, then select "View by date" from the dropdown at the top of the History pane.

    There are third-party programs that will "Wipe your tracks" when the computer is restarted or shut down.

    If this is a work computer, contact your Help Desk... they may be limiting how much history is being kept by IE.

    Regards.


    Rob^_^

    10 февраля 2012 г. 5:30
  • Hi Rob,

    I opened the history as you suggested. I saw some entries from last week. When I tried to type in the same address in history from address bar, I should expect auto-complete for all known addresses in history. But address bar does not prompt the auto-complete at all.

    Hardy


    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    10 февраля 2012 г. 13:04
  • Hi,

    Its your autocomplete settings for the Address bar. Internt Options>Content tab>Autocomplete section, 'Settings' button, Address Bar>check Browser History.

    Regards.


    Rob^_^

    10 февраля 2012 г. 19:26
  • Yes, it is checked.

    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    10 февраля 2012 г. 22:18
  • then its your google account settings (use online history) or your Google toolbar settings.

    disable them both or add

    analytics.google.com

    to your IE Restricted Sites list...

    ha ha.... easily defeated google.... you should read the updates to their privacy policy before switching on their Optional Privacy settings.

    I'm waiting for google to offer me paid work to fix THEIR problems with compeditors browsers.

    You pay peanuts you only get monkeys and elephants to do the work.

    thanks for the link to your google code project.... I will add it to my list of blocked software.


    Rob^_^


    10 февраля 2012 г. 23:35
  • Well, I don't even have google toolbar installed.

    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    10 февраля 2012 г. 23:37
  • does adding analytics to your restricted sites list work?

    I suppose you have Chrome installed.... what version of IE are you using... they drop the chrome frame payload when you install Chrome. Its also offered with some other third party products.

    chrome frame addon in IE8 or lower (its ignored in IE9 and higher, for good reason)... the missing history items will be from pages you visited using the chrome=1 x-ua meta or header. You are probably seeing as enabled in your IE9 Addons manager.... not so. Its ignored and never even loaded.

    (there are 1000's of support tickets at answers.microsoft.com for "Back and forward buttons do not work properly")

    or

    If a page is using the x-ua EmulateIE7 meta and has the Google + button on it. Add plus.google.com to your restricted sites list....

    soon we will only have to ask users to add *.google.com to the restricted sites list.

    the issue of supporting google mistakes will be solved soon.

    Please refer any further questions to the Google support forums.

    I would suggest that you develop with android i/o windows if you want to target their platforms.

    Regards.


    Rob^_^

    11 февраля 2012 г. 0:07
  • I have IE9. This is a clean installed machine, no Chrome, no Firefox.

    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    11 февраля 2012 г. 0:46
  • Hi,

    1. do you have "Display all sites in compatibility view" unchecked, "Include updated web site lists from Microsoft" checked.... have you run a Windows Update since the clean install. Is Sp1 installed?

    2. How was IE9 delivered? through windows update or a manual install or pre-installed. have you been using InPrivate browsing... (no history is recorded) are your missing urls from when you were using InPrivate browsing.

    can you post back with the urls that you are missing from your history... do any of those pages use the google + button? or have the google analytics site api's

    or

    Provide a reproducable test plan.

    or

    turn on the Network capturing panel in IE Developer Tools and log your requests and responses for redirects and 404 errors. Probably the fiddler Tool (http://www.fiddlertool.com) is better for bulk monitoring and filtering of traffic that you are interested in.

    Unless your windows disk is from MSDN it will be an OEM bundle.... probably won't be as clean as you think it is. "Beware of silly smiles"

    3. Are you on a home or company network? What proxy software is installed.

    4. Who is your ISP? AOL or Comcast?

    they may be silly questions... but I have my reasons.

    Perhaps the simplist way to proceed is for you to provide a reproducable test plan


    Rob^_^

    11 февраля 2012 г. 3:36
  • 1. it is unchecked. All patches installed, including Win7 SP1.
    2. Installed from MS as web installer (I believe). I never use InPrivate browse, don't use Google+ at all. Google analytics API resides on web client, does it have anything to do with browser?
    3. Home, no proxy. Computer is behind router.
    4. Neither is my ISP. I don't live in States.

    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    11 февраля 2012 г. 13:27
  • Hi,

    Do you have one link to a site that does not appear in your history list? I can't assist you without something to work with.

    Does that page use hash navigation? the address will have a # in it....

    Usually hash navigation is used only on mobile sites, but more and more sites are using cross platform coding.... there is a trick to update the window.location with the new hash value.

    If it is your own site (in development), see the jQuery.mobile examples.

    Regards.


    Rob^_^

    12 февраля 2012 г. 3:46
  • One example is maps.google.ca, it does not show up in address auto-complete after a couple of days but still in my history.

    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    12 февраля 2012 г. 13:29
  • thanks.

    funny its a google site.

    well I leave you alone. try code.google.com for support.


    Rob^_^

    12 февраля 2012 г. 17:54
  • Well, this is just one example. There are a lot more non-google sites as well.

    OK, I will be waiting for some other information.


    Welcome to help me with my open source project at http://code.google.com/p/batch-image-watermark-processor/

    12 февраля 2012 г. 22:55
  • I don't know why MS cannot figure out that there is a bug in IE. Maybe it has to do with IE or maybe with IE's interaction between IE and an add-on or security program, but there are countless threads about this all over the web. My problem is:

    Windows 7

    IE9 (since it was beta)

    Number of days to keep pages = 20 (was larger but changed on reset to default settings)

    250MB (was 1024 MB but changed on reset to default settings)

    Delete browser history on exit IS NOT CHECKED

    InPrivate Browsing IS NOT turned on.

    Internet Explorer 9 settings were reset to default , yet IE9 (still gets to a point and stops recording 'History'. It is not because of CHrome, FireFox, or other browsers. The website that I visit all of the time show up one day, and then not the next day. It acts like their is a memory leak in the browser. After a certain number of pages is visited (not a specific number, just a week or two's worth) the browser stops recording all internet history.  The last time this happened, I wiped the entire browser history clean, deleted all temporary internet files, and it started recording again. This time it also worked. When I had the browser history cache set at 1024 MB, the cache should have never filled up in a week unless IE is not periodically emptying the temporary files. The funny thing is that when I download photos off my memory card, they all show up in the browser history. How come the websites don't show.

    Microsoft needs to get cracking on this problem. They don't even seem to acknowledge that there is a problem. They re-hash the same old tired suggestions. " Set your browser history to a longer time period. Uncheck delete browsing history on exit, Turn off InPrivate browsing. Empty your browser's cahce and/or increase the size of your browser's cache" I haven't seen this help anyone so far, because 95% of people use the default settings, which means that these settings are already "fixed". This should be an easy fix.

    I never has this problem with other versions of IE. Maybe it is an interaction between IE and WIndows 7. Chrome doesn't have the same problem. I am going to start using it if there is no solution for this IE problem.


    • Изменено crashq 13 февраля 2012 г. 6:24
    13 февраля 2012 г. 6:22
  •  

    Hi,

    How about testing the issue in on add-ons mode?

    Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons)

    Since I don't have the history about last week, I cannot repro the issue. I will go on monitoring this case.


    Niki Han

    TechNet Community Support

    15 февраля 2012 г. 8:51
    Модератор
  • Interesting, as I've come to the same conclusion ... been wrestling this problem of periodic IE9 amnesia for website history for about 4 months as it began about 6 months after the purchase of the laptop.  I keep checking for solutions online which is how I found this forum (from the many who are having this increasing headache).  My situation is a duplicate of yours right down to the effort to clear the browser history to prod it into tracking again.  My settings are default save for the number of days set at 21 ... history no longer makes it to that point when all previous history "disappears" at 2 weeks and it stops recording.  I find this quite annoying although I can live without the history.  What I find puzzling is the time IE9 keeps history seems to be steadily shortening with each incident ... seriously Microsoft, you have a problem with IE9 that needs some study AND a fix.
    15 марта 2012 г. 19:39
  • Add me to the list of the outraged. This problem's been going on since I downloaded IE 9, in 2011. Microsoft's been good for nothing but giving useless advice as if to kindergartners: "Check your settings." My settings are fine. After a week or two, Internet Explorer 9 just STOP recording history. Most of the time, I don't even realize this has begun happening, but it's infuriating when suddenly I need to know of a page I visited a couple of days ago.

    I'm sick enough of this, now, I think, to just dump IE 9, and move to another browser. And I thought the omission of the title bar was annoying...

    12 июня 2012 г. 3:38
  • After a week or two, Internet Explorer 9 just STOP recording history.

    Change the number of days that you want History to start purging after.   Note this is not necessarily the number of days that you would like to have, just the number of days to prevent  Low\History.IE5\index.dat  from getting too big.

    C.f.

    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/ie-9-will-not-record-browsing-history/940e6020-20d4-49ab-b2a7-da18abd44f53#last

    FWIW  I forgot to note that in IE10 this symptom may be changed because the implementation is completely different--no more index.dat, in it we get  container.dat   which is 0 bytes.   I have no idea how we will be able to diagnose any problems with it.



    FYI


    Robert Aldwinckle
    ---

    12 июня 2012 г. 17:40
    Отвечающий