none
IE8 - configurazione automatica proxy forzata

    Domanda

  • Uso IE8 con XP pro  su un porttaile collegato in dhcp alla LAN. Ho la necessità di configurare manualmente i parametri di collegamento al proxy (per poter specificare delle eccezioni). Una volta fatte le modifiche tutto funziona fino al prossimo riavvio (anzi basta far la disconnessione dell'utente e rientrare) poichè rientrando ie8 perde le configurazioni manuali e torna alle configurazioni automatiche. la macchina non è in dominio e non ho configurazioni particolario... ho fatto questa operazione decine di volte su macchine diverse e non ho mai riscontrato questo problema. Cosa può essere? Grazie. Michele

    • Spostato Vincenzo Di RussoMVP, Moderator lunedì 22 agosto 2011 12:07 Spostato nel Forum per Windows XP, più appropriato (network/proxy issue) (Da:Microsoft Internet Explorer Forum)
    lunedì 22 agosto 2011 10:35

Tutte le risposte

  • Uso IE8 con XP pro  su un porttaile collegato in dhcp alla LAN. Ho la necessità di configurare manualmente i parametri di collegamento al proxy (per poter specificare delle eccezioni). Una volta fatte le modifiche tutto funziona fino al prossimo riavvio (anzi basta far la disconnessione dell'utente e rientrare) poichè rientrando ie8 perde le configurazioni manuali e torna alle configurazioni automatiche. la macchina non è in dominio e non ho configurazioni particolario... ho fatto questa operazione decine di volte su macchine diverse e non ho mai riscontrato questo problema. Cosa può essere? Grazie. Michele

    Credo sarebbe utile avere ulteriori informazioni, vedi, il problema (si fa per dire) da te "lamentato" potrebbe essere dovuto a diversi fattori, incluse delle policies impostate localmente, l'implementazione di WPAD sulla rete alla quale ti connetti ed altro ancora; se potessi aggiungere ulteriori dettagli ed informazioni e far capire meglio quele sia la reale problematica che vuoi risolvere, forse sarebbe possibile aiutarti, in caso contrario, considerando che la sfera di cristallo è a fare il tagliando (ha fatto un mucchio di kilometri :D) la vedo dura riuscire ad aiutarti

     

    lunedì 22 agosto 2011 12:39
  • Credo sarebbe utile avere ulteriori informazioni, vedi, il problema (si fa per dire) da te "lamentato" potrebbe essere dovuto a diversi fattori, incluse delle policies impostate localmente, l'implementazione di WPAD sulla rete alla quale ti connetti ed altro ancora; se potessi aggiungere ulteriori dettagli ed informazioni e far capire meglio quele sia la reale problematica che vuoi risolvere, forse sarebbe possibile aiutarti, in caso contrario, considerando che la sfera di cristallo è a fare il tagliando (ha fatto un mucchio di kilometri :D) la vedo dura riuscire ad aiutarti


    Ciao Michele,

    Seguendo il post sopra, mi permetto di segnalarti intanto questo post di Vincenzo Di Russo (MVP): Come porre una domanda, spero che ti possa ispirare per seguire gli ottimi consigli di ObiWan.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    mercoledì 24 agosto 2011 12:14
    Proprietario
  • Ciao ObiWan,

    scusami per non essere stato sufficientemente chiaro nella domanda. Ieri ti ho scritto delle precisazioni, ma non vedo il post nell’elenco delle risposte… non so cosa ho sbagliato..

    Comunque la situazione è questa:

    Problema: la configurazione manuale settata nelle Impostazioni LAN di Explorer viene persa ad ogni riavvio della macchina (cioè torna al configurazione di default con riconoscimento automatico delle impostazioni)

     

    Dati che spero possano essere utili:

    1)      Portatile con SO xp pro sp3 aggiornato, non in dominio, configurazione di rete DHCP, sw antivirus Avast 6.

    2)      Normalmente è collegato ad una LAN  (10.1.10.0/24) con Firewall/proxy IPCOP, con un’altra decina di macchine (delle quali alcune in dhcp, altre con ip statico), in nessun’altra di queste ho notato il “problema”, quindi escluderei problemi legati al dhcp/wpad

    3)      A livello di Explorer tutte le macchine hanno un configurazione manuale delle “Impostazioni LAN” per poter specificare delle eccezioni nei confronti del proxy  

    4)      Gli utenti che  usano questo pc hanno account “limitati”

    5)      Il problema non si presentava fino a qualche settimana fa. La persona che lo usa viaggia abbastanza collegandosi alle varie reti LAN della nostra associazione.. non ha mai riscontrato problemi di navigazione (nei vari firewall/proxy sono impostate delle eccezioni a livello di MAC address per “far passare” questo pc)

     

    Se può essere utile oggi ho notato questo:

    a) se imposto la macchina in oggetto in DHCP e a livello di Explorer lascio abilitata la sola configurazione automatica, allora la macchina riesce a navigare su siti che richiedano la risoluzione dei nomi (es www.ansa.it) mentre NON accede ai siti specificati tramite ip (quelli che normalmente metto nelle eccezioni).  E questo mi pare corretto.

    Viceversa

    b) se imposto la macchina in oggetto con IP statico e a livello di Explorer lascio abilitata la sola configurazione automatica, allora la macchina NON riesce a navigare su siti che richiedano la risoluzione dei nomi (es www.ansa.it) mentre accede regolarmente ai siti specificati tramite ip (quelli che normalmente metto nelle eccezioni).  E questo invece non me lo spiego...

     

    In ogni caso, se imposto qualsiasi opzione a livello di Impostazione LAN di Explorer, questa al successivo riavvio viene persa.

     

    Ultima cosa anche per ringraziare Anca Popa dei suggerimenti, avevo già provato a cercare in internet problemi simili… non ho trovato quasi nulla se non questo articolo (al quale aveva risposto anche Vincenzo Di Russo), che però non risolve la mia situazione

    http://it.narkive.com/2008/6/17/4396208-impostazioni-rete-locale-non-salva-le-modifiche.html

     

    Grazie per il prezioso tempo che hai già dedicato a questo problema.

    Michele

    giovedì 25 agosto 2011 11:22
  • Ciao ObiWan,


    Ciao, scusami per il "cut" così esteso ma... considerando quanto scrivi, mi viene il sospetto che vi sia qualcosa di mal-configurato su quella macchina o che "qualcosa" stia interferendo con il corretto funzionamento del sistema; ora, visto quanto hai riportato, suggerirei di lanciare questi comandi (da console - ossia start->esegui->cmd)

    ipconfig /all >c:\settings.txt
    route print >>c:\settings.txt
    proxycfg >>c:\settings.txt
    notepad settings.txt
    
    


    sia sul computer che manifesta problemi, sia su un computer che funziona correttamente, postando poi qui il contenuto dei due files (quello che vedrai in notepad) ed ovviamente marcando ciascun file in modo da permetterci di capire "da dove vengano" i dati :)

    Oltre a quanto sopra, che potrebbe permettere di capire cosa stia causando tale strano comportamento, ti consiglio di accedere ad un altro computer (dotato di "masterizzatore") e scaricare questo tool, quindi di avviare il programma scaricato procedendo con la creazione del "CD"; a questo punto, usa il CD appena creato per avviare la macchina "problematica" (in alcuni casi è necessario premere un tasto all'accensione per avviare il "boot" da CD) procedendo poi con le operazioni di scansione/pulizia; questo al fine di accertarci che il computer in questione non abbia qualche "clandestino" a bordo; ovviamente, sarà opportuno postare qui anche i risultati di tale scansione

    P.S.: Grazie Anca :D !

     

    giovedì 25 agosto 2011 12:27
  • [OT] Di nulla, era solo che avevo pensato che potrebbe tornare utile nel fornirci ulteriori informazioni per proseguire nelle analisi. :-) 

    Grazie a te del tempo che dedichi costantemente per condividere consigli utilissimi con la community, al fine di risolvere altrettante problematiche!


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 25 agosto 2011 14:24
    Proprietario
  • Ciao ObiWan, ecco i due test eseguiti

    COMPUTER FUNZIONANTE

    --------------------------------------------------------------

    Configurazione IP di Windows

            Nome host . . . . . . . . . . . . . . : PO-165

            Suffisso DNS primario  . . . . . . .  :

            Tipo nodo . . . . . . . . . . . .  : Misto

            Routing IP abilitato. . . . . . . . . : No

            Proxy WINS abilitato . . . . . . . .  : No

            Elenco di ricerca suffissi DNS. . . . : cmv

    Scheda Ethernet Connessione alla rete locale (LAN):

            Suffisso DNS specifico per connessione: cmv

            Descrizione . . . . . . . . . . . . . : Atheros AR8151 PCI-E Gigabit Ethernet Controller

            Indirizzo fisico. . . . . . . . . . . : 00-26-2D-A8-B7-3C

            DHCP abilitato. . . . . . . . . . . . : Sì

            Configurazione automatica abilitata   : Sì

            Indirizzo IP. . . . . . . . . . . . . : 10.1.10.209

            Subnet mask . . . . . . . . . . . . . : 255.255.255.0

            Gateway predefinito . . . . . . . . . : 10.1.10.254

            Server DHCP . . . . . . . . . . . . . : 10.1.10.254

            Server DNS . . . . . . . . . . . . .  : 10.1.10.254

            Lease ottenuto. . . . . . . . . . . . : venerdì 26 agosto 2011 11.15.56

            Scadenza lease . . . . . . . . . . .  : venerdì 26 agosto 2011 12.15.56

    Scheda Ethernet Connessione rete senza fili:

            Stato supporto . . . . . . . . . . . : Supporto disconnesso

            Descrizione . . . . . . . . . . . . . : Scheda di rete Broadcom 802.11n

            Indirizzo fisico. . . . . . . . . . . : 90-4C-E5-7C-57-25

    ===========================================================================
    Elenco interfacce
    0x1 ........................... MS TCP Loopback interface
    0x2 ...00 26 2d a8 b7 3c ...... Atheros AR8151 PCI-E Gigabit Ethernet Controller - Miniport dell'Utilità di pianificazione pacchetti
    0x3 ...90 4c e5 7c 57 25 ...... Scheda di rete Broadcom 802.11n - Miniport dell'Utilità di pianificazione pacchetti
    ===========================================================================
    ===========================================================================


    Route attive:
    Indirizzo rete             Mask             Gateway       Interfac.  Metric
              0.0.0.0          0.0.0.0      10.1.10.254     10.1.10.209   10
            10.1.10.0    255.255.255.0      10.1.10.209     10.1.10.209   10
          10.1.10.209  255.255.255.255        127.0.0.1       127.0.0.1   10
       10.255.255.255  255.255.255.255      10.1.10.209     10.1.10.209   10
            127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1   1
            224.0.0.0        240.0.0.0      10.1.10.209     10.1.10.209   10
      255.255.255.255  255.255.255.255      10.1.10.209     10.1.10.209   1
      255.255.255.255  255.255.255.255      10.1.10.209               3   1
    Gateway predefinito:       10.1.10.254
    ===========================================================================


    Route permanenti:
      Nessuno
    Utilit… di configurazione proxy predefinito WinHTTP Microsoft (R)
    Copyright (c) Microsoft Corporation. Tutti i diritti riservati.

    Impostazioni proxy WinHTTP correnti in:
      HKEY_LOCAL_MACHINE\
        SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\
          WinHttpSettings :

         Accesso diretto (nessun server proxy).

     

    COMPUTER CON "PROBLEMA"

    --------------------------------------------------------------

    Configurazione IP di Windows       
    Nome host . . . . . . . . . . . . . . : PO-098       
    Suffisso DNS primario  . . . . . . .  :        
    Tipo nodo . . . . . . . . .  : Sconosciuto       
    Routing IP abilitato. . . . . . . . . : No       
    Proxy WINS abilitato . . . . . . . .  : No       
    Elenco di ricerca suffissi DNS. . . . : cmv
    Scheda Ethernet Connessione alla rete locale (LAN):       
    Suffisso DNS specifico per connessione: cmv       
    Descrizione . . . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet       
    Indirizzo fisico. . . . . . . . . . . : 00-A0-D1-AB-13-BD       
    DHCP abilitato. . . . . . . . . . . . : Sì       
    Configurazione automatica abilitata   : Sì       
    Indirizzo IP. . . . . . . . . . . . . : 10.1.10.211       
    Subnet mask . . . . . . . . . . . . . : 255.255.255.0       
    Gateway predefinito . . . . . . . . . : 10.1.10.254       
    Server DHCP . . . . . . . . . . . . . : 10.1.10.254       
    Server DNS . . . . . . . . . . . . .  : 10.1.10.254       
    Lease ottenuto. . . . . . . . . . . . : venerdì 26 agosto 2011 11.48.30       
    Scadenza lease . . . . . . . . . . .  : venerdì 26 agosto 2011 12.48.30
    Scheda Ethernet Connessione rete senza fili:       
    Stato supporto . . . . . . . . . . . : Supporto disconnesso       
    Descrizione . . . . . . . . . . . . . : Intel(R) Wireless WiFi Link 5300       
    Indirizzo fisico. . . . . . . . . . . : 00-16-EA-44-78-2C
    ===========================================================================
    Elenco interfacce
    0x1 ........................... MS TCP Loopback interface
    0x2 ...00 a0 d1 ab 13 bd ...... Broadcom NetXtreme Gigabit Ethernet - Miniport dell'Utilità di pianificazione pacchetti
    0x3 ...00 16 ea 44 78 2c ...... Intel(R) Wireless WiFi Link 5300 - Miniport dell'Utilità di pianificazione pacchetti
    ===========================================================================
    ===========================================================================

    Route attive:
    Indirizzo rete             Mask             Gateway       Interfac.  Metric
              0.0.0.0          0.0.0.0      10.1.10.254     10.1.10.211   20
            10.1.10.0    255.255.255.0      10.1.10.211     10.1.10.211   20
          10.1.10.211  255.255.255.255        127.0.0.1       127.0.0.1   20
       10.255.255.255  255.255.255.255      10.1.10.211     10.1.10.211   20
            127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1   1
            224.0.0.0        240.0.0.0      10.1.10.211     10.1.10.211   20
      255.255.255.255  255.255.255.255      10.1.10.211     10.1.10.211   1
      255.255.255.255  255.255.255.255      10.1.10.211               3   1
    Gateway predefinito:       10.1.10.254
    ===========================================================================


    Route permanenti:
      Nessuno
    Utilit… di configurazione proxy predefinito WinHTTP Microsoft (R)
    Copyright (c) Microsoft Corporation. Tutti i diritti riservati.

    Impostazioni proxy WinHTTP correnti in:
      HKEY_LOCAL_MACHINE\
        SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Connections\
          WinHttpSettings :

         Accesso diretto (nessun server proxy).

    -------------------------------------------------------------------

    per quanto riguarda la scansione con Sweeper:

    ho scaricato il cd e fatto la scansione delle cartelle principali (document and settings, programmi , windows)  ma non mi ha rilevato nulla...

    Grazie, ciao

    Michele

    venerdì 26 agosto 2011 11:10