none
Controllo del controller di dominio: rilevato ambiente non conforme al criterio di gestione licenze

    Domanda

  • Buonasera,

    Ho la seguente rete di windows :

    1 DC WIndows 2003

    1 Server HP SBS 2011 Server Essential

    Il secondo server (HP) è stato messo solo come appoggio per utilizzo come file server e niente piu'

    per cui non è stato installato il dominio, nella configurazione di lavoro non ha nessun senso, avere un secondo dominio, quindi a me servirebbe proprio e solo come file server peer. Solo per due client, che utilizzano W7Pro. Capisco che è una soluzione poco ortodossa, ma perfettamente funzionante per lo scopo previsto.

    Ora da qualche giorno il file server a scadenze di 6 giorni si spegne segnalando quanto segue :

    Controllo del controller di dominio: rilevato ambiente non conforme al criterio di gestione licenze.

    Il server deve essere un controller di dominio. Impostare il server come controller di dominio.

    Il server è stato attivato tramite licenza, immediatamente via internet, i client sono tutti correttamente registrati. Solo che vedo che ora nel pannello riporta la seguente frase" 20 giorni rimasti per l'attivazione della licenza", ma come è possibile se è stato attivato via internet, correttamente senza segnalare nulla di strano ?

    Non avendo fatto il dcpromo e quindi lavorando come peer non riconosce il suo stato di licenza ?

    Non capisco!
    Eventualmente si puo' evitare di lavorare come DC o si è obbligati ?

    Se qualcuno riesce a spiegarmi come devo procedere.

    Grazie

    Carlo

    martedì 20 marzo 2012 16:23

Risposte

  • l'eula (licenza) dell'sbs impone che il server con sbs sia il primo dc di un nuovo dominio, deve essere obbligatoriamente un domain controller e non può essere configurato come domain controller aggiuntivo di un dominio esistente.

    prima di acquistare dei sistemi operativi è opportuno informarsi sui limiti della licenza. per fare quello che vuoi tu hai bisogno di acquistare una licenza di windows server 2008 standard.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    martedì 20 marzo 2012 16:45

Tutte le risposte

  • l'eula (licenza) dell'sbs impone che il server con sbs sia il primo dc di un nuovo dominio, deve essere obbligatoriamente un domain controller e non può essere configurato come domain controller aggiuntivo di un dominio esistente.

    prima di acquistare dei sistemi operativi è opportuno informarsi sui limiti della licenza. per fare quello che vuoi tu hai bisogno di acquistare una licenza di windows server 2008 standard.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    martedì 20 marzo 2012 16:45
  • Ok se pero' creo un nuovo dominio su questo server e autentico i due utenti che devono poter condividere una unità disco (quindi mapparla come risorsa locale), ho problemi ?

    In pratica avrei :

    Server 1 (dominio win2003) Utenti : A e B

    Server2 (dominio sbs 2008) Utenti : A e B (stesse userid e password del server1), mappo sul loro pc in locale un disco condiviso (everyone) del server sbs 2008.

    Ho problemi con questa configurazione ?

    Se il problema è solo il fatto che non esiste il Dc su SBS 2008,lo creo ovviamente diverso da quello di Windows 2003 e vado a creare gli utenti che necessito con le stesse UserId e Password che ho nel dominio di windows 2003.

    Penso che così dovrei poter accedere al server SBS2008 e mappare un'unità condivisa di questo server e utilizzarla sul Pc locale dei due client che sono pero' parte dell'altro dominio.

    Spero di aver spiegato il mio problema e che mi possiate dire se fattibile o meno.

    Grazie

    Carlo


    • Modificato kant860 venerdì 23 marzo 2012 16:14
    venerdì 23 marzo 2012 14:56
  • Ok se pero' creo un nuovo dominio su questo server e autentico i due utenti che devono poter condividere una unità disco (quindi mapparla come risorsa locale), ho problemi ?

    In pratica avrei :

    Server 1 (dominio win2003) Utenti : A e B

    Server2 (dominio sbs 2008) Utenti : A e B (stesse userid e password del server1), mappo sul loro pc in locale un disco condiviso (everyone) del server sbs 2008.

    Ho problemi con questa configurazione ?

    ovviamente gi utenti A e B del primo dominio hanno un SID diverso dagli utenti Ae B del secondo dominio (pur avendo stessa username e password) quindi non possono condividere le risorse.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    venerdì 23 marzo 2012 19:24
  • Alla fine ho creato un unico dominio di windows 2008 con sbs 2011 e tutti fanno parte di questo dominio, così ho adeguato la rete al nuovo SO.

    Tutto funziona bene, ma ho nuovamente lo stesso problema, la licenza di sbs 2011 è stata attivata,come la volta precedente , ma dopo qualche giorno andando a vedere nelle proprietà del server mi avverte che la licenza dovrà essere attivata entro x giorni. Non vorrei dopo aver fatto tutto il lavoro, incappare ancora in qualche spegnimento del server, adesso non dovrebbero esserci piu' ragioni teoriche perchè cio' si verifichi. Non riesco a capire come sia possibile anche perchè durante l'attivazione non ha segnalato nessun tipo di problema e dopo il processo mi ha riportato che la licenza era stata attivata regolarmente !

    Un grazie di cuore a chi mi puo' aiutare.

    Carlo


    • Modificato kant860 mercoledì 28 marzo 2012 07:38
    mercoledì 28 marzo 2012 07:35
  • Ciao.

    Scusami, l'errore è lo stesso della volta precedente (ovvero "il server deve essere domain controller") ?

    Prova a lanciare netdom query fsmo

    Se tutti gli incarichi sono (correttamente) sul nuovo server, a breve dovresti non ricevere più l'errore di cui parliamo.

    Se ci sono altri errori "di contorno", cortesemente segnalaceli.


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    VMware Certified Professional on vSphere 4
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com

    mercoledì 28 marzo 2012 07:56
  • Eseguendo questo comando mi riporta :

    Master schema                         SERVER.xxxxx.local

    Master denominazione domini    SERVER.xxxxx.local

    PDC                                         SERVER.xxxxx.local

    Gestione Pool RID                     SERVER.xxxxx.local

    Master Infrastrutture                 SERVER.xxxxx.local

    Nelle proprietà del server mi segnala, riguardo alla licenza :

    "7 giorni rimasti per l'attivazione di windows attivare adesso ?"

    Il server non riporta nel registro l'errore dell'altra volta. Non dà piu' nessun tipo di errore.

    E' corretto?

    Grazie

    Carlo


    • Modificato kant860 lunedì 2 aprile 2012 08:21
    lunedì 2 aprile 2012 08:20
  • è corretto! ora devi solo attivarlo.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    lunedì 2 aprile 2012 08:55
  • Si, l'ho già attivato la prima volta dopo aver installato il SO e andava bene, poi dopo un giorno riporta sempre sto messaggio nelle proprietà come se non lo avessi mai attivato, ma non è così.

    Se cerco di attivarlo mi richiede in alternativadi acquistare un nuovo codice di attivazione.

    Come mai la prima volta è andato correttamente l'attivazione e dopo qualche giorno richiede nuovamente l'attivazione ?

    Cosa dovrei fare ?
    Grazie

    Carlo

    lunedì 2 aprile 2012 12:21
  • viene registrato qualcosa nel registro eventi relativamente alla mancata attivazione ?

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org

    lunedì 2 aprile 2012 15:59
  • Ho controllato il registro eventi ma non c'e' nessuna voce relativa alla mancata attivazione.

    Il server in questi giorni non era collegato ad internet, lo è stato solo per la prima attivazione e aggiornamenti successivi. Solitamente non deve essere collegato se non per manutenzioni e aggiornamenti. Mi chiedo se è possibile effettuare l'attivazione telefonica come si faceva con gli altri prodotti OS.

    Ora l'ho lasciato collegato ad internet per vedere se con la connessione attiva riesce a sbloccare e riportare in modo corretto lo stato di attivazione.

    Spero di risolvere non mi è mai capitato di avere questi problemi.

    Un grazie a tutti e se ci sono altre idee ben vengano,

    Carlo

    martedì 3 aprile 2012 08:21
  • Solo una domanda : a server collegato ad Internet, se tu lanci manualmente l'attivazione, cosa succede ?

    Se ti viene segnalato che devi attivare, nelle proprietà del computer dovresti avere X giorni residui.

    Ti allego un articolo per capirci sui passaggi.

    http://www.elmajdal.net/win2k8/how_to_activate_windows_server_2008_online.aspx


    Fabrizio Volpe
    MVP Directory Services
    MCITP Windows 2008
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com

    martedì 3 aprile 2012 08:47
  • Si ho controllato e come dicevo questa situazione la prima volta è andata così nel senso che mi ha attivato windows correttamente, poi adesso mi ritrovo con il messaggio : 7 giorni per attivare windows, attivalo ora.

    Ho rifatto l'attivazione digitando il codice (product key) che accompagna il server (e un OEM).

     Mi segnala il seguente errore :

    0XC004E003

    Servizio gestione licenze : impossibile eseguire la valutazione della licenza.

    martedì 3 aprile 2012 09:03
  • Per questo codice d'errore il suggerimento che si da in genere è di "reinserire" la tua product Key.

    http://forevergeeks.com/change-product-key-on-windows-server-2008/


    Fabrizio Volpe
    MVP Directory Services
    MCITP Windows 2008
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com

    martedì 3 aprile 2012 09:08
  • Ho potuto riprovare solo ora ,

    purtroppo anche cancellando le chiavi seguendo esattamente la procedura proposta, non viene attivato, e sì che il codice è corretto.

    Ho provato sia cancellando e rispegnendo il server, che seguendo tutta la procedura senza spegnere, ma niente di positivo ...

    Vi ringrazio veramente perchè mi avete suggerito il possibile e guidato fin quì, l'unica ultima cosa che mi resta da fare è di riformattare nuovamente il tutto e sperare che non mi segnali piu' dopo qualche giorno il messaggio fatidico.

    Se non ci sono altre idee....

    Un grazie a tutti

    Carlo

    giovedì 5 aprile 2012 15:52