none
Issue with opening SharePoint library in Windows Explorer view

    질문

  • I am having trouble opening a document library in Windows Explorer view. The portal is MOSS 2007. I have installed Office 2007 and IE7 on my computer. The error that I get is
    "Documents in this folder are not available. The folder may have been moved or deleted, or network problems may be preventing a connection to the server."
    2009년 10월 13일 화요일 오전 11:52

답변

  • On the Client

    Ensure your WebApplication is in the Local Intranet security Zone

    When you use Internet Explorer to access the WebDAV site, Internet Explorer uses Windows HTTP Services (WinHTTP). WinHTTP sends user credentials only in response to requests that occur on a local intranet site during an authenticated logon process. However, WinHTTP does not check the security zone settings in Internet Explorer to determine whether a Web site is a local intranet site. Instead, WinHTTP depends on the proxy settings in Internet Explorer to determine whether a Web site is a local intranet site. If the Automatically detect settings option is not enabled, any auto-configuration script that is defined will not be processed. WinHTTP will not identify the WebDAV site as a local intranet site. Therefore, WinHTTP will send out a request without user credentials, and you will be prompted to type user credentials.



    On the WFEs

    Check if the WebServer > Role Service > WebDav Publishing is installed on the SharePoint WFEs . I have had this issue and the only way I found the resolution was with Fiddler, another farm to compare where I didn’t have the issue, and Google.

    Disabling the component is not enough, it must be removed completely from IIS using the following steps:

    1. Open Server Manager

    2. On the left side of the pane click on Roles

    3. Scroll down to the "Role Services" section, and click on "Remove Role Services"

    4. Under "web server" uncheck the box next to "WebDav Publishing"

    5. Choose Next, then choose Remove

    6. A reboot will be required



    Reference

    Sudeep Gopalakrishnan
    http://www.pubsub.com/Webdav-folders-–-no-full-functionality_Windows-MOSS-7tB9oLk7rqi,fVoMRAEGZf3E

    Sean McDonough SharePoint, WebDAV, and a Case of the 405 Status Codes
    http://sharepointinterface.com/2009/12/28/sharepoint-webdav-and-a-case-of-the-405-status-codes/

    Todd Klindt, “Installing Remote Blob Store (RBS) on SharePoint 2010
    http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=174

    Troubleshooting WebDav
    http://www.microsoft.com/downloads/details.aspx?FamilyId=C523AC7A-5724-48BE-B973-641E805588F4&displaylang=en

    KB Article for this with MOSS 2007 and explorer Reference
    http://support.microsoft.com/kb/2171959/en-us

    Originally Found on TechNet:
    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/99d923cd-50e2-4a32-a45d-5df4f8627f37?prof=required

    Thanks Ivan !

     

    http://tim-barsotti.blogspot.com/2010/07/windows-explorer-sharepoint-2007.html

    2010년 7월 8일 목요일 오후 4:29

모든 응답

  • This might be related to a WebDAV issue - I saw something similar a few years back.  This KB provided the update for our user:

    http://support.microsoft.com/kb/892211#appliesto

    The following software update is installed on the client computer and fixed our problem:

    http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en

    • 답변으로 제안됨 Steven Fischer 2009년 10월 25일 일요일 오전 6:21
    • 답변으로 제안 취소됨 Mike Walsh FIN 2010년 1월 12일 화요일 오후 6:03
    2009년 10월 13일 화요일 오후 11:13
  • Hi Stev,

    Even after installing the hot fix my problem still exist..

    Can any one please help me on this regard.

    Thanks,

    Karthi.
    2009년 10월 15일 목요일 오전 5:35
  • Hi Karthi,

     

    1.     What’s the version of your MOSS? Did you install SP2? If you haven’t installed SP2, I suggest you install it first and run post configuration wizard.

    2.     What’s the operation system and version of your machine?

    3.     What kind of browser do you use?

    4.     Does the problem only happen on one document library or all document libraries?

    You can refer to the documents below to do some basic troubleshooting:

    Whitepaper - Understanding and Troubleshooting the SharePoint Explorer View

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=c523ac7a-5724-48be-b973-641e805588f4

     

    Let me know the result if possible, thanks.

     

    Lu Zou

    2009년 10월 15일 목요일 오전 8:41
  • Hi

    1. MOSS 2007 and SP2
    2. OS: Windows 2003  64 BIT
    3. IE 7
    4. The problem is happening in all the document library.


    Regards,

    Karthi

    2009년 10월 16일 금요일 오전 7:17
  • Hi Karthi,

    There are a couple of things I would check.

    1. On the client, make sure that the WebClient service is running (Administrative Tools > Services).
    2. On the server, make sure that there is a site created at the ROOT of your SharePoint web application. It doesn't matter what type of site, just as long as one exists.

    This has fixed the problem for me in the past, but when it comes to Explorer view, there are a lot of components involved (as the white paper will tell you)

    Anyway hope this helps

    Paul.
    2009년 10월 16일 금요일 오후 1:44
  • Hi there, i had a similar issue on WebDav.
    The system guys installed this WebDav feature in my Windows 2008 , although your OS is Windows 2003 ,my error message was the same.
    Check this out http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/023f4b23-3ce6-4d83-8cb0-7398b88ba6ab/

    Hope it helps

    Best regards

    Any Question feel free to ask

    Rodrigo Pinto(Scoutman), SharePoint Architect

    2010년 1월 8일 금요일 오전 2:37
  • Steven Fischer:

    Please do not propose your own posts as answers, it isn't helpful.

    Propose the good answers of other people instead - that helps.


    (Moderator)
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    2010년 1월 12일 화요일 오후 6:03
  • I would say the post Scoutman put up is really helpful. solved the issues i've been having for months with the password prompt in all Office docs.

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/023f4b23-3ce6-4d83-8cb0-7398b88ba6ab/?prof=required

    Remove WebDav from your Sharepoint Servers and reboot them. It will fix the issue with Windows Explorer view. Also, if you have your system x64 bit, make sure you open IE x86 to launch Explorer View.


    Jawad
    2010년 5월 12일 수요일 오후 3:24
  •  But in case of a SharePoint generic list we don't have this option.To implement this functionality we need to add the following script in the page, and call the script method from a event. In SharePoint list, if a list Item contains any attachment, it creates a folder with the name of the item id and add the attachments inside that  folder. When we open the list in Window Explorer we can see the folders for the list items which contain attachments, here we can drag and drop the documents to save as attachment for the list Item.
    <style>
           .httpFolder {behavior: url(#default#httpFolder);}
    </style>
    <script>
           function fnOpenFolderView() {
            oDAV.navigateFrame("url for the list", "_self");
             }
    </script>

         
    <div id = "oDAV" class = "httpFolder"/>
     
       <!-- The input object calls the fnOpenFolderView function -->
     <input type = "button" value = "Open Folder View" onclick ="fnOpenFolderView()"/>

    hope this adds value.Any suggestions are appreciated.

    Cheers, Eliza
    2010년 6월 17일 목요일 오후 12:23
  • On the Client

    Ensure your WebApplication is in the Local Intranet security Zone

    When you use Internet Explorer to access the WebDAV site, Internet Explorer uses Windows HTTP Services (WinHTTP). WinHTTP sends user credentials only in response to requests that occur on a local intranet site during an authenticated logon process. However, WinHTTP does not check the security zone settings in Internet Explorer to determine whether a Web site is a local intranet site. Instead, WinHTTP depends on the proxy settings in Internet Explorer to determine whether a Web site is a local intranet site. If the Automatically detect settings option is not enabled, any auto-configuration script that is defined will not be processed. WinHTTP will not identify the WebDAV site as a local intranet site. Therefore, WinHTTP will send out a request without user credentials, and you will be prompted to type user credentials.



    On the WFEs

    Check if the WebServer > Role Service > WebDav Publishing is installed on the SharePoint WFEs . I have had this issue and the only way I found the resolution was with Fiddler, another farm to compare where I didn’t have the issue, and Google.

    Disabling the component is not enough, it must be removed completely from IIS using the following steps:

    1. Open Server Manager

    2. On the left side of the pane click on Roles

    3. Scroll down to the "Role Services" section, and click on "Remove Role Services"

    4. Under "web server" uncheck the box next to "WebDav Publishing"

    5. Choose Next, then choose Remove

    6. A reboot will be required



    Reference

    Sudeep Gopalakrishnan
    http://www.pubsub.com/Webdav-folders-–-no-full-functionality_Windows-MOSS-7tB9oLk7rqi,fVoMRAEGZf3E

    Sean McDonough SharePoint, WebDAV, and a Case of the 405 Status Codes
    http://sharepointinterface.com/2009/12/28/sharepoint-webdav-and-a-case-of-the-405-status-codes/

    Todd Klindt, “Installing Remote Blob Store (RBS) on SharePoint 2010
    http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=174

    Troubleshooting WebDav
    http://www.microsoft.com/downloads/details.aspx?FamilyId=C523AC7A-5724-48BE-B973-641E805588F4&displaylang=en

    KB Article for this with MOSS 2007 and explorer Reference
    http://support.microsoft.com/kb/2171959/en-us

    Originally Found on TechNet:
    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/99d923cd-50e2-4a32-a45d-5df4f8627f37?prof=required

    Thanks Ivan !

     

    http://tim-barsotti.blogspot.com/2010/07/windows-explorer-sharepoint-2007.html

    2010년 7월 8일 목요일 오후 4:29
  • Hi ,

    As I saw that you already tried the WebDAV procedures and not worked So , I think you need to have a look at CA (Central Administration) and make sure that your web application enabled the client integration tools .

    Make sure it's enabled if not this will fix your problem.

     

    Thanks,

    Hesham Saad


    Best Regards, Hesham Saad
    2010년 7월 31일 토요일 오전 6:59
  • Hi,


    We get this problem quite frequently. It is usually as a result of a corrupt NetHood. Below I've copied the text from the EduGeek article related to this. http://www.edugeek.net/forums/windows/59047-intermittent-sharepoint-nethood-corruption-documents-folder-not.html

    When the user gets the error "Documents in this folder are not available. The folder may be have been moved or deleted, or network problems may be preventing a connection to the server." In XP you need to run c:\windows\system32\webfldrs.msi in repair mode. Uncheck Repair all detected reinstall problems but check everything else. Runas an administrator with the user logged in.

    In Windows 7 download the following: Download details: Software Update for Web Folders (KB907306)

    Thanks,

    2011년 4월 14일 목요일 오후 1:14
  • “Open with Windows Explorer” option of SharePoint  only works for the 32-bit system.

    The reason is that Web DAV functionality is provided natively by Web Client Service and extended by the Office installation of Microsoft Data Access Internet Publishing Provider(MSDAIPP). Since MSDAIPP is only 32-bit, it cannot be used by 64 bit Internet Explorer.

     

    Please shift back to 32-bit

    2011년 10월 25일 화요일 오후 1:48
  • “Open with Windows Explorer” option of SharePoint  only works for the 32-bit system.

    I think what he is talking about is the 32-bit version of Internet Explorer.  We have 32- and 64-bit Windows XP, Vista, and 7 systems that connect to our MOSS 2007 x64 farm.  They use Windows Explorer view on all platforms (not perfectly) for 32- AND 64-bit systems.  However, the option to do this does not appear if you run Internet Explorer in 64-bit mode.

    • 편집됨 IT Happens 2011년 12월 7일 수요일 오후 9:00
    2011년 12월 7일 수요일 오후 8:59
  • Who said “Open with Windows Explorer” option works only on 32-bit sustems.

    DO NOT PROPOSE YOUR ASSUMPTIONS to others without properly validating, it will definitely mislead people.

    2012년 3월 27일 화요일 오후 2:25
  • I have been unable to solve this issue so far for the regular 32-bit IE9 in Windows 7, I have been able to get the "Open with Windows Explorer" to work using the Internet Explorer (No Add-ons) icon.  When I run IE in the no add-on mode it functions normal, I will investigate this further.
    • 답변으로 제안됨 Redhorse515 2012년 7월 10일 화요일 오전 12:03
    2012년 4월 18일 수요일 오후 9:06
  • Installing KB 907306 on Windows 7 is unsupported by Microsoft.

    To repair MSDAIPP on Windows XP use the "Microsoft Data Access Internet Publishing Provider configuration repair script" http://support.microsoft.com/kb/2459200

    2013년 11월 20일 수요일 오후 11:27