none
Conversation History not working in Outlook 2010

    Question

  • I went to find an old Communicator conversation in the Conversation History folder in Outlook, and it appears that it stopped logging my conversations when I installed Office 2010. Has anyone else noticed this, and is there a fix?
    Friday, December 04, 2009 3:34 PM

All replies

  • I've got the same thing...
    Matt Nixon | http://unifiedmatt.blogspot.com
    Sunday, December 06, 2009 10:47 PM
  • Do you have multiple Exchange Accounts configured?
    Are you general options on Personal Information Manager correct and checked to log conversations in conversation history?
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Monday, December 07, 2009 4:17 PM
  • The options in the PIM section are actually grayed out. That said, all of the options are checked, which is how I want it to be. I think it started out with the option to save conversations unchecked, but I changed a registry setting (i can't locate the site with that info on it right now) and it changed the option so that it was checked.

    since the options are grayed out, that makes me wonder if installing the beta of Office 2010 took over some of those controls.
    Monday, December 07, 2009 4:51 PM
  • You are not using GPO to configure the settings?
    Because grayed out normally means that it is configured through GPO
    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Monday, December 07, 2009 4:55 PM
  • Actually mine is working now...
    Matt Nixon | http://unifiedmatt.blogspot.com
    Monday, December 07, 2009 11:20 PM
  • Hi
    Any update for your issue?

    Regards!
    gavin
    Wednesday, December 09, 2009 10:01 AM
  • i have not implemented any GPO's related to OCS, but that's a good point about grayed-out things being affected by GPO's. Matt, did you change anything?
    Wednesday, December 09, 2009 1:25 PM
  • I went to find an old Communicator conversation in the Conversation History folder in Outlook, and it appears that it stopped logging my conversations when I installed Office 2010. Has anyone else noticed this, and is there a fix?
    If you're using O2K10 x64, it won't work due to API differences between the x32 MOC and x64 Outlook. Think of it like 'crossing the streams' in Ghostbusters - it isn't supported.


    http://blog.tiensivu.com/aaron/ - https://mvp.support.microsoft.com/profile/Aaron.Tiensivu - If you find my post helpful, please click on the "Post was helpful" option inside my post.
    Thursday, December 10, 2009 9:43 AM
  • Hi Paul,
    Please make sure you have update the latest kb for your OCS server and OC client.
    I have found some related issue caused by that.

    Regards!
    gavin
    Thursday, December 10, 2009 12:10 PM
  • Aaron,

    If that is really the case with Outlook 2010 x64 and MOC x86, then that is my problem, and that makes me feel better about it all. The question, then, is... when do we get a 64-bit version of Communicator?


    Thursday, December 10, 2009 1:45 PM
  • The January updates to Communicator fixes the Conversation History feature in Outlook 2010 64-bit. Download link here:

    • Proposed as answer by VaibhavD Tuesday, August 23, 2011 9:24 AM
    Friday, January 15, 2010 1:17 PM
  • The January updates to Communicator fixes the Conversation History feature in Outlook 2010 64-bit. Download link here:

    Does not do it for me.  I am running O2K10 x64.

    Dnxcoded
    Wednesday, January 20, 2010 12:02 PM
  • Anyone found a solution for this? 
    Friday, April 16, 2010 12:01 PM
  • Hi
    Some mormal troubleshooting procedure.

    Scenario A: The user account logon computer is the same with user account used in Outlook and OC.
    ==============
    Check list:
    ------------
    1. We must have a Outlook profile using user account the same with computer log on account and OC account.
    2. The Outlook profile doesn’t need to be the default profile.
    3. The Outlook profile must have ever been initialized.

    Scenario B: Computer logon account is different from the account used by Outlook and OC.
    ===============
    Check list:
    -------------
    1. Outlook profile with the OC logon account must be created.
    2. The Outlook profile which has OC log account must be the default profile.
    3. After setting the Outlook profile as the default one, we must initialize the \user’s Outlook mailbox. (Open Outlook using the profile with OC user account at
    least once. ).
    4. Log off OC client and Log on again. This profile related “Outlook Integration” issue should be solved. Conversation history should be able to save in Outlook now.

    NOTE, please update to the latest kb.
    Regards!
    Gavin
    • Proposed as answer by Philip Waters Monday, November 01, 2010 4:04 PM
    Monday, April 19, 2010 3:31 AM
  • Yes I have two laptops. 

     

    Laptop One: Windows 7 64-bit with Office 2010 64-bit and OCS 2007 R2 with all updates including the latest in January.

    Laptop Two: Windows XP SP3 with office 2007 32-bit and OCS 2007 R2 with all updated including the latest in Janaury.

     

    Login accounts for OC and both laptops are all the same.

     

    If I login to laptop one, no conversations are recorded to my outlook folder.

    If I login to laptop two, all conversations are recorded and work without issue.

    Monday, April 19, 2010 2:30 PM
  • Gavin-Zhang....anything I can provide to help you resolve my issue?
    Tuesday, April 20, 2010 2:12 PM
  • Would you please capture the logs and warnings with Snooper put here for narrow down the issue?

     

    Communicator->Tools->Options->General->logging->"Turn on logging in communicator"

     

    Then use Soonper(Download from:http://www.microsoft.com/downloads/details.aspx?familyid=B9BF4F71-FB0B-4DE9-962F-C56B70A8AECD&displaylang=en) analyze the logs(C:\users\Alias\Tracing) ,then put error logs here.

     

    And make sure the latest KB of office 2010 have been updated properly.


    Best Regards!
    Wednesday, April 21, 2010 3:00 AM
  • Hi
    I have do some test and could not reproduce your issue in my scenario, mine works very well.
    So, if you test on the laptop one, you should not login the account on other laptop.
    And if the operation are all right, have you test the same scenario on other client, or you could reinstall the Office and the ocs 2007 r2 and reconfigure them.
    According to the laptop two work well, the server system seems work well too.
    Sure the method is a normal way, but it is efficent to save time.

    Regards!
    gavin

    Wednesday, April 21, 2010 3:17 AM
  • Hi, Paul, I reproduce the scenario on my VM server, would you please check the procedures below.

    If outlook isn't installed properly ,the related outlook settings in MOC are grey out, once outlook was installed properly, then you can check "Save my instant message conversations in the outlook conversation history folder." so I would suggest you reinstall outlook or move to another computer to test this.

    once the "Save my instant message....." settings was checked, the MOC will connect to Exchange server for create "Conversation history folder" and sync chat history in the Exchange account, it may takes 10 minutes, after restart outlook then "Conversation history folder" is appears in the outlook folder.


    Best Regards!
    Wednesday, April 21, 2010 6:01 AM
  • I am having the same issue just installed Office 2010 x64 and communicator 2007 R2 with the hotfix and it says it can not connect to outlook.
    cmcgreanor
    Friday, April 23, 2010 9:21 PM
  • Would you move to another computer to test?


    Best Regards!
    • Proposed as answer by bmoorewiz Monday, April 26, 2010 12:24 PM
    Monday, April 26, 2010 4:04 AM
  • The problem seems to be with the add-in to Outlook 2010. The Add-in Does not seem to be installed properly. Where is the file located so that I may install the Office Communicator 2007 Add-in?

     

    If I look at all of the other add-ins they have a file location and type.

     

    The Microsoft Office Communicator 2007 Add-in says it is a COM Add-in but does not have a location.

     

    ???

    Monday, April 26, 2010 12:28 PM
  • The Add-in should be installed along with Office package, so the Add-in must be installed once the Office 2007 or 2010 have been installed, if another computer works fine but this computer don’t work, the Add-in must be blocked by computer settings.


    Best Regards!
    Tuesday, April 27, 2010 1:55 AM
  • hi bimooreviz..... did you get this working somehow? I am facing the same issue and dont know how to resolve this. this sounds like horrible :(
    Friday, May 14, 2010 1:10 PM
  • We also have the problem with the conversation history. I tried everything in this thread with no luck. (We have 6 people with Outlook 2010 64-bit) Everything was working perfectly with Outlook 2007.

    Did anyone get this problem resolved? Or do we have to wait for OCS 2010 64-bit?

    Thursday, August 26, 2010 12:48 AM
  • Update MOC to latest version will resolve that problem.

    http://support.microsoft.com/kb/2028888


    Best regards,
    Thursday, August 26, 2010 2:19 AM
  • For me (Office 2010 32 bit + Office Communicator 2007), "Personal Information manager" settings are grayed out only on Win7 Enterprise clients which installed many applications as part of OS deployment with SCCM.

    The fix is to repair Office 2010 from add/remove programs . The add-in in Outlook seems to be loaded correctly

    Friday, October 01, 2010 3:27 PM
  • Gavin-Zhang

    This was an awesome post and gave me the information I needed to troubleshoot. Thank You.

    I tried this after I ran Set-CsClientPolicy -DisableEmailComparisonCheck $True on the server.

    Thanks again

    Phil

    Monday, November 01, 2010 4:05 PM
  • Running Windows 7 64-bit with Outlook 2010 32-bit and Communicator 2007 R2 - latest hotfixes. Multiple Exchange accounts configured in Outlook.

    I'm finding my IM conversations randomly stored in the Conversation History folder of one of the other accounts.

    Wednesday, November 10, 2010 1:00 PM
  • I am having this issue with Outlook 2010 32-Bit and Lync 2010 RC x64 on Windows 7 x64.

    I have two exchange accounts in Outlook. One is the account that I log in to windows with., the other is a goddady exchange account.

    Conversation history randomly goes in to one but usually the wrong one.

    Wednesday, November 17, 2010 11:16 PM
  • This really sucks. It's a significant privacy issue as far as I am concerned and, based on your experience, not fixed in Lync.

    I'm waiting for the days that somebody complains that their private conversations are being posted in a public location (shared mailbox). Our answers is, "it just works like that"?

    Nothing from Microsoft I note...

    Thursday, November 18, 2010 10:30 AM
  • I too am having this issue.  Outlook 2010, and OCS 2007 R2.  Also appears with Lync.  We need to be able to add multiple accounts in the outlook profile.  Having random conversations ending up in a shared mailbox is a HUGE privacy issue for us.

     

    Has anyone heard of a fix for this, or contacted Microsoft about this?

     

    Thanks,

    Rob

    Monday, December 13, 2010 6:39 PM
  • I spoke to our Microsoft account manager a few weeks ago but haven't heard anything yet. He was going to raise with the product group. I'll hopefully get an update this week but not holding my breath.
    Tuesday, December 14, 2010 1:08 PM
  • I've broken this privacy issue out as a new question at http://social.technet.microsoft.com/Forums/en-US/ocsclients/thread/e2203b6e-e034-4666-b418-29cabe64d8bd since it seems to be lost in this thread.
    Wednesday, December 15, 2010 5:40 PM
  • I have a third scenario:

    Scenario C: The Outlook client has a profile with two Exchange accounts and the OC is saving conversation history to the wrong account, even though it is not the default account.

    Tuesday, January 18, 2011 7:49 PM
  • i too had problems saving conversations. The scenario is i had my company acccount and a client mail account. Lync was being used on client mail account.I have a 64 bit machine and was using outlook 2010. Now initially had client mails and my company mail configured on exchange. The conversation were logging somewhere(as my lync said so) so i checked the client mail server they weren't ther nor in my personal folders poiting to client mails. After some thinking kept my company mails on pop3 and the client mails on exchang and bingo it was able to get all the conversation folder data...it was a relief.
    Thursday, February 03, 2011 4:59 PM
  • Sean, I too have two Exchange accounts.  OC is saving conversation history to the non-default account.  Were you able to find a solution, or a setting that allows you to point to a specified account to save history?
    Tuesday, April 05, 2011 4:23 PM
  • The January updates to Communicator fixes the Conversation History feature in Outlook 2010 64-bit. Download link here:

    Hi,

        I installed the hotfix and my OCS 2007R2 started saving the conversation history. Thanks for the hotfix. Cheers

     


    Vaibhav
    Tuesday, August 23, 2011 9:25 AM
  • I have Outlook 2010 x64 and Lync 2010 x64 and am having this issue.
    If you find my post helpful, please hit the "Vote as helpful" button so that others may see that it is helpful as well.
    Tuesday, September 06, 2011 7:41 PM
  • The January updates to Communicator fixes the Conversation History feature in Outlook 2010 64-bit. Download link here:
    I have installed the hot fix and still have the problem. I see the communicator add-in in the Outlook Inactive Add-ins list without a path. Anyone want to post the path and I can see if I can add it in manually?
    Wednesday, October 26, 2011 6:44 PM
  • Hello Team,

    I facing same issue, I do have MS-Office 2010 installed and Lync 2010, I am not able to see the conversation history in Outlook

    from last few days where as earlier conversation was getting stored.

    Also "Save Instant Message conversations in my email conversation history folder"

    and "Save call logs in my email conversation history folder" are grey out.

    Please suggest what to do to resolve this.

    Thanks

    Ravi Bankar

    The January updates to Communicator fixes the Conversation History feature in Outlook 2010 64-bit. Download link here:

    I have installed the hot fix and still have the problem. I see the communicator add-in in the Outlook Inactive Add-ins list without a path. Anyone want to post the path and I can see if I can add it in manually?

    Tuesday, February 28, 2012 8:19 AM
  • You can create a batch file from the following command that will enable Client side Archiving, although it works like the GPO so the setting is disabled in the client settings.  If you want to remove it you need to go into the registry and delete the entry.
    reg add HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator /v IMAutoArchivingPolicy /t REG_DWORD /d 1
    Tuesday, June 05, 2012 1:15 AM
  • I facing same issue, I do have MS-Office 2010 installed and Lync 2010, I am not able to see the conversation history in Outlook

    Also "Save Instant Message conversations in my email conversation history folder"

    and "Save call logs in my email conversation history folder" are grey out.

    Please suggest what to do to resolve this.


    Raja Sekhar B

    Thursday, June 14, 2012 8:40 AM
  • can someone found any solution? I have lync 2010 and outlook2010 and conversation history suddenly stop last month, this issue only face 2 users, other users conversation history saved in outlook working fine.

    Tuesday, September 18, 2012 1:26 AM
  • For us conversations were saved in another user's mailbox. Check Windows credential manager and look for the address of your exchange server. If you see another credential set for this address, lync will access EWS with these other credentials and put the conversation history in that mailbox.
    Friday, September 21, 2012 1:20 PM
  • Hi,

    I Appologies for delay, i check the Configuration Information for two user, 1 for who face issue and 2nd that user which working fine, both EWS Internal and External blank. only sip url defind in configuration information for user 1. i also check user 1 to sign in another laptop on owa and outlook client but same issue, on server side i uncheck user 1, and then sign in again and check on owa/outlook the conversation history not save. please help what next step. i also uncheck and check save in lync client properties. i can't recreate that account because This is MD ID, who have lot of contect save in lync, and what mean windows credential manger, where i check this option.

    Regards,

    Sunday, September 23, 2012 6:04 PM
  • found a solution to the third scenario ! 

    check out  

    http://felipecgoncalves.blogspot.com/2011/10/ocs-conversation-history-saved-on-wrong.html?showComment=1354797034080#c2192689801224543859

    In summary,

    uncheck save to outlook in OCS options,

    remove all accounts except destination account from outlook,

    reconfigure ocs to save conversation history,

    test that it works,

    re-add additional accounts back to outlook.

    Thursday, December 06, 2012 12:35 PM