none
Failure [0xC3FC200D] one or more error were detected during Front end server validation in OCS R2

    Question

  • Pool Name: server-comms.xxx.qum
      Failure
    [0xC3FC200D] One or more errors were detected
    Check Pool Hosted User Setting   AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=SERVER-COMMS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=XXX,DC=qum)(!(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=256)))
    All users enabled for enhanced presence: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=SERVER-COMMS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=XXX,DC=qum)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=128))
    Any user enabled for voice routing: True
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=SERVER-COMMS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=XXX,DC=qum)(msRTCSIP-FederationEnabled=TRUE))
    Any user enabled for federation: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=SERVER-COMMS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=XXX,DC=qum)(msRTCSIP-InternetAccessEnabled=TRUE))
    Any user enabled for remote access: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=SERVER-COMMS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=XXX,DC=qum)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=1))
    Any user enabled for public IM connectivity: False
    Warning: One or more pool hosted users are enabled for telephony, federation or remote access, but no audio-video edge server is specified for the pool.
    Error: One or more pool hosted users are enabled for telephony, but default location profile hasn't been specified for the pool.
      Failure
    [0xC3FC200D] One or more errors were detected


    My standar edition OCS 2007 R2 Valication fail with the above error which I was not expecting but I was expecting a different warning with 0x43FC200C. I don't have edge server or enterprise voice yet. So I was expecting the warning with 0x43FC200C but not this error.  

    Please advice
    Friday, June 19, 2009 4:51 AM

Answers

  • Hi mkhan100

              Any user enabled for voice routing: True

    Unless you have not configured "voice" - you need to turn off "voice" for all users.


    Thanks

    • Marked as answer by mkhan100 Sunday, June 21, 2009 9:24 PM
    Friday, June 19, 2009 3:13 PM

All replies

  • Hi mkhan100

              Any user enabled for voice routing: True

    Unless you have not configured "voice" - you need to turn off "voice" for all users.


    Thanks

    • Marked as answer by mkhan100 Sunday, June 21, 2009 9:24 PM
    Friday, June 19, 2009 3:13 PM
  • onece again. Thanks very much to sharadsharma2k5
    Sunday, June 21, 2009 9:25 PM
  • Hi sharadsharma2k5,

    I have the same problem as mkhan100. How do I turn off "voice" for all users? I have tried with the wizard of "Configuring users" but cannot locate that option.

    Your help would be appreciated.

    THANKS IN ADVANCE
    Thursday, July 02, 2009 8:52 AM
  • Hi,

    I have read about the msRTCSIP-OptionFlags. 'Any user enabled for voice routing: True'  appears because in the value of msRTCSIP-OptionFlags the eigth bit is equal to 1, I mean 128. I run the "Configuration users" wizard and disable the Enterprise voice. After that I keep getting the same error: Any user enabled for voice routing: True.  If I review the msRTCSIP-OptionFlags, I get a value of 256 which is Enhanced presence.

    The value of 256 makes:

    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=XXX-XXXX,,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=xxxx,DC=xxxx)(!(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=256)))   ---> 256 != 256 --> False
    All users enabled for enhanced presence: False

    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=XXX-XXXX,,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=xxxx,DC=xxxx)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=1))           ---> 1 = 256 --> False
    Any user enabled for public IM connectivity: False

    Then, I do not understand why:

    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=XXX-XXXX,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=xxxx,DC=xxxx)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=128))     --> 128 = 256 --> False
    Any user enabled for voice routing: True    --->WHY TRUE????



    My question is: Is there any other user where I have to disable Enterprise Voice? I am using OCS 2007 R2 over Windows server 2008 SP2.

    Any help would be appreciated.

    THANK YOU

    Thursday, July 02, 2009 10:40 AM
  • Hi sharadsharma2k5,

    I have the same problem as mkhan100. How do I turn off "voice" for all users? I have tried with the wizard of "Configuring users" but cannot locate that option.

    Your help would be appreciated.

    THANKS IN ADVANCE



    Hi adelmoral

         Please check this link:
    http://technet.microsoft.com/en-us/library/dd572502(office.13).aspx

    1. Open the Office Communications Server 2007 R2 snap-in.

    2. In the console tree, expand the forest node, and then navigate to the Standard Edition server or Enterprise pool that contains the user account that you want to configure.

    3. Expand the appropriate server node or pool node.

    4. In the console tree, click Users , and then do one of the following:

      • To configure all users in this node, right-click Users , and then click Configure users to start the Configure Office Communications Server Users Wizard.
      • To configure only specific users, in the details pane, select the users that you want to configure, right-click the selection, and then click Configure users to start the Configure Office Communications Server Users Wizard.
    5. On the Welcome to the Configure Users Wizard page, click Next .

    6. On the Configure User Settings page, select the check box next to the features that you want to configure for the selected user or users, and then, for each feature, click Enable or Disable . The available user settings are listed here:

      • Federation
      • Remote user access
      • Public IM connectivity
      • Enhanced presence
      • Archive internal messages
      • Archive federated messages
    7. Click Next .

    8. On the Configure Meeting Settings page, select the Organize meetings with anonymous participants check box, and then click Allow or Disallow . These options are not available if the global setting is not configured to support anonymous participation in meetings. For details, see Enabling and Configuring Anonymous Participation in Meetings .

    9. Click Next .

    10. On the Configure User Settings page, do one of the following:

      • To view the policy, click View . You can only view the settings of the selected policy.
        Dd572502.note(en-us,office.13).gif Note:
        To change any settings shown in the View Meeting Policy page, edit them in Office Communications Server 2007 R2 by using the Meetings tab of Global Properties .
      • To change the meeting policy for these users, select the Change meeting policy check box, and then click the policy in the Select a meeting policy for the users drop-down list box. The Change meeting policy option cannot be changed for users if the global policy is not configured to enforce meeting policy on a per-user basis.
    11. Click Next .

    12. On the Configure Enterprise Voice page, to enable or disable Enterprise Voice for users, select the Change Enterprise Voice Settings for selected users check box, click Enable Enterprise Voice or click Disable Enterprise Voice , and then click Next .

    13. On the Configure Enterprise Voice Settings and Location Profile page, to change the Enterprise Voice policy, select the Change Enterprise Voice policy for selected users check box, and then click the name of the Enterprise Voice policy in the list. To view the settings that are configured for a policy, click the name of the policy in the list, and then click View .

    14. To configure the location profile that will be applied to the selected users, select the Change location profile for selected users check box, and then click the name of the location profile in the list. To view the settings that are configured for a location profile, click the name of the location profile in the list, and then click View .

    15. Click Next .

    16. On the Configure Operation Status page, verify that the operation succeeded, and then do the following:

      • To export account information to an XML file, click the Export button below the list that contains the accounts for which you want to export user configuration information.
      • To close the wizard, click Finish .


    Thanks



    Thursday, July 02, 2009 1:42 PM
  • Thank you very much for your answer sharadsharma2k5.

    I still keep receving the following failure: 

    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=OCS-ETIC,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=etic,DC=local)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=128))
    Any user enabled for voice routing: True

    I've run the wizard for all users and check the Disable Enterprise voice and still keep this failure in order to get all validation right. I've looked for the msRTCSIP-OptionFlags for all users (using ADSEDIT) and I've seen that the value is 256, which is supposed to be Enhanced Presence.

    Do you have any idea on what I'm missing? Any idea would be really appreciated.

    THANK YOU VERY MUCH.
    Thursday, July 02, 2009 8:27 PM
  • I have the exact same problem. I had made a previous Enterprise installation that i uninstalled before testing after receiving instructions.
    I used the following commands to clean the AD:

    lcscmd.exe /Server /Role:SE /Action:Deactivate /Force
    lcscmd.exe /Web /Action:Deactivate /Force
    lcscmd.exe /Domain:domain /Action:DomainUnPrep /Force
    lcscmd.exe /Forest:domain /Action:ForestUnprep /Force


    After installing the Standard Edition, attempting validation i keep getting the same error:

    Filtro de pesquisa do AD: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=RDORIAOCS,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=rauldoria,DC=local)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=128))
    Qualquer usuário habilitado para roteamento de voz: Verdadeiro

    I've configured all users. I'm clueless.

    Server 2008 x64 Enterprise
    • Edited by Ricardo Garrido Wednesday, July 22, 2009 5:26 PM details missing
    Wednesday, July 22, 2009 5:25 PM
  • Has anyone found a resolution the issue above?

    I have just installed a clean installation of Windows 2k8 along with OCS 2007 R2 SE. I have no users configured. I have followed the MS documentation on this software from the beginning, and  when I run the verification I get the above issue as well.

    I followed the steps laid out by sharadsharma2k5 , and to no avail I am still receiving the same error.

    Any help on this issue would be appreciated.
    Users Medals Users Medals Users Medals Users Medals Users Medals
    Tuesday, July 28, 2009 2:52 PM
  • The problem persists. I've tried everything i can remember.
    Tuesday, July 28, 2009 5:56 PM
  • I have been going over everything so far and from what i can see from the server stand point is that there appears to be 3 users that are configured in the user database.

    I have done a completely clean install of the OS and the applications, and it still appears.

    Any one know of an application I can use to access the SQL database on this server?





    Number of active end points: 1
    Number of enabled users: 4
    Number of active users: 1
    Average number of contacts per user: <None>
    Minimum number of contacts per user: <None>
    Maximum number of contacts per user: <None>
    Standard deviation of number of contacts per user: <None>
    Percentage of contacts which are external (averaged over entire pool): <None>
    Number of PIC enabled users: 0
    Number of Federation enabled users: 0
    Number of Remote Access enabled users: 0
    Number of Enterprise Voice enabled users: 3
    Number of PBX integration enabled users: 0
    Number of Remote Call Control enabled users: 0

    Tuesday, July 28, 2009 6:51 PM
  • Alright so what is currently going on is this, OCS 2007 R2 Is seeing all the user accounts I have setup in AD. It is then proceeding to think that these users are automatically Enabled for OCS, even though they have not actually been enabled by the administrator. 


    Even after I have enabled the users, assigned them a SIP and then removed them from the OCS pool, they are still registered as being enabled.

    I have Disabled my test user, and it appears once the user is disabled, there is one less user enabled for OCS.

    I have also disabled the 2 accounts I installed for starting the services. And now I am down to 1 Account enabled on the OCS server. This is the Administration Account.

    I am going to enable all 4 users again and add them to the OCS configuration, then remove them all from the Voice controll. This should fix the issue I am having, and maybe the issue you are having.
    Tuesday, July 28, 2009 8:15 PM
  • i have this error "0xC3FC200D" and check the ocs on AD to find " configure user " and disable enterprise voice because "Any user enabled for voice routing: True "

    i right click on the "users" under the forest but it is not located there.


    it is very important for me as it is part of my dissertation.

    thanks
    Sunday, November 29, 2009 12:06 AM
  • Perhaps all AD user accounts - even the disabled ones - are enabled for enterprise voice on instalation.
    Sunday, November 29, 2009 5:31 PM
  • I am having the same problem when I run the Validate Front End Server Configuration for Standard Edition.

    As far as configured users I have only enabled and configured 2 users and for both of these I have changed the Enterprise Voice Setting to disable Enterprise Voice. Yet when I run it it comes back with:

    Failure
    [0xC3FC200D] One or more errors were detected


    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=DBSSRV02,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=test,DC=com)(!(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=256)))
    All users enabled for enhanced presence: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=DBSSRV02,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=test,DC=com)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=128))
    Any user enabled for voice routing: True
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=DBSSRV02,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=test,DC=com)(msRTCSIP-FederationEnabled=TRUE))
    Any user enabled for federation: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=DBSSRV02,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=test,DC=com)(msRTCSIP-InternetAccessEnabled=TRUE))
    Any user enabled for remote access: False
    AD search filter: (&(msRTCSIP-PrimaryHomeServer=CN=LC Services,CN=Microsoft,CN=DBSSRV02,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=test,DC=com)(msRTCSIP-OptionFlags:1.2.840.113556.1.4.803:=1))
    Any user enabled for public IM connectivity: False
    Warning: One or more pool hosted users are enabled for telephony, federation or remote access, but no audio-video edge server is specified for the pool.
    Error: One or more pool hosted users are enabled for telephony, but default location profile hasn't been specified for the pool.

    Wanabe how did you get the user list showing the number of Enterprise Voice enabled users?
    Tuesday, December 01, 2009 12:18 PM
  • Has ANYONE figured this out? I have the same issue. I dont even want Telephony/Voice as part of my OCS install, I want just the corporate IM (Not even Public) on this server. Someone please help us all!
    Wednesday, December 09, 2009 5:55 AM
  • I have the same issue.
    Error: One or more pool hosted users are enabled for telephony, but default location profile hasn't been specified for the pool.

    I have only one user, and it is disabled in all sections.


    Somebody got a solution for this problem?
    Wednesday, December 23, 2009 2:52 PM
  • Why don´t you just create a dummy location profile (with a dummy normalization rule) and assign it to the pool in order to get rid the error message? As long as no real user is enabled for enterprise voice it is not used anyway. These 3 enterprise voice enabled users seem to be something built-in which cannot be changed.
    Wednesday, December 23, 2009 5:58 PM
  • How to create a location profie?
    Thursday, December 24, 2009 7:02 AM
  • I have exactly the same issue.  How did you resolve this?
    Tuesday, May 11, 2010 7:56 PM
  • T. Werner suggestion is good.

     

    Go to the OCS MMC, right click the forest and go to Properties->Voice Prop.

    See if there's any location profile there, if not create a dummy one.

    After there's a location profile go to your OCS Pool, right click it and select Properties-> Front End Properties. Go to the voice tab and select the dummy profile on the "default location profile for this pool".

    "Problem" should be fixed

     

    Regards


    Hugo Picão MCSE / MCTS http://hpicao.blogspot.com/
    Thursday, May 13, 2010 2:38 PM
  • Right click the forest and go to properties then forest properties.  Create the location profile and normalization rules ( I copied one from the guide).

    Right click the pool/server and go to front-end properties. assign that profile on the voice tab.

    force replication or wait for replication.

    I ended up with a warning in my retest on validation but that's fine by me.... a warning is better than a failure!!

      No WMI Instance Returned By Query : select * from MSFT_SIPPhoneRouteData
    Warning: One or more gateways are not assigned to any phone route
       Warning
    [0x43FC200C] Not all checks were successful 

    I have two servers running in my environment which is why I got this error.  I"m migrating from a standard install to the enterprize install.

    I suffered through this for a while myself and after reading this thread, found a viable solution.

    • Proposed as answer by GlenVic Wednesday, July 07, 2010 10:18 PM
    Wednesday, July 07, 2010 10:17 PM
  • Hi

    I had same issue on Windows Server 2008 with OCS 2007 R2. The solution of creating a local profile and assigning it worked for me.

    Thanks for the post

    Akash

    Wednesday, August 11, 2010 8:32 AM
  • I realize that this is an old thread but maybe it will help someone to have an actual answer.

    It turns out that the problem is that in R2 some new functionality was added to support dial-in attendees. In order to support this hidden users were created with enterprise voice enabled.

    You can run the AD Search Filter on your domain controller to find them.

    When you get the report from OCS Validation, drill down to the actual error message. Then scroll up to the line that says "Any user enabled for voice routing: True" (or any of the other true lines that are causing errors).

    The AD Filter string is above the true message. Copy the filter string and take it to your domain controller.

    • In Active Directory Users and Groups, right click on Saved Queries and select New\Query
    • Enter a name like "Enterprise Voice" and click on Define Query
    • In the Find drop-down, select Custom Search
    • Click on the Advanced tab
    • Paste the filter string you copied above into the LDAP query box and click Ok and then Ok again

    You may need to click on the newly created saved query. When you do, you should see one or more users on the right with GUID's for names.

    AD will probably not let you change the enterprise voice settings because of some missing SID data. In my case I just deleted them because I do not plan to implement enterprise voice. If you do, you can still delete them now and repair AD later when you add enterprise voice.

    I hope this help someone :-)


    JPH

    Tuesday, January 29, 2013 11:11 PM