none
Lync + UM + GMail

    Question

  • So we have some users we want to include in our Lync and UM Voicemail setup but who host their email domain (domain3.com) outside the org with GMail.

    We currently have domain1.com and domain2.com set up for Lync/Exchange/UM and everything works great.  So for domain3.com we set them up for SIP using domain3.com (which is also their UPN) despite the fact that domain3.com email is hosted by GMail (we created an exchange mailbox for them with the default policy creating an address of user@domain.local).  I then created an Exchange contact with the SMTP address user@domain3.com - the exchange user's mailbox was then configured to forward to this contact.  This way the missed call and voicemail emails automatically get forwarded on to the user's GMail mailbox.  This works fine.

    However!  I noticed when logging in via edge they were getting Exchange integration errors and the configuration info showed "EWS not deployed" - most of the hits for this error do not apply here since EWS is functioning just fine for other sip domains.  So the user cannot see missed calls or voicemails in Lync.

    As a test I altered the users' SIP domain and added SMTP address of domain1.com and left everything else the same - and then everything works.

    So does EWS not work for domains that are not "accepted domains" in Exchange - is that my issue?

    Thanks!

    Friday, February 11, 2011 7:00 AM

All replies

  • Sorry but your question is confusing. You're talking about user and contact objects and it's confusing how those users are currently set up.

    Did you create an AD user or AD Contact for these users?
    Did you create a user mailbox or mail-enabled contact for these users?
    Did you configure the mailbox to automatically forward all incoming mail to gmail?
    Did you enable this mailbox for Unified Messaging?
    Is the SMTP email address the same as the Lync SIP URI?


    Technical Specialist Microsoft OCS/Lync & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Friday, February 11, 2011 8:34 AM
  • It sounds like the issue is with the certificate/name associated with the external name. Internally you are able to resolve the domain.local when doing an auto-discover but externally you would not. Check out KB940726 http://support.microsoft.com/kb/940726 as a workaround.
    Brian Ricks, MCSE, MVP BriComp Computers, LLC http://blogs.bricomp.com/blogs/uc/default.aspx
    Friday, February 11, 2011 1:04 PM
  • Sorry guys...  let me try to do a better job explaining now that I've gotten some sleep!

    Internal domain is INT.LOCAL

    Exchange EWS is set up at secure.EXT.com with an appropriate certificate - DNS SRV records for the smtp domains properly point to this hostname and outlook/lync work just fine for all domains other than the gmail one.

    Users are set up with UPNs based on their SMTP email addresses, and have SIP addresses to match, so we have:

    upn/sip of user@smtpdomain1.com (exchange accepted domain)

    upn/sip of user@smtpdomain2.com (exchange accepted domain)

    upn/sip of user@smtpdomain3.com (gmail hosted domain)

     

    Users on domain1/domain2 are configured in Exchange normally and have UM functioning perfectly.  I then created an exchange mailbox for a user on domain3 (full exchange mailbox) but left it with the default address policy, so its only smtp address was user_d3@INT.local - I enable UM on the mailbox and configure its extension and UM address is based on smtpdomain3.com just like the sip uri.

    I then created a separate exchange contact named user_d3contact and set its smtp address to user@smtpdomain3.com - and set the user_d3@INT.local exchange mailbox to forward to the user_d3contact item.  So now all mail (including missed calls and voicemails) get forwarded to the user's gmail account.  This works fine.  At this point, the smtp email address is of course different than the sip uri (int.local versus smtpdomain3.com).

    The only problem comes when logging into Lync - exchange connecitvity error comes up and the red exclamation points show over the missed call and voicemail areas in lync.  Clicking on the configuration shows the "ews not deployed" message.

    As a test, I gave the same user an smtp address on smtpdomain1 and changed its sip to smtpdomain1 as well - the errors go away.

     

    So in sum, users on smtpdomains 1 and 2 work just fine despite their smtp/sip domains not matching the domain of the exchange certificate, so i do not think the cert is the issue.  The only difference with smtpdomain3 is that it is not an "accepted domain" in Exchange - perhaps EWS refuses to serve accounts that are not accepted domains?  I have used the remote connectivity analyzer with the account in question and it confirms that autodiscover is working properly all the way through the process...

    Let me know what you think, thanks!

    Friday, February 11, 2011 4:50 PM
  • p.s. if there is a better/more efficient way of handling the forwarding than creating a separate contact and forwarding the mailbox to it, please let me know!
    Friday, February 11, 2011 4:52 PM
  • I changed the user's sip domain back to match their UPN (smtpdomain3.com - the one hosted by gmail) and I am no longer getting the errors.  Will test with another user soon to see the behavior.

    Do you guys know if it is possible to schedule a future Lync meeting with Lync itself - or is that only possible with Outlook (which the gmail users don't have)...

    Thanks!

    Wes

    Thursday, February 17, 2011 12:17 AM