none
McxSipPrimaryListeningPort 5086 not listening

    Question

  • Hi,

    I am on my second Lync 2010 Mobility install and have run into a problem.

    I have run the below commands several times but the server is not listening on ports 5086 or 5087. I have run the commands several times and rebooted the server several times to be sure.

    Set-CsWebServer -Identity myserver.mydomain.local -McxSipPrimaryListeningPort 5086

    Set-CsWebServer -Identity myserver.mydomain.local -McxSipExternalListeningPort 5087

    Enable-CsTopology

    If I run this command,

    Get-CsService -WebServer |fl McxSipPrimaryListeningPort, McxSipExternalListeningPort

    I get this output,

    McxSipPrimaryListeningPort  : 5086
    McxSipExternalListeningPort : 5087

    netstat -an does not list the ports as listening and I cannot telnet to the server on either port (firewall is disabled).

    Using Wireshark capture I can see the connection is making it to the server, But looking at the Lync Server 2010 Logging Tool McxService there is nothing.

    The issues I had with the previous install were corrected by installing the update mentioned below (it showed up in MS updates about 6 weeks after the Mobility service was released)

    Update for Lync Server 2010, Unified Communications Managed API 3.0, Core Runtime 64-bit (KB 2500449)

    I have run all MS/windows updates but the above update is not in the list, I can see Managed API 3.0, Core Runtime 64-bit (KB 2500448) as installed but the KB is one number off.

    Any thoughts?

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Thursday, May 17, 2012 7:52 AM

Answers

  • Hi,

    I got it working.

    Our network engine did not forward all the correct ports on the external firewall to the right server/port internally.

    Once this was corrected the ports 5086/5087 started listening (I think it was triggered by the client try to connect - IMHO I think it should be always on)

    The mobile clients now connect.

    Thanks Sharon and Nic for you thoughts.

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    • Marked as answer by ssbob1975 Thursday, June 07, 2012 1:40 AM
    Thursday, June 07, 2012 1:40 AM

All replies

  • Hi,Ssbob1975,

    Have you installed the cumulative update for Lync Server 2010  and run Bootstrapper.exe to installed the Mobility service package McxStandalone.msi?

    Would you please check the IIS website to verify that the MCX and Autodiscover webpage are there?

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Friday, May 18, 2012 7:37 AM
    Moderator
  • Hi Sharon,

    Yes CU 5 for Lync 2010 has been installed and I have run the bootstrapper to install the mobility service package McxSandalone.msi and that reported success.

    I have checked IIS and Mcx and Autodiscover are there.

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Friday, May 18, 2012 9:11 AM
  • Hi Jeff,

    We have exactly the same situation. I have a pool with 2 front end servers. One frontend seems to be fine and when we do a netstat -an on that server, port 5086 is marked as listening. On the other frontend, the port can be reached  but netstat -an does not list.

    We have applied CU 5 on both frontends, and all updates are in place.

    Our mobile clients connect without a problem, so everything seems to works fine, but SSCOM keeps remembering me that on FE1 not everything is ok:

    Alert description: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ServerName: ServerPoolName Port: 5086

    Nic.

    Tuesday, May 22, 2012 8:33 PM
  • Hi Nic,

    As a test I set the ports on the Default Website on the front end server to 5086 and 5087 and was able to start that default website without any errors.

    Running netstat -an | more confirmed that it was listening on 5086 and 5087 so I stopped the default website and change the ports back to 80 and 443 and run nestat again and confirmed that it is not listening on those ports again.

    "Set-CsWebServer -Identity myserver.mydomain.local -McxSipPrimaryListeningPort 5086" followed by "Enable-CsTopology -Verbose" does not update the database.

    Can anyone confirm where the Mcx ports are set in the database and in which database as I can see several when I login to the SQL management studio on the FE server?

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Monday, May 28, 2012 2:06 AM
  • Hi,

    I have done a quick test McxP2PIM and the result is in the capture below.

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Monday, May 28, 2012 4:07 AM
  • Hi,Jeff,

    Any progress?

    Would you please verify that the mobility services are starting successfully?

    Also please make sure there is no other application occupy the listening port for Mobility service.

    B/R

    Sharon


    Sharon Shen

    TechNet Community Support

    ************************************************************************************************************************

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question.

    Monday, May 28, 2012 6:30 AM
    Moderator
  • Hi Sharon,

    Mobility services (Mcx and Autodiscover in IIS?) Yes IIS has started correctly.

    There are no other applications trying to use the mobility listening ports 5086 and 5087.

    As a test I changed the ports on the defualt website to 5086 and 5087 and was able to see it listening with "netstat -an" if the server was already listening on those ports I should not have been able to start the default website with those ports configured - it should have given an error.

    Is there a way to negate the command
    Set-CsWebServer -Identity myserver.mydomain.local -McxSipPrimaryListeningPort 5086

     The reason I ask is because when I run the command Enable-CsTopology - Verbose the feedback is "No changes were made to the Central Management Store"

    It would be nice to remove the settings and add them again and verify that the Management Store is updated.

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Monday, May 28, 2012 8:40 AM
  • Hi,

    The capture below is from the log file that is created by enable-cstopology command.

    Both components report success

    Any other thoughts?

    Thanks,

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    Tuesday, May 29, 2012 4:20 AM
  • Hi,

    I am afraid I cannot help here much, but I can report that our problem disappeared. I do not understand why, but after 3 days scom closed my problem : it reported that the alert was resolved by the system. In the event viewer I do not not see any correlation between the arising and closing of the problem. A nestat command confirms this and both of the servers are now fine, but I do not know what caused the problem in the first place.

    Nic.

    Tuesday, May 29, 2012 7:47 AM
  • Hi,

    I got it working.

    Our network engine did not forward all the correct ports on the external firewall to the right server/port internally.

    Once this was corrected the ports 5086/5087 started listening (I think it was triggered by the client try to connect - IMHO I think it should be always on)

    The mobile clients now connect.

    Thanks Sharon and Nic for you thoughts.

    Jeff


    MCP MCTS MCITP Enterprise Administrator

    • Marked as answer by ssbob1975 Thursday, June 07, 2012 1:40 AM
    Thursday, June 07, 2012 1:40 AM