none
Lync 2013 Web App closes upon launch (IE) along with other strange behavior (other browsers)

    Question

  • We have recently deployed Lync Server 2013 and we are having some trouble getting anonymous users to join a meeting via the Lync Web App. Permissions have been set to allow anonymous user access to the Web App as well as the permission for certain users to host meeting that allow anonymous access. When the anonymous user gets the link in their email, it takes them to the meet.domain.com/sipuser/unique string URL which launches the Web App correctly, but then closes instantly. No log in request, nothing. That was for IE 10. When attempting to do the same in Chrome, Java pop up window asks to allow, then takes them to the right section, then give a "lync client" error and wants to launch lync2013 client (which is not installed). From Safari on a mac, the URL just takes the user to a blank page and nothing is there. When this is tested on the internal network, everything appears to be fine. When external users to go https://meet.domain.com it resolves to the Lync web app splash page of "invalid URL" so the DNS is obviously working correctly. Any clues on how to troubleshoot this? I am fairly new to Lync myself and this is my first 2013 deployment. All inner office communications, meeting, video, audio is working just fine.

    Thursday, September 19, 2013 1:33 PM

Answers

  • As you descripted, Lync web app works in internal network while not in external networks. Then this is related with reverse proxy.

    Check the features that require external access through a reverse proxy at

    http://technet.microsoft.com/en-us/library/gg398069.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Kent-Huang Tuesday, October 15, 2013 2:16 AM
    Friday, September 27, 2013 2:54 AM
    Moderator

All replies

  • Please check you have added the simple URL as the SAN in the certificate for reverse proxy.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, September 22, 2013 10:49 AM
    Moderator
  • Lisa,

    Very much appreciate your responding to our question.

    We don't have a reverse proxy setup at this current time and maybe it's something necessary. We do plan on setting up the reverse proxy for security sake, but reading numerous articles state this is optional and can work without it. We also currently are not running an Edge server (don't believe it is necessary for this to work, only for remote connected clients). It may be worth noting, the webapp links work as expected internally, however, they do ask for AD credentials when accessed. That window can be canceled and joined as a guest.

    Currently we have two certificates as follows:

    for reference:

    Internal Domain: sbidomain.com

    External Domain: sbitech.com

    Default Certificate: where the Subject Alternative Name field includes all associated domain names (both external and internal) which include:

    DNS Name=sbilync.sbidomain.com

    DNS Name=www.sbilync.sbidomain.com

    DNS Name=admin.sbidomain.com

    DNS Name=dialin.sbidomain.com

    DNS Name=lync.sbitech.com

    DNS Name=Lyncdiscover.sbidomain.com

    DNS Name=Lyncdiscover.sbitech.com

    DNS Name=LyncdiscoverInternal.sbidomain.com

    DNS Name=LyncdiscoverInternal.sbitech.com

    DNS Name=meet.sbidomain.com

    DNS Name=meet.sbitech.com

    OAuthTokenIssuer: Which SAN includes the following domain names:

    DNS Name=sbidomain.com

    DNS Name=sbitech.com

    Monday, September 23, 2013 2:02 PM
  • As you descripted, Lync web app works in internal network while not in external networks. Then this is related with reverse proxy.

    Check the features that require external access through a reverse proxy at

    http://technet.microsoft.com/en-us/library/gg398069.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Kent-Huang Tuesday, October 15, 2013 2:16 AM
    Friday, September 27, 2013 2:54 AM
    Moderator