none
Call isn't routed to voicemail after 30 seconds

    Question

  • Hi,

    We're having a problem with the call forwarding option to voicemail (Voicemail isExchange UM). If we choose to forward the call to voicemail after 25 seconds or less everything works ok. If we choose to forward the call to voicemail after 30 seconds or more we get a voice message saying something like "the number you’re calling has been changed".

    Does anyone knows about a setting somewhere that disconnects the call after 30 seconds?

    Thursday, February 16, 2012 11:59 AM

Answers

  • Hi,

    Maybe it is a Problem with a seesion timer and you can test this settings:

    The mediation server is configured to use RTCP. Once the gateway receives a=sendonly or a=inactive in the SDP, it doesn't send any media traffic (no RTCP). The server ends the connection with "Rtcp timer is not disabled and Mediation Server encountered a gateway media stream timeout."

    Resolution

    Set the mediation server setting with following switch to disable RTCPActiveCalls and RTCPCallsOnHold.

    Set-CsTrunkConfiguration -RTCPActiveCalls $false -RTCPCallsOnHold $false


    regards Holger Technical Specialist UC

    • Marked as answer by DS_Kevin Tuesday, February 28, 2012 9:22 AM
    Thursday, February 23, 2012 8:25 AM

All replies

  • So you call from a media gateway, can you make a trace on the GW to see whats happend if the GW call will be refered to the Exchange voicemail. Maybe some codec problems.

    regards Holger Technical Specialist UC


    Thursday, February 16, 2012 2:35 PM
  • We're not using a media gateway, mediation server is connected with direct SIP trunk.
    Tuesday, February 21, 2012 9:47 AM
  • OK, may be there is something wrong with the signalling, could you make a trace with the ocslogger tool with Mediationserver, inbound and outboundrouting, S4 and Sipstack to see whats happened with this calls?

    regards Holger Technical Specialist UC

    Tuesday, February 21, 2012 10:14 AM
  • Hi Kevin,

    Any update?

    As I know, on the Mediation Server for Microsoft Office Communications Server 2007 R2, a media time-out will occur if no Real-Time Transport Protocol (RTP) packets or Real-Time Transport Control Protocol (RTCP) packets are received for 30 seconds.

    And here is another post for reference. Have a check, hope it is useful.


    Noya Lau

    TechNet Community Support


    Wednesday, February 22, 2012 8:44 AM
    Moderator
  • Hello,

    Thanks for your suggestions. Unfortunately our client that has the problem is in holiday this week so I can only do some testing starting from next week. As it seems in your post Noya and other sources I've read, this issue is probably due to a setting on the SIP Trunk so I guess I'll have to contact our Sip trunk registrar. I'll keep you updated next week!

    Wednesday, February 22, 2012 12:28 PM
  • Hi,

    Maybe it is a Problem with a seesion timer and you can test this settings:

    The mediation server is configured to use RTCP. Once the gateway receives a=sendonly or a=inactive in the SDP, it doesn't send any media traffic (no RTCP). The server ends the connection with "Rtcp timer is not disabled and Mediation Server encountered a gateway media stream timeout."

    Resolution

    Set the mediation server setting with following switch to disable RTCPActiveCalls and RTCPCallsOnHold.

    Set-CsTrunkConfiguration -RTCPActiveCalls $false -RTCPCallsOnHold $false


    regards Holger Technical Specialist UC

    • Marked as answer by DS_Kevin Tuesday, February 28, 2012 9:22 AM
    Thursday, February 23, 2012 8:25 AM
  • Hi Holger,

    Thanks for your suggestion. The RTCPActiveCalls was indeed the issue. It also resolved our issue with the calls on hold that were also disconnected after 30 seconds. The RTCPCallsOnHold parameter didn't need to be changed to solve the issues so I left this one on true.

    Tuesday, February 28, 2012 9:25 AM