none
Lync 2013 - GMail

    Question

  • Dears,

    I have integrated Lync 2013 with Gmail, it's working except for the presense on Lync side, from GTalk I can see the presense of Lync user, but on the Lync client the presense is always offline.

    Does anyone has an idea of why this is happening?

    Btw the IM is working perfectly

    Wednesday, March 06, 2013 8:06 AM

Answers

All replies

  • Same here with my lync 2013 environment.  Hopefully someone from the forum can assist.

    Wednesday, March 06, 2013 10:57 PM
  • I'm experiencing the same issue.  IM works both ways but I only see presence from the Google Talk client.

    There have been some posts that Google is blocking some XMPP federation as of earlier this week (although not sure why IM would still work but not presence).


    I'm seeing it in multiple Lync 2013 environments so I suspect it's a Google thing.
    Thursday, March 07, 2013 4:08 AM
  • Hi,

    You can enable logging tool to get report to check if there is any error.

    http://blog.schertz.name/2011/06/using-the-lync-logging-tool/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Kent Huang
    TechNet Community Support

    Thursday, March 07, 2013 6:07 AM
  • I have the same issue where presence from Gmail to Lync is not working but vice-Versa is good. IM is also working both ways. I am getting the following in the XMPP logs on the edge server.

    TL_INFO(TF_COMPONENT) [4]167C.1080::03/06/2013-10:02:34.954.00f5c71c (XmppTGWProxy,XmppLogger.LogInfo:1772.idx(32))(0000000001DBE6B4)[SocketEvent] Queued 106 bytes for send [remote=74.125.135.125:5269] [local=10.151.55.11:54048] [pending_bytes:106] [data:<presence from="lsu@contoso.com" id="5ADA3A32E7ADAFAD10000080" to="sandy@gmail.com" type="subscribe" />]

    TL_INFO(TF_COMPONENT) [4]167C.1080::03/06/2013-10:02:34.954.00f5c742 (XmppTGWProxy,XmppLogger.LogInfo:1772.idx(32))(0000000001DBE6B4)[SocketEvent] Sent (tcp) 106 bytes [remote=74.125.135.125:5269] [local=10.151.55.11:54048] [pending_bytes:0]

    TL_INFO(TF_COMPONENT) [4]167C.1344::03/06/2013-10:02:35.001.00f5c76c (XmppTGWProxy,XmppLogger.LogInfo:1772.idx(32))(0000000001DBE6B4)[SocketEvent] Received data [remote=74.125.135.125:5269] [local=10.151.55.11:54048] [data:<presence from="navee@gmail.com" id="21E356C084E2FED80F000080" to="lsu@contoso.com" type="error"><error code="503" type="cancel"><service-unavailable xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/></error></presence>]

    TL_INFO(TF_COMPONENT) [0]167C.1344::03/06/2013-10:02:35.016.00f5c9c1 (XmppTGWProxy,XmppLogger.LogInfo:1772.idx(32))


    • Edited by sandy_live Thursday, March 07, 2013 9:46 AM
    Thursday, March 07, 2013 9:44 AM
  • Duplicate of this thread:  http://social.technet.microsoft.com/Forums/en-US/lyncinterop/thread/7044a255-1c0b-4ce5-98ae-1a277b551873

     

    Might want to keep watch on that one and the Google forum post linked in it.

    • Marked as answer by Kent-Huang Wednesday, March 27, 2013 2:15 AM
    Thursday, March 14, 2013 4:00 AM