none
Web.config file missing

    Question

  • HI, In my organization we started to deploy LYNC 2010,

    In the "Deployment Wizard" -> "Install or Update Lync Server System" -> "Setup or Remove Lync Server Components", When i press "Run" it begin to execute until it throw exception:

    "Executing PowerShell command: Enable-CSComputer -Confirm:$false -Verbose -Report "C:\Users\markm\AppData\Local\Temp\Enable-CSComputer-[2011_10_05][13_41_20].html"
    Command execution failed: Filename: \\?\C:\Program Files\Microsoft Lync Server 2010\Web Components\Internal Website\web.config"

    Error: The configuration section 'system.webServer/rewrite/rules' cannot be read because it is missing a section declaration."

    can you please help me and tell me why is this happening and how can i fix it? thanks liad.

    Wednesday, October 05, 2011 11:54 AM

Answers

All replies

  • hi ,


    Can you check following ,
    • All IIS and .Net prerequisites have been installed on the machine , try to reinstall the same if required .
    • I hope your account got enough permission to install the role .

    Wednesday, October 05, 2011 3:00 PM
  • hi Shaleesh,

    Thank you for the answer,

    I installed all IIS role services and .Net Framework 3.5, reinstall and yet it shows the same error.

    About the permission, i have local admin on the machine and the SQL server.
    I need domain admin for this?

    Wednesday, October 05, 2011 3:30 PM
  • Yes , your account required Domain Admins group or Enterprise Admins group permissions .

    http://technet.microsoft.com/en-us/library/gg412962.aspx

    Wednesday, October 05, 2011 7:48 PM
  • I ran the setup with a domain admin but it didn't work,

    It replies me with the same error ("Error: The configuration section 'system.webServer/rewrite/rules' cannot be read because it is missing a section declaration.").

    What do you think I should do?

    Thursday, October 06, 2011 2:22 PM
  • I hope all prerequsites are in place for lync , like 64 bit hardware and windows 64 Bit edition and .Net etc , it seems like some version mismatch causing the issue .
    Thursday, October 06, 2011 2:52 PM
  • Hi there,

    which version of lync 2010 you are trying to install ?

    did you create a new topology and  install the local configuration store prior running the local setup ?

    regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    Thursday, October 06, 2011 8:02 PM
  • any updates regarding this issue ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    Friday, October 07, 2011 10:58 PM
  • Hi,Liad,

    Can you find the web.config file in the folder Program Files\Microsoft Lync Server 2010\Web Components\Internal Website\web.config?If you can then please check the read-write permission,you should have write permission on it(Also please check the Drive/folder security).Moreover please also verify that you have write permission on your file share folder. 

    If you can't find the web.config file there seems some misconfiguration when you install Lync web components mostly related to IIS ,would you please check if you have installed Windows Process Activation Service?

    If no luck please try to reinstall Lync Web components and IIS with adding Windows Process Activation Service.Otherwise you can manually remove Lync Prior to following these steps, if you have users that were enabled for Lync, go into Control Panel and disable them for Lync.
    1).Run cmd.exe as administrator,run the following command “bootstrapper /scorch” .It should process and show that it completed.
    The scorch process will remove all Lync items from Control Panel.  Should only have the speech server languages if enterprise voice was enabled.
    2). Go into Control Panel and ensure that all Lync items are removed; if not uninstall them.
    3). Remove IIS
    4). Reinstall IIS > make sure to add the WPAS feature (Windows Process Activation Service)
    5). Uninstall IIS Rewriteable from Control Panel
    6). Uninstall SQL to remove RTC and RTC Local databases.
    Note: SQL may fail a few times on the remove.
    7). remove the RTC and RTCLOCAL directories from the Microsoft SQL Server directory.
    8)In ADSIEdit.msc connect to the Configuration naming context and delete the CN=RTC Service folder.
    Note!!: If you have any other OCS or Lync in the forest don’t do this. You will have to remove only the specific items for this server. You can refer the great blog post http://ucmadeeasy.wordpress.com/2010/11/09/lync-server-2010-active-directory-references-and-how-to-remove-them

    Regards,

    Sharon



    Monday, October 10, 2011 8:45 AM
  • Hey everybody,

    I resolve my problem, I reinstall "URL Rewrite" on the FE and it worked.

    http://www.iis.net/download/all

    Thanks for all.

     

    • Marked as answer by Liad Oster Monday, October 10, 2011 12:26 PM
    Monday, October 10, 2011 12:21 PM
  • This worked for me too!

    I ran the Rewrite_2.0_rtw_x64.msi already present in he computer and uninstalled it. Ran the Lync setup again and allowed it to instal it.

    The Lync setup (Step 2) completed successfully and created the Web.config file.

    Thanks to Liad.

    Thursday, October 18, 2012 8:10 PM