none
Cannot Find Reg Key to Disable IM chat.

    Question

  • Hi,

    I am looking to disable this feature for some of our users. I have checked this link and although i am using version 3.5.6907.225

    http://support.microsoft.com/kb/954648/

    I cannot seem to find the local registry key on the PC. Is this PC specific as using a windows 7 machine.

    I am also looking down the route of doing a group policy to disable chat but believe this is not included in the communicator .adm files. Has anyone been successful in anything of the above

     

    Thanks in advance.

    Tuesday, September 13, 2011 5:03 PM

Answers

  • Hi Graham,

    Please configure the DisableIM registry entry as follows.

    1.        Click Start, click Run, type regedit, and then click OK.

    2.        Locate and then click the following registry subkey: HKEY_CURRENT_USER \Software\Policies\Microsoft.

    3.        On the Edit menu, point to New, and then click Key.

    4.        Type Communicator, and then press ENTER.

    5.        On the Edit menu, point to New, and then click DWORD Value.

    6.        Type DisableIM, and then press ENTER.

    7.        Right-click DisableIM, and then click Modify.

    8.        In the Value data box, type 1, and then click OK.

    9.        Exit Registry Editor.

    10.     Start Lync 2010 and have a check.

    Thursday, September 15, 2011 9:36 AM
    Moderator

All replies

  • looks like the key is in: Hkey_current_user\software\microsoft\communicator on Win7

     

    http://blogs.technet.com/b/csps/archive/2011/06/15/regintroduction.aspx



    http://windowspbx.blogspot.com

    Tuesday, September 13, 2011 6:21 PM
  • If you did not define any OCS related policies, than this folder/key will not exist. Only when you enabled some group policy settings for communicator (by example using the ADM file), the folder HKEY_CURRENT_USER \Software\Policies\Microsoft\Communicator will exist.

    I just checked the Communicator 2007 R2 group policy package and you're right it's not in there. You can still create a policy yourself for this using the Group Policy Editor registry options.

    To test you can create this registry key manually on one host.


    Certified IT Professional Lync Server 2010 / Exchange 2007 - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Thursday, September 15, 2011 8:14 AM
  • Hi Graham,

    Please configure the DisableIM registry entry as follows.

    1.        Click Start, click Run, type regedit, and then click OK.

    2.        Locate and then click the following registry subkey: HKEY_CURRENT_USER \Software\Policies\Microsoft.

    3.        On the Edit menu, point to New, and then click Key.

    4.        Type Communicator, and then press ENTER.

    5.        On the Edit menu, point to New, and then click DWORD Value.

    6.        Type DisableIM, and then press ENTER.

    7.        Right-click DisableIM, and then click Modify.

    8.        In the Value data box, type 1, and then click OK.

    9.        Exit Registry Editor.

    10.     Start Lync 2010 and have a check.

    Thursday, September 15, 2011 9:36 AM
    Moderator